libomp-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: OpenMP runtime for clang
  6. Summary(ja): clang用OpenMPランタイム
  7. Name: libomp
  8. Version: 18.1.5
  9. %define shortver %(echo %{version} | cut -d. -f1)
  10. Release: 1%{?_dist_release}
  11. Group: system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: NCSA
  15. URL: https://llvm.org/
  16. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/openmp-%{version}.src.tar.xz
  17. # patches
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: libffi-devel >= 3.3
  22. BuildRequires: elfutils-libelf-devel
  23. BuildRequires: clang-tools-extra
  24. # The AMDGCN device RTL requires clang and llvm-link to build
  25. BuildRequires: clang
  26. BuildRequires: llvm
  27. # libomptarget needs the llvm cmake files
  28. BuildRequires: llvm-devel
  29. BuildRequires: llvm-static
  30. %description
  31. The package contains the OpenMP runtime for clang.
  32. %package devel
  33. Summary: OpenMP header files
  34. Summary(ja): OpenMPヘッダファイル
  35. Group: programming
  36. Requires: clang-devel%{?isa} = %{version}
  37. %description devel
  38. The package contains the OpenMP header files.
  39. %debug_package
  40. %prep
  41. %autosetup -p2 -n openmp-%{version}.src
  42. %build
  43. # LTO causes build failures in this package. Disable LTO for now
  44. %define _lto_cflags %{nil}
  45. %cmake \
  46. -GNinja \
  47. -DLIBOMP_INSTALL_ALIASES=OFF \
  48. -DCMAKE_MODULE_PATH=%{_datadir}/llvm/cmake/Modules \
  49. -DLLVM_DIR=%{_libdir}/cmake/llvm \
  50. -DCMAKE_INSTALL_INCLUDEDIR=%{_libdir}/clang/%{shortver}/include \
  51. %if 0%{?__isa_bits} == 64
  52. -DOPENMP_LIBDIR_SUFFIX=64 \
  53. %else
  54. -DOPENMP_LIBDIR_SUFFIX= \
  55. %endif
  56. -DCMAKE_SKIP_RPATH:BOOL=ON \
  57. -DLIBOMP_HAVE_VERSION_SCRIPT_FLAG:BOOL=ON
  58. %cmake_build
  59. %install
  60. rm -rf %{buildroot}
  61. %cmake_install
  62. # Remove static libraries with equivalent shared libraries
  63. rm -f %{buildroot}%{_libdir}/libarcher_static.a
  64. %if %{with test}
  65. %check
  66. %cmake_build --target check-openmp
  67. %endif
  68. %clean
  69. rm -rf %{buildroot}
  70. %files
  71. %license LICENSE.TXT
  72. %{_libdir}/libarcher.so
  73. %{_libdir}/libomp.so
  74. %{_libdir}/libompd.so
  75. %ifnarch %{ix86} %{arm}
  76. %{_libdir}/libomptarget.so.*
  77. %{_libdir}/libomptarget.rtl.*.so*
  78. %endif
  79. %files devel
  80. %ifnarch %{ix86} %{arm}
  81. %{_libdir}/libomptarget.devicertl.a
  82. %endif
  83. %{_libdir}/clang/%{shortver}/include/omp.h
  84. %{_libdir}/clang/%{shortver}/include/ompx.h
  85. %{_libdir}/clang/%{shortver}/include/omp-tools.h
  86. %{_libdir}/clang/%{shortver}/include/ompt.h
  87. %{_libdir}/clang/%{shortver}/include/ompt-multiplex.h
  88. %{_libdir}/cmake/openmp/FindOpenMPTarget.cmake
  89. %ifnarch %{ix86} %{arm}
  90. %{_libdir}/libomptarget.so
  91. %{_libdir}/libomptarget.rtl.*.so
  92. %{_libdir}/libomptarget-*.bc
  93. %endif
  94. %changelog
  95. * Sat May 04 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 18.1.5-1
  96. - new upstream release.
  97. * Sat Oct 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
  98. - new upstream release.
  99. * Sun Oct 01 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
  100. - new upstream release.
  101. * Mon May 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
  102. - new upstream release.
  103. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  104. - new upstream release.
  105. * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  106. - new upstream release.
  107. * Thu Sep 08 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  108. - new upstream release.
  109. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  110. - new upstream release.
  111. - updated Patch0.
  112. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  113. - new upstream release.
  114. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  115. - new upstream release.
  116. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  117. - new upstream release.
  118. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  119. - devided libomp from llvm.
  120. - new upstream release.
  121. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  122. - enabled to build utils.
  123. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  124. - new upstream release.
  125. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  126. - new upstream release.
  127. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  128. - rebuilt with libffi-3.3.
  129. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  130. - new upstream release.
  131. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  132. - new upstream release.
  133. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  134. - dropped all patches.
  135. - switched build-system to ninja.
  136. - switched python to python3.
  137. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  138. - new upstream release.
  139. - added OpenMP.
  140. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  141. - fixed %%files.
  142. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  143. - new upstream release.
  144. - dropped Patch0, 4, 5, 100 and 200.
  145. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  146. - renamed a subpackage "llvm-libs".
  147. - added a subpackage "lld".
  148. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  149. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  150. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  151. - new upstream release.
  152. - dropped Patch1 and 2: fixed in upstream.
  153. - imported Patch0, 3-5, 100 and 200 from rawhide.
  154. - disabled Patch1002: no longer needed?
  155. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  156. - new upstream release.
  157. - switched to cmake.
  158. - disable ocaml binding as default.
  159. - updated Patch1000 and 1002.
  160. - disabled Patch1000 as default.
  161. - cleanup patches.
  162. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  163. - rebuild with gcc-5.4.0
  164. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  165. - new upstream release
  166. - added BR: ocaml-ctypes
  167. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  168. - new upstream release
  169. - dropt Patch 1, 201 and 1001
  170. - updated Patch 1000
  171. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  172. - updated to 3.5.1
  173. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  174. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  175. - obsoleted clang-doc
  176. - built with ocaml 4.02.1
  177. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  178. - fix <BTS:2832>
  179. - fix configure option "--with-c-include-dirs"
  180. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  181. - update Patch1001: clang-3.5.0-driver-lib64.patch
  182. - update Patch1002: clang-3.5.0-driver-vine.patch
  183. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  184. - update to 3.5.0
  185. - remove Patch11 (clang-hardfloat-hack.patch)
  186. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  187. - rebuild with libffi-3.0.13
  188. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  189. - update to 3.3
  190. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  191. - ld.gold (patch1000,1001)
  192. - add /%{_lib} to ld search path
  193. - add support *-vine-linux gcc (patch1002)
  194. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  195. - update to 3.1
  196. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  197. - updated to 3.0 release
  198. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  199. - added patch 2-4 to support -O4 link-time optimization
  200. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  201. - disable -fno-var-tracking-assignments on ppc
  202. (seems like gcc-4.4.5 still doesn't support this)
  203. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  204. - new upstream release
  205. - add BR: libffi-devel
  206. - add R: libffi-devel to -devel
  207. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  208. - initial build for Vine Linux
  209. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  210. - Update to final 2.7 release
  211. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  212. - Update to first 2.7 pre-release
  213. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  214. - Update to 2.6 pre-release2
  215. - -devel subpackage now virtually provides -static
  216. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  217. - Disable var tracking assignments on PPC
  218. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  219. - Don't adjust clang include dir; files there are noarch (bz#521893)
  220. - Enable clang unit tests
  221. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  222. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  223. - Package Clang's static analyzer tools
  224. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  225. - PIC is now enabled by default; explicitly disable on %%{ix86}
  226. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  227. - First 2.6 prerelease
  228. - Enable Clang front-end
  229. - Enable debuginfo generation
  230. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  231. - Disable assertions (needed by OpenGTL, bz#521261)
  232. - Align spec file with upstream build instructions
  233. - Enable unit tests
  234. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  235. - Only disable PIC on %%ix86; ppc actually needs it
  236. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  237. - Disable use of position-independent code on 32-bit platforms
  238. (buggy in LLVM <= 2.5)
  239. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  240. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  241. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  242. - Remove build scripts; they require the build directory to work
  243. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  244. - Update to 2.5
  245. - Package build scripts (bug #457881)
  246. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  247. - Patched build process for the OCaml binding
  248. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  249. - Update to 2.4
  250. - Package Ocaml binding
  251. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  252. - Add dependency on groff
  253. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  254. - LLVM 2.3
  255. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  256. - fix license tags
  257. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  258. - Fix compilation problems with gcc 4.3
  259. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  260. - Autorebuild for GCC 4.3
  261. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  262. - Fix review comments
  263. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  264. - Initial version