libffi-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Foreign function interface library
  3. Summary(ja): Foreign function interface ライブラリ
  4. Name: libffi
  5. Version: 3.4.6
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: Distributable
  11. URL: http://sourceware.org/libffi/
  12. Source0: https://github.com/libffi/libffi/releases/download/v%{version}/%{name}-%{version}.tar.gz
  13. BuildRequires: gcc
  14. BuildRequires: texinfo
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. %description
  17. A foreign function interface is the popular name for the interface
  18. that allows code written in one language to call code written in
  19. another language.
  20. %description -l ja
  21. Foreign function interface は一般に普及しているインターフェイスで、
  22. ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
  23. とを可能にします。
  24. #-----------------------------------------------------------------------------
  25. %package devel
  26. Summary: Libraries and headers for %{name}
  27. Summary(ja): %{name} 用の開発ライブラリおよびヘッダファイル
  28. Group: programmming
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: pkgconfig
  31. %description devel
  32. This package includes the files needed for developing and compiling
  33. applications which use the ffi library.
  34. You should install the libffi-devel package if you would like to
  35. develop applications using libffi.
  36. %description devel -l ja
  37. このパッケージは ffi ライブラリを使用するアプリケーションを開発
  38. するのに必要なライブラリやヘッダファイルを含んでいます。
  39. libffi を使用したアプリケーションを開発するなら、このパッケージ
  40. をインストールしてください。
  41. #-----------------------------------------------------------------------------
  42. %package static
  43. Summary: Static libraries for %{name}
  44. Summary(ja): %{name} の静的ライブラリ
  45. Group: programmming
  46. Requires: %{name}-devel = %{version}-%{release}
  47. %description static
  48. This package includes the static library of libffi.
  49. %description static -l ja
  50. このパッケージは ffi ライブラリの静的ライブラリを含んでいます。
  51. #-----------------------------------------------------------------------------
  52. #compat32
  53. %package -n compat32-%{name}
  54. Summary: Foreign function interface library
  55. Summary(ja): Foreign function interface ライブラリ
  56. Group: system,legacy
  57. Requires: %{name} = %{version}
  58. %description -n compat32-%{name}
  59. A foreign function interface is the popular name for the interface
  60. that allows code written in one language to call code written in
  61. another language.
  62. %description -n compat32-%{name} -l ja
  63. Foreign function interface は一般に普及しているインターフェイスで、
  64. ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
  65. とを可能にします。
  66. #-----------------------------------------------------------------------------
  67. %package -n compat32-%{name}-devel
  68. Summary: Libraries and headers for %{name}
  69. Summary(ja): %{name} 用の開発ライブラリおよびヘッダファイル
  70. Group: programming,legacy
  71. Requires: compat32-%{name} = %{version}
  72. Requires: %{name}-devel = %{version}
  73. %description -n compat32-%{name}-devel
  74. This package includes the files needed for developing and compiling
  75. applications which use the ffi library.
  76. You should install the libffi-devel package if you would like to
  77. develop applications using libffi.
  78. %description -n compat32-%{name}-devel -l ja
  79. このパッケージは ffi ライブラリを使用するアプリケーションを開発
  80. するのに必要なライブラリやヘッダファイルを含んでいます。
  81. libffi を使用したアプリケーションを開発するなら、このパッケージ
  82. をインストールしてください。
  83. #-----------------------------------------------------------------------------
  84. %prep
  85. %setup -q
  86. sed -i -e 's/{toolexeclibdir}/{libdir}/' libffi.pc.in
  87. %build
  88. autoreconf -ifv
  89. %configure
  90. %{__make}
  91. %install
  92. %{__rm} -rf ${RPM_BUILD_ROOT}
  93. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  94. # remove unnecessary files.
  95. %{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
  96. %{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
  97. %clean
  98. %{__rm} -rf ${RPM_BUILD_ROOT}
  99. %post -p /sbin/ldconfig
  100. %postun -p /sbin/ldconfig
  101. %files
  102. %defattr(-,root,root)
  103. %license LICENSE
  104. %doc ChangeLog* README*
  105. %{_libdir}/libffi.so.*
  106. %files devel
  107. %defattr(-,root,root)
  108. %{_libdir}/pkgconfig/*
  109. %{_libdir}/libffi.so
  110. %{_includedir}/*.h
  111. %{_infodir}/libffi.info*
  112. %{_mandir}/man3/*.3*
  113. %files static
  114. %defattr(-,root,root)
  115. %{_libdir}/libffi.a
  116. # compat32
  117. %if %{build_compat32}
  118. %files -n compat32-%{name}
  119. %defattr(-,root,root)
  120. %{_libdir}/libffi.so.*
  121. %files -n compat32-%{name}-devel
  122. %defattr(-,root,root)
  123. %{_libdir}/libffi.so
  124. %endif
  125. %changelog
  126. * Sat May 04 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.6-1
  127. - updated to 3.4.6.
  128. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
  129. - updated to 3.3.
  130. - dropped Patch0.
  131. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
  132. - updated to 3.2.1.
  133. - imported Patch0 from rawhide.
  134. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.13-1
  135. - update to 3.0.13
  136. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-4
  137. - create compat32 sub packages
  138. * Fri Nov 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.9-3
  139. - fixed includedir in libffi.pc
  140. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 3.0.9-2
  141. - build with rpm-4.8.1-1 for pkg-config file
  142. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0.9-1
  143. - new upstream release
  144. - built with new toolchain
  145. * Wed Jan 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.8-1
  146. - new upstream release
  147. - spec in UTF-8
  148. * Thu Apr 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.5-1
  149. - updated to new upstream release
  150. * Wed Apr 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-1
  151. - apply new versioning policy
  152. * Sun Mar 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-0vl1
  153. - initial build for Vine Linux