123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- Summary: Double-Array Trie Library
- Name: libdatrie
- Version: 0.2.13
- Release: 1%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: GPLv2
- URL: https://linux.thai.net/~thep/datrie/datrie.html
- Source0: https://github.com/tlwg/libdatrie/releases/download/v%{version}/%{name}-%{version}.tar.xz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: doxygen
- %description
- This is an implementation of double-array structure for representing trie,
- as proposed by Junichi Aoe.
- Trie is a kind of digital search tree, an efficient indexing method with
- O(1) time complexity for searching. Comparably as efficient as hashing,
- trie also provides flexibility on incremental matching and key spelling
- manipulation. This makes it ideal for lexical analyzers, as well as spelling
- dictionaries.
- %package devel
- Summary: Development tools for libdatrie
- Summary(ja): libdatrie の開発環境
- Group: programming
- Requires: %{name} = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- Header files and libraries for building a extension library for the
- libdatrie.
- %package docs
- Summary: Documentation for libdatrie
- Summary(ja): libdatrie 用のドキュメント
- Group: documentation
- Requires: %{name} = %{version}-%{release}
- BuildArch: noarch
- Provides: %{name}-doc = %{version}-%{release}
- %description docs
- This package contains documentation for libdatrie
- # compat32
- %package -n compat32-%{name}
- Summary: Double-Array Trie Library
- Group: system,legacy
- Requires: %{name} = %{version}-%{release}
- %description -n compat32-%{name}
- This is an implementation of double-array structure for representing trie,
- as proposed by Junichi Aoe.
- Trie is a kind of digital search tree, an efficient indexing method with
- O(1) time complexity for searching. Comparably as efficient as hashing,
- trie also provides flexibility on incremental matching and key spelling
- manipulation. This makes it ideal for lexical analyzers, as well as spelling
- dictionaries.
- %package -n compat32-%{name}-devel
- Summary: Development tools for libdatrie
- Summary(ja): libdatrie の開発環境
- Group: programming,legacy
- Requires: compat32-%{name} = %{version}-%{release}
- Requires: pkgconfig
- %description -n compat32-%{name}-devel
- Header files and libraries for building a extension library for the
- libdatrie.
- %debug_package
- %prep
- %setup -q
- %build
- %configure \
- --disable-static
- %{__make} %{?_smp_mflags}
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__make} install DESTDIR=${RPM_BUILD_ROOT}
- find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
- find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %files
- %defattr(-,root,root,-)
- %license COPYING
- %doc AUTHORS ChangeLog NEWS README
- %{_bindir}/trietool
- %{_bindir}/trietool-0.2
- %{_libdir}/%{name}.so.*
- %{_mandir}/man1/*.gz
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/datrie
- %{_libdir}/%{name}.so
- %{_libdir}/pkgconfig/datrie-0.2.pc
- %files docs
- %defattr(-,root,root,-)
- %doc README.migration
- %doc %{_docdir}/datrie/html
- %if %{build_compat32}
- %files -n compat32-%{name}
- %defattr(-, root, root,-)
- %{_libdir}/%{name}.so.*
- %files -n compat32-%{name}-devel
- %defattr(-, root, root,-)
- %{_libdir}/%{name}.so
- %endif
- %changelog
- * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.13-1
- - new upstream release.
- - dropped scriptlets.
- * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.10-1
- - new upstream release
- * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.8-1
- - new upstream release
- * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.7.1-1
- - new upstream release
- * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.6-1
- - update to 0.2.6
- * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-2
- - remove *.pc from compat32-%{name}-devel
- - fix typo
- * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-1
- - initial build for Vine Linux
|