123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153 |
- # Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
- # Copyright (c) 2007 Hans de Goede <j.w.r.degoede@hhs>, the Fedora project.
- #
- # This file and all modifications and additions to the pristine
- # package are under the same license as the package itself.
- Name: i2c-tools
- Version: 4.3
- Release: 1%{?_dist_release}
- Summary: A heterogeneous set of I2C tools for Linux
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: GPLv2+
- URL: https://i2c.wiki.kernel.org/index.php/I2C_Tools
- Source0: https://mirrors.edge.kernel.org/pub/software/utils/i2c-tools/%{name}-%{version}.tar.xz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- # for /etc/udev/makedev.d resp /etc/modprobe.d ownership
- Requires: udev kmod
- ExcludeArch: s390 s390x
- %description
- This package contains a heterogeneous set of I2C tools for Linux: a bus
- probing tool, a chip dumper, register-level access helpers, EEPROM
- decoding scripts, and more.
- %package -n python3-smbus
- Summary: Python module for SMBus access via I2C
- Group: programming
- BuildRequires: python-rpm-macros
- BuildRequires: python3-rpm-macros
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- Requires: python3
- %description -n python3-smbus
- This Python module allows SMBus access through the I2C /dev interface
- on Linux hosts. The host kernel must have I2C support, I2C device
- interface support, and a bus adapter driver.
- %debug_package
- %prep
- %setup -q
- %build
- make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" BUILD_STATIC_LIB=0 EXTRA=eeprog
- pushd py-smbus
- CFLAGS="$RPM_OPT_FLAGS -I../include" LDFLAGS="$RPM_LD_FLAGS" \
- %{__python3} setup.py build -b build-py3
- popd
- %install
- make install DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix} BUILD_STATIC_LIB=0 \
- EXTRA=eeprog libdir=%{_libdir}
- pushd py-smbus
- %{__python3} setup.py build -b build-py3 install --skip-build --root=$RPM_BUILD_ROOT
- popd
- # cleanup
- rm -f $RPM_BUILD_ROOT%{_bindir}/decode-edid.pl
- # Remove unpleasant DDC tools. KMS already exposes the EDID block in sysfs,
- # and edid-decode is a more complete tool than decode-edid.
- rm -f $RPM_BUILD_ROOT%{_bindir}/{ddcmon,decode-edid}
- # for i2c-dev ondemand loading through kmod
- mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/modprobe.d
- echo "alias char-major-89-* i2c-dev" > \
- $RPM_BUILD_ROOT%{_prefix}/lib/modprobe.d/i2c-dev.conf
- # for /dev/i2c-# creation (which are needed for kmod i2c-dev autoloading)
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/makedev.d
- for (( i = 0 ; i < 8 ; i++ )) do
- echo "i2c-$i" >> $RPM_BUILD_ROOT%{_sysconfdir}/udev/makedev.d/99-i2c-dev.nodes
- done
- # auto-load i2c-dev after reboot
- mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/modules-load.d
- echo 'i2c-dev' > $RPM_BUILD_ROOT%{_prefix}/lib/modules-load.d/%{name}.conf
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %license COPYING*
- %doc CHANGES README
- %config(noreplace) %{_prefix}/lib/modprobe.d/i2c-dev.conf
- %config(noreplace) %{_sysconfdir}/udev/makedev.d/99-i2c-dev.nodes
- %{_sbindir}/i2c*
- %{_sbindir}/eeprog
- %exclude %{_sbindir}/i2c-stub*
- %{_mandir}/man8/i2c*.8.*
- %{_mandir}/man8/eeprog.8.*
- %exclude %{_bindir}/decode-*
- %exclude %{_mandir}/man1/decode-*.1.*
- %exclude %{_mandir}/man8/i2c-stub-from-dump.8.*
- %{_prefix}/lib/modules-load.d/%{name}.conf
- %{_libdir}/libi2c.so.0*
- %dir %{_includedir}/i2c
- %{_includedir}/i2c/smbus.h
- %{_libdir}/libi2c.so
- %{_mandir}/man3/libi2c.3.*
- %files -n python3-smbus
- %defattr(0644,root,root,0755)
- %doc py-smbus/README
- %{python3_sitearch}/*
- %changelog
- * Tue Oct 03 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3-1
- - new upstream release.
- * Sun Feb 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.0.2-2
- - added smbus-python package
- * Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-1
- - initial build for Vine Linux
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Mon Apr 13 2009 Adam Jackson <ajax@redhat.com> 3.0.2-3
- - mv /etc/modprobe.d/i2c-dev /etc/modprobe.d/i2c-dev.conf (#495455)
- * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Thu Dec 11 2008 Adam Jackson <ajax@redhat.com> 3.0.2-1
- - i2c-tools 3.0.2
- * Wed Mar 5 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-3
- - Change /dev/i2c-# creation from /lib/udev/devices to /etc/udev/makedev.d
- usage
- - Add an /etc/modprobe.d/i2c-dev file to work around bug 380971
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.0-2
- - Autorebuild for GCC 4.3
- * Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-1
- - Initial Fedora package, based on Suse specfile
- * Mon Oct 15 2007 - jdelvare@suse.de
- - Initial release.
|