elfutils-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global nocheck false
  3. Summary: A collection of utilities and DSOs to handle compiled objects
  4. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  5. Name: elfutils
  6. Version: 0.191
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+ and (GPLv2+ or LGPLv3+) and GFDL
  12. URL: https://sourceware.org/elfutils/
  13. Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
  14. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  15. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: bison >= 1.875
  18. BuildRequires: flex >= 2.5.4a
  19. BuildRequires: gcc >= 9.0.0
  20. BuildRequires: gettext
  21. BuildRequires: m4
  22. BuildRequires: bzip2-devel
  23. BuildRequires: libzstd-devel
  24. BuildRequires: xz-devel
  25. BuildRequires: pkgconfig(zlib)
  26. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  27. BuildRequires: glibc-headers >= 2.3.4-11
  28. BuildRequires: bzip2
  29. BuildRequires: zstd
  30. %define _gnu %{nil}
  31. %define _program_prefix eu-
  32. %description
  33. Elfutils is a collection of utilities, including ld (a linker),
  34. nm (for listing symbols from object files), size (for listing the
  35. section sizes of an object or archive file), strip (for discarding
  36. symbols), readelf (to see the raw ELF file structures), and elflint
  37. (to check for well-formed ELF files).
  38. %package libs
  39. Summary: Libraries to handle compiled objects
  40. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  41. License: GPLv2+ or LGPLv3+
  42. Group: system
  43. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  44. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  45. Conflicts: elfutils < %{version}-%{release}
  46. Conflicts: elfutils > %{version}-%{release}
  47. Conflicts: elfutils-devel < %{version}-%{release}
  48. Conflicts: elfutils-devel > %{version}-%{release}
  49. %description libs
  50. The elfutils-libs package contains libraries which implement DWARF, ELF,
  51. and machine-specific ELF handling. These libraries are used by the programs
  52. in the elfutils package. The elfutils-devel package enables building
  53. other programs using these libraries.
  54. %package devel
  55. Summary: Development libraries to handle compiled objects
  56. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  57. License: GPLv2+ or LGPLv3+
  58. Group: programming
  59. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  60. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  61. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  62. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  63. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  64. %description devel
  65. The elfutils-devel package contains the libraries to create
  66. applications for handling compiled objects. libebl provides some
  67. higher-level ELF access functionality. libdw provides access to
  68. the DWARF debugging information. libasm provides a programmable
  69. assembler interface.
  70. %package devel-static
  71. Summary: Static archives to handle compiled objects
  72. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  73. License: GPLv2+ or LGPLv3+
  74. Group: programming
  75. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  76. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  77. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  78. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  79. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  80. %description devel-static
  81. The elfutils-devel-static package contains the static archives
  82. with the code to handle compiled objects.
  83. %package libelf
  84. Summary: Library to read and write ELF files
  85. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  86. License: GPLv2+ or LGPLv3+
  87. Group: system
  88. Provides: libelf = %{version}-%{release}
  89. Obsoletes: libelf <= 0.8.2-2
  90. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  91. Conflicts: elfutils < %{version}-%{release}
  92. Conflicts: elfutils > %{version}-%{release}
  93. Conflicts: elfutils-libs < %{version}-%{release}
  94. Conflicts: elfutils-libs > %{version}-%{release}
  95. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  96. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  97. %description libelf
  98. The elfutils-libelf package provides a DSO which allows reading and
  99. writing ELF files on a high level. Third party programs depend on
  100. this package to read internals of ELF files. The programs of the
  101. elfutils package use it also to generate new ELF files.
  102. %package libelf-devel
  103. Summary: Development support for libelf
  104. Summary(ja): libelf の開発用ライブラリ
  105. License: GPLv2+ or LGPLv3+
  106. Group: programming
  107. Provides: libelf-devel = %{version}-%{release}
  108. Obsoletes: libelf-devel <= 0.8.2-2
  109. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  110. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  111. Conflicts: libelf-devel < %{version}-%{release}
  112. %description libelf-devel
  113. The elfutils-libelf-devel package contains the libraries to create
  114. applications for handling compiled objects. libelf allows you to
  115. access the internals of the ELF object file format, so you can see the
  116. different sections of an ELF file.
  117. %package libelf-devel-static
  118. Summary: Static archive of libelf
  119. Summary(ja): libelf の静的ライブラリ
  120. License: GPLv2+ or LGPLv3+
  121. Group: programming
  122. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  123. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  124. %description libelf-devel-static
  125. The elfutils-libelf-static package contains the static archive
  126. for libelf.
  127. # compat32
  128. %package -n compat32-%{name}-libelf
  129. Summary: Library to read and write ELF files
  130. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  131. License: GPLv2+ or LGPLv3+
  132. Group: system,legacy
  133. Provides: compat32-libelf = %{version}-%{release}
  134. %description -n compat32-%{name}-libelf
  135. The elfutils-libelf package provides a DSO which allows reading and
  136. writing ELF files on a high level. Third party programs depend on
  137. this package to read internals of ELF files. The programs of the
  138. elfutils package use it also to generate new ELF files.
  139. %debug_package
  140. %prep
  141. %setup -q
  142. autoreconf -f -v -i
  143. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  144. # disable some tests
  145. sed -i -e 's/check_native.*$/exit 0/' \
  146. tests/run-backtrace-native.sh \
  147. tests/run-backtrace-native-biarch.sh \
  148. tests/run-backtrace-native-core.sh \
  149. tests/run-backtrace-native-core-biarch.sh \
  150. %{nil}
  151. %build
  152. # This package uses top level ASM constructs which are incompatible with LTO.
  153. # Top level ASMs are often used to implement symbol versioning. gcc-10
  154. # introduces a new mechanism for symbol versioning which works with LTO.
  155. # Converting packages to use that mechanism instead of toplevel ASMs is
  156. # recommended.
  157. # Disable LTO
  158. %define _lto_cflags %{nil}
  159. # Remove -Wall from default flags. The makefiles enable enough warnings
  160. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  161. # the makefiles disable some specific warnings for specific code.
  162. # But add -Wformat explicitly for use with -Werror=format-security which
  163. # doesn't work without -Wformat (enabled by -Wall).
  164. RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
  165. RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
  166. %configure \
  167. CFLAGS="$RPM_OPT_FLAGS -fexceptions" \
  168. --disable-debuginfod \
  169. --disable-libdebuginfod
  170. make -s %{?_smp_mflags}
  171. %install
  172. rm -rf ${RPM_BUILD_ROOT}
  173. make -s install DESTDIR=${RPM_BUILD_ROOT}
  174. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  175. %find_lang %{name}
  176. # XXX Nuke unpackaged files
  177. { cd ${RPM_BUILD_ROOT}
  178. rm -f .%{_bindir}/eu-ld
  179. }
  180. # failed on i686 container hosted by x86_64
  181. %ifarch x86_64
  182. %check
  183. %make_build -s check || (cat tests/test-suite.log; %{nocheck})
  184. %endif
  185. %clean
  186. rm -rf ${RPM_BUILD_ROOT}
  187. %files -f %{name}.lang
  188. %defattr(-,root,root)
  189. %license COPYING COPYING-GPLV2 COPYING-LGPLV3 doc/COPYING-GFDL
  190. %doc README TODO CONTRIBUTING
  191. %{_bindir}/eu-addr2line
  192. %{_bindir}/eu-ar
  193. %{_bindir}/eu-elfclassify
  194. %{_bindir}/eu-elfcmp
  195. %{_bindir}/eu-elflint
  196. %{_bindir}/eu-findtextrel
  197. %{_bindir}/eu-nm
  198. %{_bindir}/eu-objdump
  199. %{_bindir}/eu-ranlib
  200. %{_bindir}/eu-readelf
  201. %{_bindir}/eu-size
  202. %{_bindir}/eu-srcfiles
  203. %{_bindir}/eu-stack
  204. %{_bindir}/eu-strings
  205. %{_bindir}/eu-strip
  206. #%{_bindir}/eu-ld
  207. %{_bindir}/eu-unstrip
  208. %{_bindir}/eu-make-debug-archive
  209. %{_bindir}/eu-elfcompress
  210. %{_mandir}/man1/eu-*
  211. %files libs
  212. %defattr(-,root,root)
  213. %license COPYING-GPLV2 COPYING-LGPLV3
  214. %{_libdir}/libasm-%{version}.so
  215. %{_libdir}/libasm.so.*
  216. %{_libdir}/libdw-%{version}.so
  217. %{_libdir}/libdw.so.*
  218. %files devel
  219. %defattr(-,root,root)
  220. %{_includedir}/dwarf.h
  221. %dir %{_includedir}/elfutils
  222. %{_includedir}/elfutils/elf-knowledge.h
  223. %{_includedir}/elfutils/known-dwarf.h
  224. %{_includedir}/elfutils/libasm.h
  225. %{_includedir}/elfutils/libdw.h
  226. %{_includedir}/elfutils/libdwelf.h
  227. %{_includedir}/elfutils/libdwfl.h
  228. %{_includedir}/elfutils/version.h
  229. %{_libdir}/libasm.so
  230. %{_libdir}/libdw.so
  231. %{_libdir}/pkgconfig/libdw.pc
  232. %files devel-static
  233. %defattr(-,root,root)
  234. %{_libdir}/libasm.a
  235. %{_libdir}/libdw.a
  236. %files libelf
  237. %defattr(-,root,root)
  238. %{_libdir}/libelf-%{version}.so
  239. %{_libdir}/libelf.so.*
  240. %files libelf-devel
  241. %defattr(-,root,root)
  242. %{_includedir}/libelf.h
  243. %{_includedir}/gelf.h
  244. %{_includedir}/nlist.h
  245. %{_libdir}/libelf.so
  246. %{_libdir}/pkgconfig/libelf.pc
  247. %{_mandir}/man3/elf_*
  248. %files libelf-devel-static
  249. %defattr(-,root,root)
  250. %{_libdir}/libelf.a
  251. %if %{build_compat32}
  252. %files -n compat32-%{name}-libelf
  253. %defattr(-,root,root)
  254. %{_libdir}/libelf-%{version}.so
  255. %{_libdir}/libelf.so.*
  256. %endif
  257. %changelog
  258. * Sun Jun 09 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.191-1
  259. - new upstream release.
  260. * Fri Sep 22 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.189-1
  261. - new upstream release.
  262. * Sat Sep 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.187-1
  263. - new upstream release.
  264. * Thu Aug 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.185-1
  265. - new upstream release.
  266. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-2
  267. - rebuilt with current environment.
  268. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-1
  269. - new upstream release.
  270. * Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.177-1
  271. - new upstream release.
  272. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-3
  273. - rebuilt
  274. - 2vl7 was skipped (used for vl6)
  275. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
  276. - updated to 0.170.
  277. - dropped all patches.
  278. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
  279. - rebuild with gcc-5.4.0
  280. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  281. - create compat32-elfutils-libelf subpackage
  282. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  283. - update to 0.161
  284. - added Japanese summary
  285. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  286. - update to 0.157
  287. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  288. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  289. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  290. - update to 0.152
  291. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  292. - elfutils-libs: changed Group to System Environment/Libraries
  293. - elfutils-libelf: changed Group to System Environment/Libraries
  294. - elfutils-devel: changed Group to Development/Libraries
  295. - elfutils-devel-static: changed Group to Development/Libraries
  296. - elfutils-libelf-devel: changed Group to Development/Libraries
  297. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  298. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  299. - merged with Fedora 9 0.135-1
  300. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  301. - applied new versioning policy
  302. - added elfutils-0.131-readelf_c.patch
  303. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  304. - new upstream release
  305. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  306. - remove Obsoletes: libelf, libelf-devel from elfutils
  307. - add Obsoletes: libelf to elfutils-libelf
  308. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  309. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  310. - Update to 0.135
  311. - libdwfl: bug fixes
  312. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  313. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  314. - Update to 0.134
  315. - elflint: backend improvements for sparc, alpha (#204170)
  316. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  317. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  318. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  319. - Update to 0.133
  320. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  321. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  322. - libdwfl: bug fixes and optimization in relocation handling
  323. - elfcmp: bug fix for non-allocated section handling
  324. - ld: implement newer features of binutils linker.
  325. - Install eu-objdump and libasm, now has limited disassembler support.
  326. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  327. - Update to 0.132
  328. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  329. - eu-readelf: Fix handling of ET_REL files in archives.
  330. - libcpu: Implement x86 and x86-64 disassembler.
  331. - libasm: Add interface for disassembler.
  332. - all programs: add debugging of branch prediction.
  333. - libelf: new function elf_scnshndx.
  334. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  335. - Update to 0.131
  336. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  337. bug fixes for oddly-formatted DWARF
  338. - libdwfl: bug fixes in offline archive support, symbol table handling;
  339. apply partial relocations for dwfl_module_address_section on ET_REL
  340. - libebl: powerpc backend support for Altivec registers
  341. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  342. - Fix ET_REL support.
  343. - Fix odd indentation in eu-readelf -x output.
  344. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  345. - Update to 0.130
  346. - eu-readelf -p option can take an argument like -x for one section
  347. - eu-readelf --archive-index (or -c)
  348. - eu-readelf -n improved output for core dumps
  349. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  350. - eu-elflint: ditto
  351. - eu-elflint: stricter checks on debug sections
  352. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  353. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  354. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  355. - libebl: backend improvements (#324031)
  356. - libdwfl: build_id support, new functions for it
  357. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  358. - libdwfl offline archive support, new script eu-make-debug-archive
  359. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  360. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  361. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  362. - Update to 0.129
  363. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  364. - addr2line: new option --symbols (or -S)
  365. - libdw: dwarf_getscopes fixes (#230235)
  366. - libdwfl: dwfl_module_addrsym fixes (#249490)
  367. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  368. - Update to 0.128
  369. - new program: unstrip
  370. - elfcmp: new option --hash-inexact
  371. - Replace Conflicts: with Provides/Requires using -arch
  372. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  373. - Update to 0.127
  374. - libdw: new function dwarf_getsrcdirs
  375. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  376. dwfl_module_address_section
  377. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  378. - Update to 0.126
  379. - New program eu-ar.
  380. - libdw: fix missing dwarf_getelf (#227206)
  381. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  382. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  383. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  384. - Fix overeager warn_unused_result build failures.
  385. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  386. - Update to 0.125
  387. - elflint: Compare DT_GNU_HASH tests.
  388. - move archives into -static RPMs
  389. - libelf, elflint: better support for core file handling
  390. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  391. - Resolves: RHBZ #220817, RHBZ #213792
  392. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  393. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  394. - Update to 0.124
  395. - libebl: fix ia64 reloc support (#206981)
  396. - libebl: sparc backend support for return value location
  397. - libebl, libdwfl: backend register name support extended with more info
  398. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  399. - readelf, elflint: trivial bugs fixed
  400. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  401. - Update to 0.123
  402. - libebl: Backend build fixes, thanks to Stepan Kasal.
  403. - libebl: ia64 backend support for register names, return value location
  404. - libdwfl: Handle truncated linux kernel module section names.
  405. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  406. - elflint: Fix checks to permit --hash-style=gnu format.
  407. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  408. - Fix warnings in elflint compilation.
  409. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  410. - Update to 0.122
  411. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  412. - libebl: add function to test for relative relocation
  413. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  414. - elflint, readelf: add support for DT_GNU_HASH
  415. - libelf: add elf_gnu_hash
  416. - elflint, readelf: add support for 64-bit SysV-style hash tables
  417. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  418. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  419. - Update to 0.121
  420. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  421. - make all installed headers usable in C++ code (#193153).
  422. - eu-readelf: better output format.
  423. - eu-elflint: fix tests of dynamic section content.
  424. - libdw, libdwfl: handle files without aranges info.
  425. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  426. - rebuild to pick up -devel deps
  427. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  428. - Update to 0.120
  429. - License changed to GPL, with some exceptions for using
  430. the libelf, libebl, libdw, and libdwfl library interfaces.
  431. Red Hat elfutils is an included package of the Open Invention Network.
  432. - dwarf.h updated for DWARF 3.0 final specification.
  433. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  434. - libdwfl: New function dwfl_version; fixes for offline.
  435. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  436. - bump again for double-long bug on ppc(64)
  437. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  438. - rebuilt for new gcc4.1 snapshot and glibc changes
  439. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  440. - update to 0.119
  441. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  442. - rebuilt
  443. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  444. - update to 0.118
  445. - elflint: more tests.
  446. - libdwfl: New function dwfl_module_register_names.
  447. - libebl: New backend hook for register names.
  448. - Make sure -fexceptions is always in CFLAGS.
  449. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  450. - update to 0.117
  451. - libdwfl: New function dwfl_module_return_value_location (#166118)
  452. - libebl: Backend improvements for several CPUs
  453. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  454. - update to 0.116
  455. - libdw fixes, API changes and additions
  456. - libdwfl fixes (#169672)
  457. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  458. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  459. - Update requires/conflicts for better biarch update behavior.
  460. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  461. - update to 0.115
  462. - New program eu-strings.
  463. - libdw: New function dwarf_getscopes_die.
  464. - libelf: speed-ups of non-mmap reading.
  465. - Implement --enable-gcov option for configure.
  466. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  467. - update to 0.114
  468. - new program eu-ranlib
  469. - libdw: new calls for inlines
  470. - libdwfl: new calls for offline modules
  471. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  472. - update to 0.113
  473. - elflint: relax a bit. Allow version definitions for defined symbols
  474. against DSO versions also for symbols in nobits sections.
  475. Allow .rodata section to have STRINGS and MERGE flag set.
  476. - strip: add some more compatibility with binutils.
  477. - libdwfl: bug fixes.
  478. - Separate libdw et al into elfutils-libs subpackage.
  479. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  480. - update to 0.112
  481. - elfcmp: some more relaxation.
  482. - elflint: many more tests, especially regarding to symbol versioning.
  483. - libelf: Add elfXX_offscn and gelf_offscn.
  484. - libasm: asm_begin interface changes.
  485. - libebl: Add three new interfaces to directly access machine, class,
  486. and data encoding information.
  487. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  488. - update portability patch
  489. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  490. - update to 0.111
  491. - libdwfl library now merged into libdw
  492. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  493. - update to 0.110
  494. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  495. - update to 0.109
  496. - verify that libebl modules are from the same build
  497. - new eu-elflint checks on copy relocations
  498. - new program eu-elfcmp
  499. - new experimental libdwfl library
  500. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  501. - robustification of eu-strip and eu-readelf
  502. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  503. - more robustification
  504. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  505. - robustification
  506. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  507. - update to 0.108
  508. - merge strip fixes
  509. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  510. - update elf.h from glibc
  511. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  512. - fix strip -f byte-swapping bug
  513. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  514. - update to 0.107
  515. - readelf: improve DWARF output format
  516. - elflint: -d option to support checking separate debuginfo files
  517. - strip: fix ET_REL debuginfo files (#156341)
  518. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  519. - fix some bugs in new code, reenable make check
  520. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  521. - disable make check for most arches, for now
  522. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  523. - update to 0.106
  524. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  525. - update to 0.104
  526. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  527. - update to 0.103
  528. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  529. - update to 0.101.
  530. - use %%configure macro to get CFLAGS etc. right
  531. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  532. - upgrade to 0.99.
  533. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  534. - upgrade to 0.97.
  535. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  536. - upgrade to 0.96.
  537. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  538. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  539. warning
  540. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  541. - rebuilt
  542. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  543. - upgrade to 0.95.
  544. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  545. - rebuilt
  546. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  547. - rebuilt
  548. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  549. - upgrade to 0.94
  550. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  551. - upgrade to 0.93
  552. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  553. - full version
  554. - macroized spec file for GPL or OSL builds
  555. - include only libelf under GPL plus wrapper scripts
  556. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  557. - macroized spec file for GPL or OSL builds
  558. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  559. - split elfutils-devel into two packages.
  560. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  561. - include only libelf under GPL plus wrapper scripts
  562. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  563. - readelf, not readline, in %%description (#111214).
  564. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  565. - update to 0.89 (fix eu-strip)
  566. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  567. - update to 0.86 (fix eu-strip on s390x/alpha)
  568. - libebl is an archive now; remove references to DSO
  569. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  570. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  571. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  572. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  573. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  574. - upgrade to 0.82 (strip tests fixed on big-endian).
  575. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  576. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  577. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  578. - upgrade to 0.80 (debugedit changes for kernel in progress).
  579. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  580. - rebuilt
  581. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  582. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  583. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  584. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  585. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  586. - debuginfo rebuild
  587. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  588. - use the correct way of identifying the section via the sh_info link.
  589. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  590. - update to 0.75 (eu-strip -g fix)
  591. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  592. - update to 0.74 (fix for writing with some non-dirty sections)
  593. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  594. - another -0.73 update (with sparc fixes).
  595. - do "make check" in %%check, not %%install, section.
  596. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  597. - update to 0.73 (with s390 fixes).
  598. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  599. - rebuilt
  600. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  601. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  602. - fix other warnings
  603. - reenable checks on s390x
  604. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  605. - temporarily disable checks on s390x, until someone has
  606. time to look at it
  607. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  608. - update to 0.72
  609. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  610. - update to 0.71
  611. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  612. - update to 0.69.
  613. - add "make check" and segfault avoidance patch.
  614. - elfutils-libelf needs to run ldconfig.
  615. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  616. - update to 0.68.
  617. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  618. - update to 0.67.
  619. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  620. - update to 0.65.
  621. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  622. - update to 0.64.
  623. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  624. - split packages further into elfutils-libelf
  625. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  626. - update to 0.63.
  627. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  628. - Adjust for dropping libtool
  629. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  630. - update to 0.59
  631. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  632. - update to 0.56
  633. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  634. - update to 0.54
  635. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  636. - update to 0.53
  637. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  638. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  639. - get beehive to punch a rhpkg generated package.
  640. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  641. - build in 8.0.1.
  642. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  643. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  644. - Add libelf-devel to conflicts for elfutils-devel
  645. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  646. - Split into runtime and devel package
  647. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  648. - integrate into official sources
  649. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  650. - Swaddle.