docker-compose-vl.spec 2.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. Name: docker-compose
  2. Summary: Define and run multi-container applications with Docker
  3. Version: 2.29.2
  4. Release: 1%{_dist_release}
  5. Group: virtualization
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: Apache-2.0
  9. URL: https://github.com/docker/compose
  10. Source: https://github.com/docker/compose/archive/refs/tags/v%{version}.tar.gz#/compose-%{version}.tar.gz
  11. # GOPROXY=https://proxy.golang.org,direct go mod vendor
  12. Source1: vendor.tar.xz
  13. BuildRequires: golang
  14. Requires: moby-engine
  15. %description
  16. Docker Compose is a tool for running multi-container applications on Docker defined using the Compose file format. A Compose file is used to define how the one or more containers that make up your application are configured. Once you have a Compose file, you can create and start your application with a single command: docker compose up.
  17. About update and backward compatibility
  18. Docker Compose V2 is a major version bump release of Docker Compose. It has been completely rewritten from scratch in Golang (V1 was in Python). The installation instructions for Compose V2 differ from V1. V2 is not a standalone binary anymore, and installation scripts will have to be adjusted. Some commands are different.
  19. For a smooth transition from legacy docker-compose 1.xx, please consider installing compose-switch to translate docker-compose ... commands into Compose V2's docker compose .... . Also check V2's --compatibility flag.
  20. %prep
  21. %setup -q -a 1 -n compose-%{version}
  22. %build
  23. go build \
  24. -mod=vendor \
  25. -buildmode=pie \
  26. -trimpath \
  27. -ldflags="-s -w -X github.com/docker/compose/v2/internal.Version=%{version}" \
  28. -o _build/docker-compose ./cmd/
  29. %install
  30. install -Dpm 0755 _build/%{name} %{buildroot}%{_bindir}/%{name}
  31. mkdir -p %{buildroot}/usr/lib/docker/cli-plugins
  32. ln -sf ../../../bin/%{name} %{buildroot}/usr/lib/docker/cli-plugins/%{name}
  33. mkdir -p %{buildroot}%{_datadir}/bash-completion/completions
  34. ln -sf docker %{buildroot}%{_datadir}/bash-completion/completions/docker-compose
  35. %pre
  36. if [ -e /usr/lib/docker/cli-plugins/%{name} -a ! -L /usr/lib/docker/cli-plugins/%{name} ]; then
  37. rm -f /usr/lib/docker/cli-plugins/%{name}
  38. fi
  39. %files
  40. %license LICENSE
  41. %doc README.md
  42. %{_bindir}/*
  43. %dir /usr/lib/docker/
  44. %dir /usr/lib/docker/cli-plugins/
  45. /usr/lib/docker/cli-plugins/%{name}
  46. %dir %{_datadir}/bash-completion
  47. %dir %{_datadir}/bash-completion/completions
  48. %{_datadir}/bash-completion/completions/docker-compose
  49. %changelog
  50. * Sat Aug 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.29.2-1
  51. - new upstream release.
  52. * Wed Jul 24 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.29.1-1
  53. - new upstream release.
  54. * Tue Jul 16 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.28.1-1
  55. - initial build for Vine Linux.