compiler-rt-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. # see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
  6. %global optflags %(echo %{optflags} -D_DEFAULT_SOURCE)
  7. # see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=93615
  8. %global optflags %(echo %{optflags} -Dasm=__asm__)
  9. Summary: LLVM "compiler-rt" runtime libraries
  10. Summary(ja): LLVM "compiler-rt" ランタイムライブラリ
  11. Name: compiler-rt
  12. Version: 18.1.5
  13. %define shortver %(echo %{version} | cut -d. -f1)
  14. Release: 1%{?_dist_release}
  15. Group: programming
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. License: NCSA
  19. URL: https://llvm.org/
  20. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
  21. # patches
  22. Patch0: 0001-compiler-rt-Fix-FLOAT16-feature-detection.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. BuildRequires: cmake
  25. BuildRequires: ninja
  26. BuildRequires: clang
  27. BuildRequires: python3
  28. BuildRequires: python3-devel
  29. BuildRequires: llvm-devel = %{version}
  30. BuildRequires: llvm-static = %{version}
  31. Requires: clang = %{version}-%{release}
  32. # LLVM is not supported on PPC64
  33. # http://llvm.org/bugs/show_bug.cgi?id=3729
  34. ExcludeArch: ppc64
  35. %description
  36. The compiler-rt project is a part of the LLVM project. It provides
  37. implementation of the low-level target-specific hooks required by
  38. code generation, sanitizer runtimes and profiling library for code
  39. instrumentation, and Blocks C language extension.
  40. %debug_package
  41. %prep
  42. %autosetup -n compiler-rt-%{version}.src -p2
  43. # compiler-rt does not allow configuring LLVM_COMMON_CMAKE_UTILS.
  44. rm -f ../cmake
  45. ln -s %{_datadir}/llvm/cmake ../cmake
  46. pathfix%{python3_version}.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
  47. %build
  48. # Copy CFLAGS into ASMFLAGS, so -fcf-protection is used when compiling assembly files.
  49. export ASMFLAGS=$CFLAGS
  50. %cmake \
  51. -GNinja \
  52. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  53. -DCMAKE_MODULE_PATH=%{_libdir}/cmake/llvm \
  54. -DCMAKE_SKIP_RPATH:BOOL=ON \
  55. -DCOMPILER_RT_INSTALL_PATH=%{_libdir}/clang/%{shortver} \
  56. -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR=ON \
  57. %if 0%{?__isa_bits} == 64
  58. -DLLVM_LIBDIR_SUFFIX=64 \
  59. %else
  60. -DLLVM_LIBDIR_SUFFIX= \
  61. %endif
  62. -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
  63. %cmake_build
  64. %install
  65. %cmake_install
  66. %if %{with test}
  67. %check
  68. #cmake_build --target check-compiler-rt
  69. %endif
  70. %clean
  71. rm -rf %{buildroot}
  72. %files
  73. %license LICENSE.TXT
  74. %ifarch x86_64 aarch64
  75. %{_libdir}/clang/%{shortver}/bin/*
  76. %endif
  77. %{_libdir}/clang/%{shortver}/include/*
  78. %{_libdir}/clang/%{shortver}/lib/*
  79. %{_libdir}/clang/%{shortver}/share/*
  80. %changelog
  81. * Sat May 04 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 18.1.5-1
  82. - new upstream release.
  83. * Sat Oct 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
  84. - new upstream release.
  85. * Sun Oct 01 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
  86. - new upstream release.
  87. * Sun May 28 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
  88. - new upstream release.
  89. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  90. - new upstream release.
  91. * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  92. - new upstream release.
  93. * Wed Sep 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  94. - new upstream release.
  95. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  96. - new upstream release.
  97. - dropped Patch0.
  98. - imported Patch0 from rawhide.
  99. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  100. - new upstream release.
  101. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  102. - new upstream release.
  103. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  104. - new upstream release.
  105. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  106. - devided compiler-rt from llvm.
  107. - new upstream release.
  108. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  109. - enabled to build utils.
  110. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  111. - new upstream release.
  112. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  113. - new upstream release.
  114. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  115. - rebuilt with libffi-3.3.
  116. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  117. - new upstream release.
  118. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  119. - new upstream release.
  120. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  121. - dropped all patches.
  122. - switched build-system to ninja.
  123. - switched python to python3.
  124. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  125. - new upstream release.
  126. - added OpenMP.
  127. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  128. - fixed %%files.
  129. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  130. - new upstream release.
  131. - dropped Patch0, 4, 5, 100 and 200.
  132. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  133. - renamed a subpackage "llvm-libs".
  134. - added a subpackage "lld".
  135. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  136. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  137. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  138. - new upstream release.
  139. - dropped Patch1 and 2: fixed in upstream.
  140. - imported Patch0, 3-5, 100 and 200 from rawhide.
  141. - disabled Patch1002: no longer needed?
  142. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  143. - new upstream release.
  144. - switched to cmake.
  145. - disable ocaml binding as default.
  146. - updated Patch1000 and 1002.
  147. - disabled Patch1000 as default.
  148. - cleanup patches.
  149. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  150. - rebuild with gcc-5.4.0
  151. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  152. - new upstream release
  153. - added BR: ocaml-ctypes
  154. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  155. - new upstream release
  156. - dropt Patch 1, 201 and 1001
  157. - updated Patch 1000
  158. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  159. - updated to 3.5.1
  160. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  161. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  162. - obsoleted clang-doc
  163. - built with ocaml 4.02.1
  164. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  165. - fix <BTS:2832>
  166. - fix configure option "--with-c-include-dirs"
  167. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  168. - update Patch1001: clang-3.5.0-driver-lib64.patch
  169. - update Patch1002: clang-3.5.0-driver-vine.patch
  170. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  171. - update to 3.5.0
  172. - remove Patch11 (clang-hardfloat-hack.patch)
  173. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  174. - rebuild with libffi-3.0.13
  175. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  176. - update to 3.3
  177. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  178. - ld.gold (patch1000,1001)
  179. - add /%{_lib} to ld search path
  180. - add support *-vine-linux gcc (patch1002)
  181. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  182. - update to 3.1
  183. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  184. - updated to 3.0 release
  185. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  186. - added patch 2-4 to support -O4 link-time optimization
  187. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  188. - disable -fno-var-tracking-assignments on ppc
  189. (seems like gcc-4.4.5 still doesn't support this)
  190. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  191. - new upstream release
  192. - add BR: libffi-devel
  193. - add R: libffi-devel to -devel
  194. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  195. - initial build for Vine Linux
  196. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  197. - Update to final 2.7 release
  198. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  199. - Update to first 2.7 pre-release
  200. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  201. - Update to 2.6 pre-release2
  202. - -devel subpackage now virtually provides -static
  203. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  204. - Disable var tracking assignments on PPC
  205. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  206. - Don't adjust clang include dir; files there are noarch (bz#521893)
  207. - Enable clang unit tests
  208. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  209. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  210. - Package Clang's static analyzer tools
  211. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  212. - PIC is now enabled by default; explicitly disable on %%{ix86}
  213. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  214. - First 2.6 prerelease
  215. - Enable Clang front-end
  216. - Enable debuginfo generation
  217. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  218. - Disable assertions (needed by OpenGTL, bz#521261)
  219. - Align spec file with upstream build instructions
  220. - Enable unit tests
  221. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  222. - Only disable PIC on %%ix86; ppc actually needs it
  223. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  224. - Disable use of position-independent code on 32-bit platforms
  225. (buggy in LLVM <= 2.5)
  226. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  227. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  228. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  229. - Remove build scripts; they require the build directory to work
  230. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  231. - Update to 2.5
  232. - Package build scripts (bug #457881)
  233. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  234. - Patched build process for the OCaml binding
  235. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  236. - Update to 2.4
  237. - Package Ocaml binding
  238. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  239. - Add dependency on groff
  240. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  241. - LLVM 2.3
  242. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  243. - fix license tags
  244. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  245. - Fix compilation problems with gcc 4.3
  246. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  247. - Autorebuild for GCC 4.3
  248. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  249. - Fix review comments
  250. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  251. - Initial version