cmocka-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309
  1. Name: cmocka
  2. Version: 1.1.7
  3. Release: 5%{?_dist_release}
  4. Group: programming
  5. Vendor: Project Vine
  6. Distribution: Vine Linux
  7. License: Apache-2.0
  8. Summary: An elegant unit testing framework for C with support for mock objects
  9. URL: https://cmocka.org
  10. Source0: https://cmocka.org/files/1.1/%{name}-%{version}.tar.xz
  11. Source1: https://cmocka.org/files/1.1/%{name}-%{version}.tar.xz.asc
  12. Source2: cmocka.keyring
  13. BuildRequires: gcc
  14. BuildRequires: cmake
  15. BuildRequires: doxygen
  16. BuildRequires: glibc-devel
  17. BuildRequires: gnupg2
  18. %description
  19. There are a variety of C unit testing frameworks available however many of them
  20. are fairly complex and require the latest compiler technology. Some development
  21. requires the use of old compilers which makes it difficult to use some unit
  22. testing frameworks. In addition many unit testing frameworks assume the code
  23. being tested is an application or module that is targeted to the same platform
  24. that will ultimately execute the test. Because of this assumption many
  25. frameworks require the inclusion of standard C library headers in the code
  26. module being tested which may collide with the custom or incomplete
  27. implementation of the C library utilized by the code under test.
  28. Cmocka only requires a test application is linked with the standard C library
  29. which minimizes conflicts with standard C library headers. Also, CMocka tries
  30. to avoid the use of some of the newer features of C compilers.
  31. This results in CMocka being a relatively small library that can be used to
  32. test a variety of exotic code. If a developer wishes to simply test an
  33. application with the latest compiler then other unit testing frameworks may be
  34. preferable.
  35. This is the successor of Google's Cmockery.
  36. %package -n libcmocka
  37. Summary: Lightweight library to simplify and generalize unit tests for C
  38. Group: programming
  39. Conflicts: cmockery2
  40. %description -n libcmocka
  41. There are a variety of C unit testing frameworks available however many of them
  42. are fairly complex and require the latest compiler technology. Some development
  43. requires the use of old compilers which makes it difficult to use some unit
  44. testing frameworks. In addition many unit testing frameworks assume the code
  45. being tested is an application or module that is targeted to the same platform
  46. that will ultimately execute the test. Because of this assumption many
  47. frameworks require the inclusion of standard C library headers in the code
  48. module being tested which may collide with the custom or incomplete
  49. implementation of the C library utilized by the code under test.
  50. CMocka only requires a test application is linked with the standard C library
  51. which minimizes conflicts with standard C library headers. Also, CMocka tries
  52. to avoid the use of some of the newer features of C compilers.
  53. This results in CMocka being a relatively small library that can be used to
  54. test a variety of exotic code. If a developer wishes to simply test an
  55. application with the latest compiler then other unit testing frameworks may be
  56. preferable.
  57. This is the successor of Google's Cmockery.
  58. %package -n libcmocka-devel
  59. Summary: Development headers for the cmocka library
  60. Group: programming
  61. Requires: libcmocka = %{version}-%{release}
  62. Conflicts: cmockery2-devel
  63. %description -n libcmocka-devel
  64. Development headers for the cmocka unit testing library.
  65. %package -n cmocka-doc
  66. Summary: API documentation for the cmocka unit testing framework
  67. Group: documentation
  68. BuildArch: noarch
  69. %description -n cmocka-doc
  70. This package provides the API documentation for the cmocka unit testing
  71. framework.
  72. %debug_package
  73. %prep
  74. %autosetup -p1
  75. %build
  76. # This package uses -Wl,-wrap to wrap calls at link time. This is incompatible
  77. # with LTO.
  78. # Disable LTO
  79. %define _lto_cflags %{nil}
  80. %cmake \
  81. -DWITH_STATIC_LIB=ON \
  82. -DWITH_CMOCKERY_SUPPORT=ON \
  83. -DUNIT_TESTING=ON
  84. %cmake_build
  85. %__cmake --build %{__cmake_builddir} --target docs
  86. %install
  87. %cmake_install
  88. ln -s libcmocka.so %{buildroot}%{_libdir}/libcmockery.so
  89. %check
  90. %ctest
  91. %files -n libcmocka
  92. %doc AUTHORS README.md ChangeLog
  93. %license COPYING
  94. %{_libdir}/libcmocka.so.*
  95. %files -n libcmocka-devel
  96. %{_includedir}/cmocka.h
  97. %{_includedir}/cmocka_pbc.h
  98. %{_includedir}/cmockery/cmockery.h
  99. %{_includedir}/cmockery/pbc.h
  100. %{_libdir}/libcmocka.so
  101. %{_libdir}/libcmockery.so
  102. %{_libdir}/pkgconfig/cmocka.pc
  103. %{_libdir}/cmake/cmocka/cmocka-config*.cmake
  104. %files -n cmocka-doc
  105. %doc %{__cmake_builddir}/doc/html
  106. %changelog
  107. * Sat Jun 29 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.7-5
  108. - initial build for Vine Linux.
  109. * Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.7-4
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
  111. * Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.7-3
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
  113. * Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.7-2
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
  115. * Tue Feb 28 2023 Andreas Schneider <asn@redhat.com> - 1.1.7-1
  116. - Update to version 1.1.7
  117. * Update ignore list for source tarball generation
  118. * Added new assert macros to compare 2 double given an epsilon
  119. * Added meson build system
  120. * Added header with version to TAP13 output
  121. * Fixed issues with MSVC
  122. * Fixed TAP output for skipped tests
  123. * Fixed issue with fail_msg
  124. * CMake generated configs for find_package(cmocka)
  125. * Documentation improvements
  126. * Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-13
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
  128. * Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-12
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
  130. * Wed Jan 19 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-11
  131. - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
  132. * Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-10
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
  134. * Mon Apr 19 2021 Andreas Schneider <asn@redhat.com> - 1.1.5-9
  135. - Split out a cmocka-doc package
  136. * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-8
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  138. * Wed Aug 05 2020 Andreas Schneider <asn@redhat.com> - 1.1.5-7
  139. - Correctly build with new cmake macros
  140. * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-6
  141. - Second attempt - Rebuilt for
  142. https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  143. * Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-5
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  145. * Wed Jul 1 2020 Jeff Law <law@redhat.com> - 1.1.5-4
  146. - Disable LTO
  147. * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-3
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  149. * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-2
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  151. * Thu Mar 28 2019 Andreas Schneider <asn@redhat.com> - 1.1.5-1
  152. - Update to version 1.1.5
  153. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-2
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  155. * Thu Sep 27 2018 Andreas Schneider <asn@redhat.com> - 1.1.3-1
  156. - Update to version 1.1.3
  157. * Wed Aug 29 2018 Andreas Schneider <asn@redhat.com> - 1.1.2-1
  158. - Update to version 1.1.2
  159. * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-9
  160. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  161. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-8
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  163. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-7
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  165. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-6
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  167. * Tue Mar 28 2017 Than Ngo <than@redhat.com> - 1.1.0-5
  168. - added workaround for gcc7 bug on ppc64le temporary
  169. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  171. * Wed Sep 21 2016 Jakub Hrozek <jhrozek@redhat.com> - 1.1.0-1
  172. - Update to version 1.1.0
  173. * Added support to catch multiple exceptions
  174. * Added support to verify call ordering
  175. * Added support to pass initial data to test cases
  176. * Added will_return_maybe() for ignoring mock returns
  177. * Added subtests for groups using TAP output
  178. * Added support to write multiple XML files for groups
  179. * Improved documentation
  180. * Fixed XML output generataion
  181. * Fixed Windows builds with VS2015
  182. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  184. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-2
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  186. * Thu Mar 12 2015 Andreas Schneider <asn@redhat.com> - 1.0.1-1
  187. - Update to version 1.0.1:
  188. * Added a macro for assert_ptr_equal().
  189. * Fixed test_realloc() if 0 size is passed.
  190. * Fixed objects packaging bug.
  191. * Fixed building with newer gcc versions.
  192. * Mon Feb 16 2015 Andreas Schneider <asn@redhat.com> - 1.0.0-1
  193. - Update to version 1.0.0:
  194. * Added new test runner with group fixtures. The old runner is deprecated
  195. * Added an extensible message output formatter
  196. * Added jUnit XML message output
  197. * Added subunit message output
  198. * Added Test Anything Protocol message output
  199. * Added skip() command
  200. * Added test_realloc()
  201. * Added a cmockery compat header
  202. * Fixed a lot of bugs on Windows
  203. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-3
  204. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  205. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-2
  206. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  207. * Mon May 26 2014 - Andreas Schneider <asn@redhat.com> - 0.4.1-1
  208. - Update to version 0.4.1.
  209. * Fri Apr 11 2014 - Andreas Schneider <asn@redhat.com> - 0.4.0-1
  210. - Update to version 0.4.0.
  211. * Wed Nov 06 2013 - Andreas Schneider <asn@redhat.com> - 0.3.2-1
  212. - Update to version 0.3.2.
  213. - Include API documentation.
  214. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.1-2
  215. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  216. * Wed Jul 10 2013 - Andreas Schneider <asn@redhat.com> - 0.3.0-2
  217. - Update to version 0.3.1.
  218. - Fixed cmocka issues on big endian.
  219. - resolves: #975044
  220. * Wed Jun 05 2013 - Andreas Schneider <asn@redhat.com> - 0.3.0-1
  221. - Update to version 0.3.0.
  222. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-4
  223. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  224. * Fri Jan 18 2013 - Andreas Schneider <asn@redhat.com> - 0.2.0-3
  225. - Fixed typo in Source URL.
  226. * Thu Jan 17 2013 - Andreas Schneider <asn@redhat.com> - 0.2.0-2
  227. - Fixed Source URL.
  228. - Fixed package groups.
  229. * Tue Jan 15 2013 - Andreas Schneider <asn@redhat.com> - 0.2.0-1
  230. - Initial version 0.2.0