bzip2-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A file compression utility.
  3. Summary(ja): ファイル圧縮ユーティリティ
  4. Name: bzip2
  5. Version: 1.0.8
  6. Release: 2%{?_dist_release}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: BSD
  10. Group: accesories
  11. URL: https://sourceware.org/bzip2
  12. Source0: https://sourceware.org/pub/bzip2/%{name}-%{version}.tar.gz
  13. Source1: bzip2.pc
  14. Patch0: bzip2-saneso.patch
  15. Patch1: bzip2-cflags.patch
  16. Patch2: bzip2-ldflags.patch
  17. # P2 implements a progress counter (in %). It also
  18. # display the percentage of the original file the new file is (size).
  19. # URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
  20. Patch10: bzip2-1.0.2.diff.bz2
  21. # security patch(es)
  22. # none
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: texinfo
  25. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  26. %description
  27. Bzip2 is a freely available, patent-free, high quality data compressor.
  28. Bzip2 compresses files to within 10 to 15 percent of the capabilities
  29. of the best techniques available. However, bzip2 has the added benefit
  30. of being approximately two times faster at compression and six times
  31. faster at decompression than those techniques. Bzip2 is not the
  32. fastest compression utility, but it does strike a balance between speed
  33. and compression capability.
  34. Install bzip2 if you need a compression utility.
  35. %package devel
  36. Summary: Header files and libraries for developing apps which will use bzip2.
  37. Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
  38. Group: programming
  39. Requires: %{name} = %{version}-%{release}
  40. Provides: pkgconfig(bzip2) = %{version}
  41. %description devel
  42. Header files and a static library of bzip2 functions, for developing apps
  43. which will use the library.
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-%{name}
  46. Summary: A file compression utility.
  47. Summary(ja): ファイル圧縮ユーティリティ
  48. Group: system,legacy
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n compat32-%{name}
  51. Bzip2 is a freely available, patent-free, high quality data compressor.
  52. Bzip2 compresses files to within 10 to 15 percent of the capabilities
  53. of the best techniques available. However, bzip2 has the added benefit
  54. of being approximately two times faster at compression and six times
  55. faster at decompression than those techniques. Bzip2 is not the
  56. fastest compression utility, but it does strike a balance between speed
  57. and compression capability.
  58. Install bzip2 if you need a compression utility.
  59. %package -n compat32-%{name}-devel
  60. Summary: Header files and libraries for developing apps which will use bzip2.
  61. Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
  62. Group: programming,legacy
  63. Requires: compat32-%{name} = %{version}-%{release}
  64. Requires: %{name}-devel = %{version}-%{release}
  65. %description -n compat32-%{name}-devel
  66. Header files and a static library of bzip2 functions, for developing apps
  67. which will use the library.
  68. %debug_package
  69. %prep
  70. %setup -q
  71. %patch0 -p1
  72. %patch1 -p1
  73. %patch2 -p1
  74. %patch10 -p1
  75. cp -a %{SOURCE1} .
  76. sed -i "s|^libdir=|libdir=%{_libdir}|" bzip2.pc
  77. %build
  78. make -f Makefile-libbz2_so \
  79. CC="%{__cc}" \
  80. AR="%{__ar}" \
  81. RANLIB="%{__ranlib}" \
  82. CFLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -fpic -fPIC" \
  83. LDFLAGS="" \
  84. %{?_smp_mflags} all
  85. rm -f *.o
  86. make \
  87. CC="%{__cc}" \
  88. AR="%{__ar}" \
  89. RANLIB="%{__ranlib}" \
  90. CFLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64" \
  91. LDFLAGS="" \
  92. %{?_smp_mflags} all
  93. %install
  94. rm -rf %{buildroot}
  95. chmod 644 bzlib.h
  96. mkdir -p %{buildroot}{%{_bindir},%{_mandir}/man1,%{_libdir}/pkgconfig,%{_includedir}}
  97. cp -p bzlib.h %{buildroot}%{_includedir}
  98. install -m 755 libbz2.so.* %{buildroot}%{_libdir}
  99. #install -m 644 libbz2.a %{buildroot}%{_libdir}
  100. install -m 644 bzip2.pc %{buildroot}%{_libdir}/pkgconfig/bzip2.pc
  101. install -m 755 bzip2-shared %{buildroot}%{_bindir}/bzip2
  102. install -m 755 bzip2recover bzgrep bzdiff bzmore %{buildroot}%{_bindir}/
  103. cp -p bzip2.1 bzdiff.1 bzgrep.1 bzmore.1 %{buildroot}%{_mandir}/man1/
  104. ln -s bzip2 %{buildroot}%{_bindir}/bunzip2
  105. ln -s bzip2 %{buildroot}%{_bindir}/bzcat
  106. ln -s bzdiff %{buildroot}%{_bindir}/bzcmp
  107. ln -s bzmore %{buildroot}%{_bindir}/bzless
  108. ln -s bzgrep %{buildroot}%{_bindir}/bzegrep
  109. ln -s bzgrep %{buildroot}%{_bindir}/bzfgrep
  110. ln -s libbz2.so.%{library_version} %{buildroot}%{_libdir}/libbz2.so.1
  111. ln -s libbz2.so.1 %{buildroot}%{_libdir}/libbz2.so
  112. ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bzip2recover.1
  113. ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bunzip2.1
  114. ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bzcat.1
  115. ln -s bzdiff.1 %{buildroot}%{_mandir}/man1/bzcmp.1
  116. ln -s bzmore.1 %{buildroot}%{_mandir}/man1/bzless.1
  117. ln -s bzgrep.1 %{buildroot}%{_mandir}/man1/bzegrep.1
  118. ln -s bzgrep.1 %{buildroot}%{_mandir}/man1/bzfgrep.1
  119. %files
  120. %defattr(-,root,root)
  121. %{!?_licensedir:%global license %%doc}
  122. %license LICENSE
  123. %doc CHANGES README
  124. %{_bindir}/*
  125. %{_mandir}/*/*
  126. %{_libdir}/*so.*
  127. %files devel
  128. %defattr(-,root,root)
  129. %{_includedir}/*
  130. %{_libdir}/*so
  131. %{_libdir}/pkgconfig/*
  132. ## to build compat32 for x86_64 architecture support
  133. %if %{build_compat32}
  134. %files -n compat32-%{name}
  135. %defattr(-,root,root)
  136. %{_libdir}/*so.*
  137. %files -n compat32-%{name}-devel
  138. %defattr(-,root,root)
  139. %{_libdir}/*so
  140. %{_libdir}/pkgconfig/*
  141. %endif
  142. %changelog
  143. * Sun Jun 09 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.8-2
  144. - dropped ldconfig scriptlets.
  145. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.8-1
  146. - new upstream release.
  147. - dropped Patch0-3 and 1000.
  148. - imported Patch0-2 from rawhide.
  149. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-4
  150. - fixed %%files.
  151. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-3
  152. - added Patch1000 to fix CVE-2016-3189.
  153. * Wed Jan 1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.6-2
  154. - rebuilt with new vineseed toolchain
  155. * Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  156. - update to 1.0.6
  157. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
  158. - build on current VineSeed
  159. - update URL and Source0 tags URL
  160. * Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
  161. - rebuild with new toolchain
  162. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
  163. - updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
  164. - removed unneccesary %if !%{build_compat32} case condition
  165. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
  166. - spec in utf-8
  167. - remove static library
  168. * Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
  169. - new upstream release with security fix
  170. - drop old patches (patch3-6) which are included in new release
  171. - build under new versioning policy
  172. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
  173. - changed Group to Applications/Archiving
  174. - changed compat32-bzip2 Group to System Environment/Libraries
  175. * Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
  176. - new upstream release
  177. - add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
  178. * Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
  179. - fixed %%postun (missing to build as scriptlet by invalid comment)
  180. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
  181. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  182. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  183. - added compat32- packages for x86_64 architecture support
  184. - changed autoconf-2.13 to current autoconf
  185. * Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
  186. - added patch 1 from Rawhide 1.0.2-8
  187. - added patch 2 from Mandrake 1.0.2-14mdk
  188. * Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
  189. - previous patch is so incomplete that "bzip2 -f" fails.
  190. instead, update the source which fixes this and other bugs.
  191. * Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  192. - fix race condition.
  193. * Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  194. - 1.0.1-3vl2
  195. - added Japanese summary
  196. - rebuilt under new %%{_mandir} definition
  197. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
  198. - build on Vine Linux with gcc-2.95.3
  199. - partially used rpmmacros
  200. * Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
  201. - new URL and source location
  202. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  203. - automatic rebuild
  204. * Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  205. - 1.0.1
  206. - ported my patch
  207. * Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
  208. - FHS packaging to build on solaris2.5.1.
  209. - remove config.cache from autoconf patch.
  210. - sparc: use %%configure, but not the m4 macros.
  211. * Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
  212. - Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
  213. * Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
  214. - 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
  215. * Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
  216. - use soft links, not hardlinks, for binaries
  217. - mv .so to devel
  218. * Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
  219. - autoconfed and libtoolized package
  220. - fixed Copyright (it's BSD, not GPL)
  221. - dumped bzless (less works fine with bz2-files)
  222. - rewrote build and install parts
  223. - separated main package and devel package
  224. * Mon May 8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  225. - 1.0pre8
  226. * Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  227. - Add bzgrep (a version of zgrep hacked to do bzip2)
  228. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  229. - handle compressed manpages
  230. * Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
  231. - 0.9.5d
  232. - Update download URL, add URL: tag in header
  233. * Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
  234. - upgrade to 0.9.5c.
  235. * Mon Aug 9 1999 Bill Nottingham <notting@redhat.com>
  236. - install actual bzip2 binary, not libtool cruft.
  237. * Sun Aug 8 1999 Jeff Johnson <jbj@redhat.com>
  238. - run ldconfig to get shared library.
  239. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  240. - create shared libbz1.so.* library.
  241. * Sun Apr 4 1999 Jeff Johnson <jbj@redhat.com>
  242. - update to bzip2-0.9.0c.
  243. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  244. - auto rebuild in the new build environment (release 4)
  245. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  246. - build against glibc 2.1
  247. * Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
  248. - force compilation with egcs to avoid gcc optimization bug (thank God
  249. we haven't been beaten by it)
  250. * Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
  251. - version 0.9.0b
  252. * Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
  253. - updated to 0.9.0
  254. * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
  255. - first build for Manhattan