bluez-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546
  1. %bcond_with systemd
  2. %define _unpackaged_files_terminate_build 1
  3. %if "0%{?_udevrulesdir}" == "0"
  4. %global _udevrulesdir /usr/lib/udev/rules.d
  5. %endif
  6. Summary: Bluetooth utilities
  7. Summary(ja): Bluetooth ユーティリティ
  8. Name: bluez
  9. Version: 5.76
  10. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  11. Group: system,admin-tools
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: daisuke
  15. License: GPLv2+
  16. URL: http://www.bluez.org/
  17. #----------------------------------------------------------------------------
  18. Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
  19. Source1: bluetooth.init.vine
  20. Source3: bluez-uinput.modules
  21. Source11: trusts.txt
  22. Source20: main.conf
  23. # Scripts for automatically btattach-ing serial ports connected to Broadcom HCIs
  24. Source22: 69-btattach-bcm.rules
  25. Source23: btattach-bcm@.service
  26. Source24: btattach-bcm-service.sh
  27. # from http://www.linuxfromscratch.org/patches/downloads/bluez/
  28. Patch0: bluez-5.76-obexd_without_systemd-1.patch
  29. # Patch for Vine
  30. Patch100: 0002-bluez-5.54-daemon.patch
  31. Patch101: 0003-bluez-5.54-config-vine.patch
  32. #----------------------------------------------------------------------------
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. BuildRequires: flex
  35. BuildRequires: bison
  36. BuildRequires: cups-devel
  37. BuildRequires: dbus-devel
  38. BuildRequires: glib2-devel
  39. BuildRequires: readline-devel
  40. BuildRequires: libical-devel
  41. BuildRequires: json-c-devel
  42. BuildRequires: python3-docutils
  43. %if %{with systemd}
  44. BuildRequires: systemd-devel
  45. %{?systemd_requires}
  46. %else
  47. BuildRequires: eudev-libudev-devel
  48. Requires: initscripts
  49. Requires(post): /sbin/chkconfig, /sbin/service
  50. Requires(preun): /sbin/chkconfig, /sbin/service
  51. Requires(postun): /sbin/service
  52. %endif
  53. ExcludeArch: s390 s390x
  54. Obsoletes: bluez-pan < 4.0, bluez-sdp < 4.0
  55. Requires: bluez-libs = %{version}
  56. Requires: dbus >= 0.60
  57. # Requires: fuse
  58. ## Requires: hwdata >= 0.215
  59. Requires: hwdata >= 0.146
  60. #----------------------------------------------------------------------------
  61. Obsoletes: bluez-utils < 4.5-2
  62. Provides: bluez-utils = %{version}-%{release}
  63. Obsoletes: bluez-gstreamer < 5.0
  64. Obsoletes: bluez-alsa < 5.0
  65. #----------------------------------------------------------------------------
  66. %description
  67. Utilities for use in Bluetooth applications:
  68. - hcitool
  69. - hciattach
  70. - hciconfig
  71. - bluetoothd
  72. - l2ping
  73. - start scripts VineLinux (RedHat base)
  74. - pcmcia configuration files
  75. Please, read %{_defaultdocdir}/%{name}-%{version}/trusts.txt
  76. The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
  77. %description -l ja
  78. Bluetooth ユーティリティ (bluez-utils):
  79. - hcitool
  80. - hciattach
  81. - hciconfig
  82. - l2ping
  83. - 起動スクリプト (Red Hat用をVineLinuxに合わせました)
  84. - pcmcia コンフィグレーション ファイル
  85. ※付属の%{_defaultdocdir}/%{name}-%{version}/trusts.txtもご覧下さい。
  86. (BLUETOOTH は Bluetooth SIG, Inc.(USA)のトレードマークです)
  87. #----------------------------------------------------------------------------
  88. %package libs
  89. Summary: Libraries for use in Bluetooth applications
  90. Summary(ja): BlueTooth アプリケーションの使用するライブラリ(BlueZ)
  91. Group: system
  92. %description libs
  93. Libraries for use in Bluetooth applications.
  94. %description libs -l ja
  95. Bluetooth アプリケーションのためのライブラリです。
  96. ※BlueZ のユーティリティのためにも必要です
  97. #----------------------------------------------------------------------------
  98. %package libs-devel
  99. Summary: Development libraries for Bluetooth applications
  100. Summary(ja): Bluetooth アプリケーション開発のためのdevelパッケージ
  101. Group: programming
  102. Requires: bluez-libs = %{version}
  103. Requires: pkgconfig
  104. Obsoletes: bluez-sdp-devel < 4.0
  105. %description libs-devel
  106. bluez-libs-devel contains development libraries and headers for
  107. use in Bluetooth applications.
  108. %description libs-devel -l ja
  109. bluez-libs-devel パッケージは Bluetooth アプリケーション開発のための
  110. ライブラリやヘッダーファイルを提供します。
  111. #----------------------------------------------------------------------------
  112. %package cups
  113. Summary: CUPS printer backend for Bluetooth printers
  114. Summary(ja): Bluetooth 経由の CUPS プリンタシステム用
  115. Group: servers
  116. Obsoletes: bluez-utils-cups < 4.5-2
  117. Provides: bluez-utils-cups = %{version}-%{release}
  118. Requires: bluez-libs = %{version}
  119. Requires: cups
  120. %description cups
  121. This package contains the CUPS backend
  122. %description cups -l ja
  123. Bluetooth対応 プリンターを CUPS印刷システムから利用する
  124. ためのバックエンドです。
  125. #----------------------------------------------------------------------------
  126. %debug_package
  127. #----------------------------------------------------------------------------
  128. %prep
  129. rm -rf $RPM_BUILD_ROOT
  130. %setup -q
  131. %if !%{with systemd}
  132. %patch0 -p1
  133. %endif
  134. %patch100 -p1
  135. %patch101 -p1
  136. %build
  137. %configure \
  138. %if %{with systemd}
  139. --with-systemdsystemunitdir=%{_unitdir} \
  140. --with-systemduserunitdir=%{_userunitdir} \
  141. --enable-mesh \
  142. %else
  143. --disable-systemd \
  144. %endif
  145. --enable-deprecated \
  146. --enable-library \
  147. --enable-tools \
  148. --enable-sixaxis \
  149. --enable-cups \
  150. --enable-nfc \
  151. --enable-hid2hci \
  152. --disable-android
  153. make %{?_smp_mflags}
  154. #----------------------------------------------------------------------------
  155. %install
  156. rm -rf %{buildroot}
  157. make install DESTDIR=%{buildroot}
  158. # Remove autocrap and libtool droppings
  159. find %{buildroot} -name '*.la' -exec rm -f {} \;
  160. mkdir -p %{buildroot}%{_sysconfdir}/bluetooth/
  161. mkdir -p %{buildroot}%{_libdir}/bluetooth/
  162. mkdir -p %{buildroot}%{_sbindir}
  163. # "make install" fails to install gatttool, necessary for Bluetooth Low Energy
  164. # Red Hat Bugzilla bug #1141909, Debian bug #720486
  165. install -m0755 attrib/gatttool $RPM_BUILD_ROOT%{_bindir}
  166. # "make install" fails to install avinfo
  167. # Red Hat Bugzilla bug #1699680
  168. install -m0755 tools/avinfo $RPM_BUILD_ROOT%{_bindir}
  169. # btmgmt is not installed by "make install", but it is useful for debugging
  170. # some issues and to set the MAC address on HCIs which don't have their
  171. # MAC address configured
  172. install -m0755 tools/btmgmt $RPM_BUILD_ROOT%{_bindir}
  173. rm -f ${RPM_BUILD_ROOT}/%{_sysconfdir}/udev/*.rules ${RPM_BUILD_ROOT}/usr/lib/udev/rules.d/*.rules
  174. install -D -p -m0644 tools/hid2hci.rules ${RPM_BUILD_ROOT}/%{_udevrulesdir}/97-hid2hci.rules
  175. install -d -m0755 $RPM_BUILD_ROOT/%{_localstatedir}/lib/bluetooth
  176. %if %{with systemd}
  177. install -d -m0755 $RPM_BUILD_ROOT/%{_localstatedir}/lib/bluetooth/mesh
  178. #serial port connected Broadcom HCIs scripts
  179. install -D -p -m0644 %{SOURCE22} %{buildroot}/%{_udevrulesdir}/
  180. install -D -p -m0644 %{SOURCE23} %{buildroot}/%{_unitdir}/
  181. install -D -p -m0755 %{SOURCE24} %{buildroot}/%{_libexecdir}/bluetooth/
  182. %else
  183. install -D -m0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/bluetooth
  184. ln -s ../libexec/bluetooth/bluetoothd %{buildroot}%{_sbindir}/bluetoothd
  185. %endif
  186. #copy bluetooth config file and setup auto enable
  187. chmod 755 %{buildroot}/etc/bluetooth
  188. install -D -p -m0644 src/main.conf %{buildroot}/etc/bluetooth/main.conf
  189. install -D -p -m0644 mesh/mesh-main.conf %{buildroot}/etc/bluetooth/mesh-main.conf
  190. sed -i 's/#\[Policy\]$/\[Policy\]/; s/#AutoEnable=false/AutoEnable=true/' %{buildroot}/%{_sysconfdir}/bluetooth/main.conf
  191. install -D -m0755 %{SOURCE3} %{buildroot}%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
  192. #----------------------------------------------------------------------------
  193. %post
  194. %if %{with systemd}
  195. %systemd_post bluetooth.service
  196. %systemd_user_post bluetooth-mesh.service
  197. %systemd_user_post obex.service
  198. /bin/udevadm trigger --subsystem-match=usb
  199. %else
  200. /sbin/chkconfig --add bluetooth
  201. /sbin/udevadm trigger --subsystem-match=usb
  202. %endif
  203. exit 0
  204. %preun
  205. %if %{with systemd}
  206. %systemd_preun bluetooth.service
  207. %systemd_user_preun bluetooth-mesh.service
  208. %systemd_user_preun obex.service
  209. %else
  210. if [ "$1" = "0" -o -x /usr/bin/systemctl ]; then
  211. /sbin/service bluetooth stop >/dev/null 2>&1 || :
  212. /sbin/chkconfig --del bluetooth
  213. fi
  214. exit 0
  215. %endif
  216. %postun
  217. %if %{with systemd}
  218. %systemd_postun_with_restart bluetooth.service
  219. %else
  220. if [ "$1" -ge "0" ]; then
  221. /sbin/service bluetooth condrestart >/dev/null 2>&1 || :
  222. fi
  223. %endif
  224. #----------------------------------------------------------------------------
  225. %files
  226. %license COPYING
  227. %doc AUTHORS INSTALL ChangeLog NEWS README
  228. %dir %{_sysconfdir}/bluetooth/
  229. %config(noreplace) %{_sysconfdir}/bluetooth/*
  230. %{_datadir}/dbus-1/system.d/bluetooth.conf
  231. %{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
  232. %{_bindir}/*
  233. %exclude %{_bindir}/isotest
  234. %exclude %{_bindir}/l2test
  235. %exclude %{_bindir}/l2ping
  236. %exclude %{_bindir}/rctest
  237. %{_libexecdir}/bluetooth/bluetoothd
  238. %{_libexecdir}/bluetooth/obexd
  239. %dir %{_libdir}/bluetooth
  240. %{_mandir}/man1/*
  241. %exclude %{_mandir}/man1/isotest.1.*
  242. %exclude %{_mandir}/man1/l2ping.1.*
  243. %exclude %{_mandir}/man1/rctest.1.*
  244. %{_mandir}/man8/*
  245. /usr/lib/udev/hid2hci
  246. %{_udevrulesdir}/97-hid2hci.rules
  247. %dir %{_datadir}/zsh
  248. %dir %{_datadir}/zsh/site-functions
  249. %{_datadir}/zsh/site-functions/_bluetoothctl
  250. %dir %{_localstatedir}/lib/bluetooth
  251. %if %{with systemd}
  252. %{_unitdir}/bluetooth.service
  253. %{_unitdir}/btattach-bcm@.service
  254. %{_libexecdir}/bluetooth/btattach-bcm-service.sh
  255. %{_udevrulesdir}/69-btattach-bcm.rules
  256. %{_userunitdir}/obex.service
  257. %{_datadir}/dbus-1/system-services/org.bluez.service
  258. %{_datadir}/dbus-1/services/org.bluez.obex.service
  259. # mesh files
  260. %doc tools/mesh-gatt/*.json
  261. %config %{_sysconfdir}/dbus-1/system.d/bluetooth-mesh.conf
  262. %{_datadir}/dbus-1/system-services/org.bluez.mesh.service
  263. %{_libexecdir}/bluetooth/bluetooth-meshd
  264. %{_unitdir}/bluetooth-mesh.service
  265. %dir %{_localstatedir}/lib/bluetooth/mesh
  266. %else
  267. %{_sysconfdir}/rc.d/init.d/bluetooth
  268. %{_sbindir}/bluetoothd
  269. %endif
  270. %files libs
  271. %{_libdir}/libbluetooth.so.*
  272. %files libs-devel
  273. %{_bindir}/isotest
  274. %{_bindir}/l2test
  275. %{_bindir}/l2ping
  276. %{_bindir}/rctest
  277. %{_libdir}/libbluetooth.so
  278. %dir %{_includedir}/bluetooth
  279. %{_includedir}/bluetooth/*
  280. %{_libdir}/pkgconfig/bluez.pc
  281. %{_mandir}/man1/isotest.1.*
  282. %{_mandir}/man1/l2ping.1.*
  283. %{_mandir}/man1/rctest.1.*
  284. %{_mandir}/man5/org.bluez.*.5*
  285. %files cups
  286. %{_libdir}/cups/backend/bluetooth
  287. %changelog
  288. * Sun Jul 07 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.76-1
  289. - updated to 5.76.
  290. * Tue Nov 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.62-1
  291. - updated to 5.62.
  292. * Tue Jun 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.59-1
  293. - updated to 5.59.
  294. - dropped ldconfig scriptlets.
  295. * Thu Oct 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.55-1
  296. - updated to 5.55.
  297. - added systemd support (disabled as default).
  298. * Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.54-1
  299. - updated to 5.54.
  300. - updated all patches.
  301. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.50-1
  302. - updated to 5.50.
  303. * Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.48-1
  304. - updated to 5.48.
  305. * Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.35-1
  306. - update to 5.35
  307. - remove %%{name}-gstreamer, %%{name}-alsa subpackages
  308. - add Patch0 (bluez-5.35-obexd_without_systemd-1.patch)
  309. - add Patch100 (bluez-5.35-daemon.patch)
  310. - add Patch101 (bluez-5.35-config-vine.patch)
  311. * Sat Jul 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-5
  312. - rebuild with readline-6.3
  313. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-4
  314. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  315. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-3
  316. - rebuild with VineSeed environment
  317. * Thu Jul 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.101-2
  318. - build with sbc
  319. - add BR: sbc-devel
  320. * Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-1
  321. - new upstream release
  322. * Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.99-1
  323. - new upstream release
  324. * Thu Feb 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.98-1
  325. - new upstream release
  326. * Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.97-1
  327. - new upstream release
  328. - add BuildRequires: check-devel, readline-devel
  329. * Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.96-1
  330. - new upstream release
  331. - add BuildRequires: libudev-devel
  332. * Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.89-1
  333. - new upstream release
  334. * Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.87-1
  335. - new upstream release
  336. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.84-1
  337. - new upstream release
  338. * Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.82-1
  339. - new upstream release
  340. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.81-1
  341. - new upstream release
  342. * Tue Nov 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.79-1
  343. - new upstream release
  344. - drop Patch2
  345. * Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.77-1
  346. - new upstream release
  347. - fix %files (change path of alsa/bluetooth.conf)
  348. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-2
  349. - rebuild with rpm-4.8.1 for pkg-config file
  350. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-1
  351. - new upstream release
  352. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.66-1
  353. - new upstream release
  354. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.64-1
  355. - new upstream release
  356. - drop Patch1, Patch5, Patch6
  357. * Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-2
  358. - add bluetooth.init again.
  359. - on-demand startup on bootup process will fail, because
  360. D-BUS service is not started yet.
  361. * Sun Jun 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-1
  362. - new upstream release
  363. * Mon Jun 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-2
  364. - remove bluetooth.init
  365. - on-demand start/stop bluetoothd using udev
  366. - run hid2hci using udev
  367. - add missing files to %%files
  368. * Fri Jun 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-1
  369. - new upstream release
  370. - add udev rule
  371. - add upstream Patch[2-6]
  372. * Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.37-1
  373. - new upstream release
  374. * Fri Oct 24 2008 Seiichirou Babasaki 4.15-1
  375. - Update to 4.15
  376. - added # Maintainers: comments.
  377. - FedoraCore - LOGS
  378. -- 4.14-2
  379. -- Add script to autoload uinput on startup, so the PS3 remote
  380. works out-of-the-box
  381. -- 4.14-1 - Update to 4.14
  382. -- 4.13-3
  383. -- Update udev rules (#246840)
  384. -- 4.13-2
  385. -- Fix PS3 BD remote input event generation
  386. -- 4.13-1 - Update to 4.13
  387. -- 4.12-1 - Update to 4.12
  388. -- 4.11-1 - Update to 4.11
  389. -- 4.10-1 - Update to 4.10
  390. -- 4.9-1 - Update to 4.9
  391. -- 4.8-1 - Update to 4.8
  392. -- 4.7-1 - Update to 4.7
  393. -- 4.6-4
  394. -- Fix patch application
  395. -- 4.6-3
  396. -- Add fuzz
  397. -- 4.6-2
  398. -- Fix possible crasher on resume from suspend
  399. -- 4.6-1 - Update to 4.6
  400. -- 4.5-4
  401. -- SDP browse fixes
  402. -- 4.5-3
  403. -- Bluez-alsa needs to provide/obsolete bluez-utils-alsa
  404. -- Use versioned Obsoletes:
  405. -- 4.5-2
  406. -- Change main utils package name to 'bluez'; likewise its subpackages
  407. -- Remove references to obsolete initscripts (hidd,pand,dund)
  408. -- 4.5-1
  409. -- Update to 4.5
  410. -- Fix initscript to actually start bluetoothd by hand
  411. -- Add chkconfig information to the initscript
  412. -- 4.4-2
  413. -- Fix rpmlint problems
  414. -- Fix input device handling
  415. -- 4.4-1
  416. -- Update to 4.4
  417. -- Update source address, and remove unneeded deps (thanks Marcel)
  418. -- 4.1-1
  419. -- Initial build
  420. - updated specfile
  421. - VineLinux-4.2 logfile
  422. -- *Thu Oct 2 2008 Seiichirou Babasaki 3.24-4
  423. -- update bleuz-gnome, rebuild bluez-utils
  424. -- Requires: fuse
  425. -- updated specfile
  426. -- *Tue Sep 30 2008 Seiichirou Babasaki 3.24-3
  427. -- trusts.txt update (added audio profile)
  428. -- updated specfile
  429. #----------------------------------------------------------------------------
  430. * Fri Sep 26 2008 Seiichirou Babasaki 3.32-2
  431. - *.conf update
  432. - updated specfile
  433. * Fri Jun 13 2008 Seiichirou Babasaki 3.32-1
  434. - Updated 3.32
  435. - Updated specfile
  436. - ** LOGS 3.31-2
  437. - ** Add a .service file, starting up hcid only when used (#446918)
  438. - ** Fix descriptions in the initscript headers (#433647)
  439. - ** LOGS 3.30-2
  440. - ** Add support for Dell HID/HCI switch
  441. - ** LOGS 3.27-1
  442. - ** Ship audio.conf (#278831)
  443. - ** Ship network service
  444. * Sat Jan 26 2008 Seiichirou Babasaki 3.24-2
  445. - Updated specfile
  446. - marge bluez-utils-3.24-conf-vl.patch
  447. - << bluez-utils-2.3-conf.patch
  448. - add trusts.txt(ja)
  449. - Updated specfile
  450. * Mon Jan 21 2008 Seiichirou Babasaki 3.24-1vl2
  451. - Updated specfile for (dbus-devel >= 0.90)
  452. * Wed Jan 16 2008 Seiichirou Babasaki 3.24-1vl1
  453. - Import bluez-utils - Packager: Babasaki
  454. - Updated specfile for (dbus-devel >= 0.60)
  455. - Update to 3.24