autoconf-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. # run "make check" by default
  2. %bcond_without check
  3. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  4. Summary: A GNU tool for automatically configuring source code.
  5. Summary(ja): ソースコードを自動的に設定するための GNU ツール
  6. Name: autoconf
  7. Version: 2.72
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: GPL
  13. URL: https://www.gnu.org/software/autoconf/
  14. Source: https://ftp.gnu.org/pub/gnu/autoconf/autoconf-%{version}.tar.xz
  15. # Vine Source(s)
  16. Source10: autoconf-mode-install.sh
  17. Source11: autoconf-mode-remove.sh
  18. Requires(post,preun): /sbin/install-info
  19. Requires: gawk, m4, mktemp, perl, textutils
  20. Obsoletes: autoconf253 < 2.54
  21. BuildArch: noarch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. %description
  24. GNU's Autoconf is a tool for configuring source code and Makefiles.
  25. Using Autoconf, programmers can create portable and configurable
  26. packages, since the person building the package is allowed to
  27. specify various configuration options.
  28. You should install Autoconf if you are developing software and
  29. would like to create shell scripts that configure your source code
  30. packages. If you are installing Autoconf, you will also need to
  31. install the GNU m4 package.
  32. Note that the Autoconf package is not required for the end-user who
  33. may be configuring software with an Autoconf-generated script;
  34. Autoconf is only required for the generation of the scripts, not
  35. their use.
  36. %description -l ja
  37. GNU autoconf はソースコードと Makefile を自動的に設定する GNU ツール
  38. です.Autoconf を使えば,プログラマは移植や設定が容易なパッケージを
  39. 作ることができます.そのため,パッケージ作成者はさまざまな設定
  40. オプションを指定できます。
  41. ソフトウェアを開発していてソースコードパッケージを設定するシェル
  42. スクリプトを生成したいとお考えなら,Autoconf をインストールしてください.
  43. Autoconf をインストールするためには GNU m4 パッケージもインストールする
  44. 必要があります.
  45. Autoconf が生成したスクリプトを使ってソフトウェアを設定するかもしれない
  46. エンドユーザには Autoconf パッケージが必要ないことに注目してください.
  47. Autoconf が必要になるのはスクリプトを生成するときのみで,使うときには
  48. 必要ありません.
  49. %package mode
  50. Summary: Emacs-lisp autoconf-mode for autoconf/autotest
  51. Group: programming
  52. BuildRequires: emacs
  53. %prereq_ge emacsen-common
  54. Requires: emacsen
  55. %description mode
  56. Emacs-lisp autoconf-mode for autoconf/autotest
  57. %prep
  58. %setup -q -n autoconf-%{version}
  59. %build
  60. %configure
  61. make %{?_smp_mflags}
  62. %install
  63. rm -rf ${RPM_BUILD_ROOT}
  64. %makeinstall
  65. gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/autoconf.info*
  66. # We don't want to include the standards.info stuff in the package,
  67. # because it comes from binutils...
  68. rm -f ${RPM_BUILD_ROOT}%{_infodir}/standards*
  69. # cp install-sh ${RPM_BUILD_ROOT}%{_datadir}/autoconf
  70. # remove info dir file since it isn't packaged
  71. rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  72. # move elisp files
  73. pushd ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp
  74. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/autoconf-mode
  75. mv *.el autoconf-mode/
  76. popd
  77. # emacsen-common-ize
  78. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/autoconf-mode
  79. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  80. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  81. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  82. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  83. %_installemacsenscript autoconf-mode %{SOURCE10}
  84. %_removeemacsenscript autoconf-mode %{SOURCE11}
  85. rm -f %{buildroot}%{_datadir}/emacs/site-lisp/auto*-mode.elc
  86. %check
  87. %if %{with check}
  88. make check %{?_smp_mflags}
  89. %endif
  90. %post mode
  91. if [ "$1" = 2 ]; then
  92. %_emacsenPackageRemove autoconf-mode
  93. fi
  94. %_addemacsenlist autoconf-mode
  95. %_emacsenPackageInstall autoconf-mode
  96. %preun mode
  97. if [ "$1" = 0 ]; then
  98. %_emacsenPackageRemove autoconf-mode
  99. %_removeemacsenlist autoconf-mode
  100. fi
  101. %files
  102. %defattr(-,root,root)
  103. %doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
  104. %{_bindir}/*
  105. %{_infodir}/*.info*
  106. %{_datadir}/autoconf
  107. %{_mandir}/man1/*
  108. %files mode
  109. %defattr(-,root,root)
  110. %{_datadir}/emacs/site-lisp/autoconf-mode/
  111. #/usr/lib/emacsen-common/packages/install/autoconf-mode
  112. #/usr/lib/emacsen-common/packages/remove/autoconf-mode
  113. %{emacsen_pkgdir}/install/autoconf-mode
  114. %{emacsen_pkgdir}/remove/autoconf-mode
  115. %changelog
  116. * Sun Jul 07 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.72-1
  117. - updated to 2.72.
  118. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.71-1
  119. - updated to 2.71.
  120. - dropped Patch1 and 3: fixed in upstream.
  121. - updated Patch2.
  122. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.69-2
  123. - added Patch1-3.
  124. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.69-1
  125. - update to 2.69
  126. * Sun Nov 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.68-1
  127. - new upstream release
  128. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.65-2
  129. - rebuilt with rpm-4.8.1-3
  130. * Sun Apr 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.65-1
  131. - new upstream release
  132. * Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.63-1
  133. - new upstream release
  134. - dropped Patch0 (merged into upstream)
  135. * Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 2.62-3
  136. - added %%emacsen_pkgdir macro
  137. - spec in utf-8
  138. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.62-2
  139. - import Patch0 from Fedora 2.62-2
  140. * Fri Jun 06 2008 Karsten Hopp <karsten@redhat.com> 2.62-2
  141. - add upstream fix from Eric Blake for #449973,
  142. m4_if releated error message from autotest
  143. * Sun May 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.62-1
  144. - new upstream release
  145. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.61-0vl1
  146. - new upstream release
  147. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.59-2vl4
  148. - changed autoconf-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  149. - added Japanese summary and description from vinedocs.sourceforge.jp
  150. - s/Copyright/License/
  151. * Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 2.59-2vl3
  152. - rebuild
  153. * Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl2
  154. - rebuild
  155. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.59-2vl1
  156. - update to 2.59 bugfix release
  157. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.58-0vl1
  158. - new upstream release
  159. * Tue Apr 08 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.57-3vl1
  160. - source update
  161. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl2
  162. - don't show annoying messages during elisp compilation
  163. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.56-1vl1
  164. - based on 2.56-1 from Rawhide and built for Vine Linux
  165. - emacsen-common-ize
  166. * Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 2.56-1
  167. - update to 2.56
  168. - obsolete autoheader-warn patch
  169. - no longer provide autoconf253
  170. - include site-lisp and man files
  171. - remove info dir which is not in the manifest
  172. - do not version suffix bin files for now
  173. * Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 2.53-8
  174. - make check
  175. * Fri Jun 28 2002 Jens Petersen <petersen@redhat.com> 2.53-7
  176. - update url (#66840)
  177. - added doc files
  178. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.53-6
  179. - automated rebuild
  180. * Sun May 26 2002 Tim Powers <timp@redhat.com> 2.53-5
  181. - automated rebuild
  182. * Mon May 20 2002 Bill Nottingham <notting@redhat.com> 2.53-4
  183. - provide autoconf253
  184. * Thu May 16 2002 Bill Nottingham <notting@redhat.com> 2.53-3
  185. - obsolete autoconf253
  186. * Wed May 8 2002 Jens Petersen <petersen@redhat.com> 2.53-2
  187. - patch autoheader so that --warnings=CATEGORY works (#64566)
  188. [reported with fix by hjl@gnu.org]
  189. * Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 2.53-1
  190. - update to autoconf-2.53
  191. - drop mawk patch again
  192. - version suffix bindir files and add symlinks to unversioned names
  193. * Fri Feb 1 2002 Jens Petersen <petersen@redhat.com> 2.52-7
  194. - revert to 2.52 (also fixes #58210!)
  195. - remove relversion variable
  196. - bring back mawk -> gawk patch
  197. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.52-6
  198. - automated rebuild
  199. * Thu Dec 20 2001 Jens Petersen <petersen@redhat.com> 2.52-5
  200. - update to 2.52f
  201. - add URL
  202. - minor description improvements
  203. - define relversion to carry version number
  204. - mawk.patch no longer needed
  205. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-4
  206. - rebuild
  207. * Wed Sep 19 2001 Jens Petersen <petersen@redhat.com> 2.52-3
  208. - restore patch to prefer gawk to mawk
  209. * Tue Sep 18 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.52-2
  210. - update to 2.52d
  211. * Mon Sep 17 2001 Jens Petersen <petersen@redhat.com> 2.52-1
  212. - update to 2.52
  213. - remove obsolete patches, since already new version
  214. - dont install install-sh
  215. * Tue Jul 10 2001 Jens Petersen <petersen@redhat.com>
  216. - add patch to include various standard C headers as needed
  217. by various autoconf tests (#19114)
  218. - add patch to autoscan.pl to get a better choice of init
  219. file (#42071), to test for CPP after CC (#42072) and to
  220. detect C++ source and g++ (#42073).
  221. * Tue Jun 26 2001 Jens Petersen <petersen@redhat.com>
  222. - Add a back-port of _AC_PROG_CXX_EXIT_DECLARATION
  223. from version 2.50 to make detection of C++ exit()
  224. declaration prototype platform independent. The check is
  225. done in AC_PROG_CXX with the result stored in "confdefs.h".
  226. The exit() prototype in AC_TRY_RUN_NATIVE is no longer needed.
  227. (fixes #18829)
  228. * Wed Nov 29 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  229. - Fix up interoperability with glibc 2.2 and gcc 2.96:
  230. AC_TRY_RUN_NATIVE in C++ mode added a prototype for exit() to
  231. the test code without throwing an exception, causing a conflict
  232. with stdlib.h --> AC_TRY_RUN_NATIVE for C++ code including stdlib.h
  233. always failed, returning wrong results
  234. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  235. - add textutils as a dependency (#14439)
  236. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  237. - automatic rebuild
  238. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  239. - FHS packaging.
  240. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  241. - fix preun
  242. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  243. - add patch to help autoconf clean after itself and not leave /tmp clobbered
  244. with acin.* and acout.* files (can you say annoying?)
  245. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  246. - auto rebuild in the new build environment (release 4)
  247. - use gawk, not mawk
  248. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  249. - moved /usr/lib/autoconf to /usr/share/autoconf (with automake)
  250. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  251. - Injected new description and group.
  252. * Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
  253. - update to 2.13.
  254. * Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
  255. - build against glibc 2.1
  256. * Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
  257. - requires perl
  258. * Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
  259. - patch for fixing /tmp race conditions
  260. * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
  261. - spec file cleanups
  262. - made a noarch package
  263. - uses autoconf
  264. - uses install-info
  265. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  266. - built with glibc