audit-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: User space tools for kernel auditing
  5. Name: audit
  6. Version: 4.0.2
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. License: GPLv2+
  9. Group: system,admin-tools
  10. Distribution: Vine Linux
  11. Vendor: Project Vine
  12. URL: https://people.redhat.com/sgrubb/audit/
  13. Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
  15. Source2: auditd.init
  16. Source3: auditd.sysconfig
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: gettext intltool libtool swig
  19. BuildRequires: python-devel python-rpm-macros
  20. BuildRequires: python3-devel python3-rpm-macros
  21. BuildRequires: openldap-devel
  22. BuildRequires: krb5-devel
  23. BuildRequires: kernel-headers >= 2.6.18
  24. BuildRequires: libcap-ng-devel
  25. BuildRequires: automake >= 1.9
  26. BuildRequires: autoconf >= 2.59
  27. %if %{with systemd}
  28. %{?systemd_requires}
  29. %else
  30. Requires(post): /sbin/chkconfig
  31. Requires(preun): /sbin/chkconfig
  32. Requires(preun): /sbin/service
  33. Requires(postun): /sbin/service
  34. %endif
  35. Requires: %{name}-libs = %{version}-%{release}
  36. Requires: %{name}-rules = %{version}-%{release}
  37. Requires(pre): coreutils
  38. %description
  39. The audit package contains the user space utilities for
  40. storing and searching the audit records generate by
  41. the audit subsystem in the Linux kernel.
  42. %package libs
  43. Summary: Dynamic library for libaudit
  44. License: LGPLv2+
  45. Group: system
  46. %description libs
  47. The audit-libs package contains the dynamic libraries needed for
  48. applications to use the audit framework.
  49. %package libs-devel
  50. Summary: Header files and static library for libaudit
  51. License: LGPLv2+
  52. Group: programming
  53. Requires: %{name}-libs = %{version}-%{release}
  54. Requires: kernel-headers >= 2.6.18
  55. %description libs-devel
  56. The audit-libs-devel package contains the static libraries and header
  57. files needed for developing applications that need to use the audit
  58. framework libraries.
  59. %package libs-python3
  60. Summary: Python3 bindings for libaudit
  61. License: LGPLv2+
  62. Group: programming
  63. Provides: python-audit = %{version}-%{release}
  64. Requires: %{name}-libs = %{version}-%{release}
  65. %description libs-python3
  66. The audit-libs-python3 package contains the bindings so that libaudit
  67. and libauparse can be used by python3.
  68. %package -n audispd-plugins
  69. Summary: Plugins for the audit event dispatcher
  70. Group: system
  71. License: GPLv2+
  72. Provides: python3-audit = %{version}-%{release}
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: %{name}-libs = %{version}-%{release}
  75. %description -n audispd-plugins
  76. The audispd-plugins package provides plugins for the real-time
  77. interface to the audit system, audispd. These plugins can do things
  78. like relay events to remote machines or analyze events for suspicious
  79. behavior.
  80. %package -n audispd-plugins-zos
  81. Summary: z/OS plugin for the audit event dispatcher
  82. Group: system
  83. License: GPLv2+
  84. Requires: %{name}%{?_isa} = %{version}-%{release}
  85. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  86. Requires: openldap
  87. %description -n audispd-plugins-zos
  88. The audispd-plugins-zos package provides a plugin that will forward all
  89. incoming audit events, as they happen, to a configured z/OS SMF (Service
  90. Management Facility) database, through an IBM Tivoli Directory Server
  91. (ITDS) set for Remote Audit service.
  92. %package rules
  93. Summary: audit rules and utilities
  94. License: GPLv2+
  95. Recommends: %{name} = %{version}-%{release}
  96. %description rules
  97. The audit rules package contains the rules and utilities to load audit rules.
  98. %package -n compat32-%{name}-libs
  99. Summary: Dynamic library for libaudit
  100. License: LGPLv2+
  101. Group: system,legacy
  102. %description -n compat32-%{name}-libs
  103. The audit-libs package contains the dynamic libraries needed for
  104. applications to use the audit framework.
  105. %debug_package
  106. %prep
  107. %setup -q -n audit-userspace-%{version}
  108. cp %{SOURCE1} .
  109. autoreconf -vif
  110. # Remove the ids code, its not ready
  111. sed -i 's/ ids / /' audisp/plugins/Makefile.am
  112. sed -i 's/ ids / /' audisp/plugins/Makefile.in
  113. %build
  114. %configure --sbindir=/sbin --libdir=/%{_lib} \
  115. --with-python=yes --with-python3=yes \
  116. --with-libcap-ng=yes --enable-gssapi-krb5=yes \
  117. --enable-zos-remote \
  118. --enable-experimental \
  119. --with-io_uring \
  120. %if %{with systemd}
  121. --enable-systemd
  122. %else
  123. %{nil}
  124. %endif
  125. make CFLAGS="%{optflags}" %{?_smp_mflags}
  126. %install
  127. rm -rf $RPM_BUILD_ROOT
  128. mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audit/plugins.d,rc.d/init.d,audit/rules.d}}
  129. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
  130. mkdir -p $RPM_BUILD_ROOT/%{_lib}
  131. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
  132. mkdir -p --mode=0700 $RPM_BUILD_ROOT/%{_var}/log/audit
  133. mkdir -p $RPM_BUILD_ROOT/%{_var}/spool/audit
  134. make DESTDIR=$RPM_BUILD_ROOT install
  135. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  136. # This winds up in the wrong place when libtool is involved
  137. mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
  138. mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
  139. curdir=`pwd`
  140. cd $RPM_BUILD_ROOT/%{_libdir}
  141. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
  142. ln -s ../../%{_lib}/$LIBNAME libaudit.so
  143. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
  144. ln -s ../../%{_lib}/$LIBNAME libauparse.so
  145. cd $curdir
  146. # Remove these items so they don't get picked up.
  147. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
  148. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
  149. find $RPM_BUILD_ROOT -name '*.la' -delete
  150. # Move the pkgconfig file
  151. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  152. # On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
  153. touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
  154. touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
  155. %if %{with systemd}
  156. rm -rf %{buildroot}%{_libexecdir}/initscripts
  157. rm -f %{buildroot}%{_libexecdir}/audit-functions
  158. %else
  159. mkdir -p %{buildroot}%{_initdir}
  160. install -m755 %{SOURCE2} %{buildroot}%{_initdir}/auditd
  161. mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
  162. install -m640 %{SOURCE3} %{buildroot}%{_sysconfdir}/sysconfig/auditd
  163. rm -rf %{buildroot}/usr/lib/systemd
  164. rm -rf %{buildroot}%{_libexecdir}/initscripts
  165. %endif
  166. %check
  167. #make check
  168. # Get rid of make files so that they don't get packaged.
  169. #rm -f rules/Makefile*
  170. %clean
  171. rm -rf $RPM_BUILD_ROOT
  172. rm -rf zos-remote-policy
  173. %post
  174. # This is to migrate users from audit-1.0.x installations
  175. if [ -f /etc/auditd.conf ]; then
  176. mv /etc/auditd.conf /etc/audit/auditd.conf
  177. fi
  178. if [ -f /etc/audit.rules ]; then
  179. mv /etc/audit.rules /etc/audit/audit.rules
  180. fi
  181. # This is to enable the dispatcher option which was commented out
  182. if [ -f /etc/audit/auditd.conf ]; then
  183. grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
  184. if [ $? -eq 1 ] ; then
  185. tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
  186. if [ -n $tmp ]; then
  187. sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
  188. cat $tmp > /etc/audit/auditd.conf
  189. rm -f $tmp
  190. fi
  191. fi
  192. fi
  193. # Copy default rules into place on new installation
  194. files=`ls /etc/audit/rules.d/ 2>/dev/null | wc -w`
  195. if [ "$files" -eq 0 ] ; then
  196. # FESCO asked for audit to be off by default. #1117953
  197. if [ -e %{_datadir}/%{name}/sample-rules/10-no-audit.rules ] ; then
  198. cp %{_datadir}/%{name}/sample-rules/10-no-audit.rules /etc/audit/rules.d/audit.rules
  199. else
  200. touch /etc/audit/rules.d/audit.rules
  201. fi
  202. chmod 0600 /etc/audit/rules.d/audit.rules
  203. fi
  204. %if %{with systemd}
  205. %systemd_post auditd.service
  206. %else
  207. /sbin/chkconfig --add auditd
  208. %endif
  209. %post rules
  210. %systemd_post audit-rules.service
  211. # Copy default rules into place on new installation
  212. files=`ls /etc/audit/rules.d/ 2>/dev/null | wc -w`
  213. if [ "$files" -eq 0 ] ; then
  214. echo "No rules detected, adding default"
  215. # FESCO asked for audit to be off by default. #1117953
  216. if [ -e %{_datadir}/%{name}-rules/10-no-audit.rules ] ; then
  217. install -m 0600 -o 0 -g 0 -p %{_datadir}/%{name}-rules/10-no-audit.rules /etc/audit/rules.d/audit.rules
  218. else
  219. install -m 0600 -o 0 -g 0 /dev/null /etc/audit/rules.d/audit.rules
  220. fi
  221. # Only load the new rules if not running during an rpm-ostree compose
  222. if [ ! -f /run/ostree-booted ] ; then
  223. # Make the new rules active
  224. augenrules --load || true
  225. fi
  226. fi
  227. %preun
  228. %if %{with systemd}
  229. %systemd_preun auditd.service
  230. %else
  231. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  232. /sbin/service auditd stop > /dev/null 2>&1
  233. /sbin/chkconfig --del auditd
  234. fi
  235. %endif
  236. %if %{with systemd}
  237. %preun rules
  238. %systemd_preun audit-rules.service
  239. # If uninstalling, delete the rules loaded in the kernel
  240. if [ $1 -eq 0 ] ; then
  241. auditctl -D > /dev/null 2>&1 || true
  242. fi
  243. %endif
  244. %postun
  245. %if %{with systemd}
  246. %systemd_postun_with_restart auditd.service
  247. %else
  248. if [ $1 -ge 1 ]; then
  249. /sbin/service auditd condrestart > /dev/null 2>&1 || :
  250. fi
  251. %endif
  252. %files libs
  253. %defattr(-,root,root)
  254. %{!?_licensedir:%global license %%doc}
  255. %license lgpl-2.1.txt
  256. /%{_lib}/libaudit.*
  257. /%{_lib}/libauparse.*
  258. %config(noreplace) %attr(640,root,root) /etc/libaudit.conf
  259. %{_mandir}/man5/libaudit.conf.5.gz
  260. %files libs-devel
  261. %defattr(-,root,root)
  262. %{!?_licensedir:%global license %%doc}
  263. %license COPYING.LIB
  264. %doc contrib/skeleton.c contrib/plugin
  265. %{_libdir}/libaudit.a
  266. %{_libdir}/libauparse.a
  267. %{_libdir}/libaudit.so
  268. %{_libdir}/libauparse.so
  269. %{_includedir}/libaudit.h
  270. %{_includedir}/audit_logging.h
  271. %{_includedir}/audit-records.h
  272. %{_includedir}/auparse.h
  273. %{_includedir}/auparse-defs.h
  274. %{_datadir}/aclocal/audit.m4
  275. %{_libdir}/pkgconfig/audit.pc
  276. %{_libdir}/pkgconfig/auparse.pc
  277. %{_mandir}/man3/*
  278. %files libs-python3
  279. %defattr(-,root,root,-)
  280. %attr(755,root,root) %{python3_sitearch}/*
  281. %files
  282. %defattr(-,root,root,-)
  283. %doc README.md ChangeLog init.d/auditd.cron
  284. %{!?_licensedir:%global license %%doc}
  285. %license COPYING
  286. %attr(644,root,root) %{_mandir}/man8/auditd.8.gz
  287. %attr(644,root,root) %{_mandir}/man8/aureport.8.gz
  288. %attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
  289. %attr(644,root,root) %{_mandir}/man8/aulast.8.gz
  290. %attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
  291. %attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
  292. %attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
  293. %attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
  294. %attr(644,root,root) %{_mandir}/man5/auditd-plugins.5.gz
  295. %attr(750,root,root) /sbin/auditd
  296. %attr(755,root,root) /sbin/ausearch
  297. %attr(755,root,root) /sbin/aureport
  298. %attr(750,root,root) %{_bindir}/aulastlog
  299. %attr(750,root,root) %{_bindir}/aulast
  300. %attr(755,root,root) %{_bindir}/ausyscall
  301. %attr(750,root,root) %dir %{_var}/log/audit
  302. %attr(750,root,root) %dir /etc/audit
  303. %attr(750,root,root) %dir /etc/audit/rules.d
  304. %attr(750,root,root) %dir /etc/audit/plugins.d
  305. %config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
  306. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
  307. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
  308. %config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
  309. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/af_unix.conf
  310. %if %{with systemd}
  311. %attr(644,root,root) %{_unitdir}/auditd.service
  312. %else
  313. %config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
  314. %attr(755,root,root) /etc/rc.d/init.d/auditd
  315. %endif
  316. %files rules
  317. %attr(755,root,root) %dir %{_datadir}/%{name}-rules
  318. %attr(644,root,root) %{_datadir}/%{name}-rules/*
  319. %attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
  320. %attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
  321. %attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
  322. %attr(750,root,root) /sbin/auditctl
  323. %attr(755,root,root) /sbin/augenrules
  324. %if %{with systemd}
  325. %attr(644,root,root) %{_unitdir}/audit-rules.service
  326. %endif
  327. %attr(750,root,root) %dir /etc/audit
  328. %attr(750,root,root) %dir /etc/audit/rules.d
  329. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
  330. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
  331. %config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
  332. %files -n audispd-plugins
  333. %defattr(-,root,root,-)
  334. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-remote.conf
  335. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-remote.conf
  336. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/syslog.conf
  337. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-statsd.conf
  338. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-statsd.conf
  339. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/af_unix.conf
  340. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-filter.conf
  341. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/filter.conf
  342. %attr(750,root,root) /sbin/audisp-remote
  343. %attr(750,root,root) /sbin/audisp-syslog
  344. %attr(750,root,root) /sbin/audisp-af_unix
  345. %attr(750,root,root) /sbin/audisp-statsd
  346. %attr(750,root,root) /sbin/audisp-filter
  347. %attr(700,root,root) %dir %{_var}/spool/audit
  348. %attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
  349. %attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
  350. %attr(644,root,root) %{_mandir}/man8/audisp-syslog.8.gz
  351. %attr(644,root,root) %{_mandir}/man8/audisp-af_unix.8.gz
  352. %attr(644,root,root) %{_mandir}/man8/audisp-statsd.8.gz
  353. %attr(644,root,root) %{_mandir}/man8/audisp-filter.8.gz
  354. %files -n audispd-plugins-zos
  355. %attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
  356. %attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
  357. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/audispd-zos-remote.conf
  358. %config(noreplace) %attr(640,root,root) /etc/audit/zos-remote.conf
  359. %attr(750,root,root) /sbin/audispd-zos-remote
  360. %if %{build_compat32}
  361. %files -n compat32-%{name}-libs
  362. %{!?_licensedir:%global license %%doc}
  363. %license COPYING.LIB
  364. %defattr(-,root,root)
  365. %attr(755,root,root) /%{_lib}/libaudit.*
  366. %attr(755,root,root) /%{_lib}/libauparse.*
  367. %endif
  368. %changelog
  369. * Fri Aug 09 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-1
  370. - new upstream release.
  371. * Thu Apr 04 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.1-1
  372. - new upstream release.
  373. * Tue Aug 08 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.2-1
  374. - new upstream release.
  375. * Wed May 03 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-2
  376. - imported Patch2 from rawhide.
  377. * Sat Apr 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
  378. - new upstream release.
  379. - imported Patch1 from rawhide.
  380. * Fri Feb 10 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1-1
  381. - new upstream release.
  382. * Tue Aug 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.9-1
  383. - new upstream release.
  384. * Wed Mar 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  385. - new upstream release.
  386. * Mon Jan 24 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.7-1
  387. - new upstream release.
  388. * Sat Oct 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.6-1
  389. - new upstream release.
  390. * Wed Sep 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.5-1
  391. - new upstream release.
  392. - dropped Patch1.
  393. - dropped ldconfig scriptlets.
  394. * Fri Feb 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  395. - new upstream release.
  396. - dropped Patch1.
  397. - imported Patch1 from rawhide.
  398. * Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-1
  399. - new upstream release.
  400. - imported Patch1 from rawhide.
  401. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
  402. - new upstream release.
  403. - dropped all patches.
  404. - dropped system-config-audit.
  405. - added python3 bindings.
  406. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
  407. - fix sca_release
  408. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
  409. - create compat32-audit-libs subpackage
  410. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
  411. - rebuild with python-2.7.2
  412. - add Patch12 (audit-1.7.18-libaudit.patch)
  413. * Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
  414. - new upstream release
  415. - rebuild with krb5-1.8.2
  416. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
  417. - forgot to increment sca_release macro (why on earth is sca_release
  418. individually defined from main package's release number anyway?)
  419. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
  420. - rebuilt with gcc-4.4.3-3 on ppc
  421. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
  422. - rebuilt with rpm-4.8.0-3 (on ppc)
  423. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
  424. - rebuild with python-2.6
  425. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
  426. - rebuild with openldap-2.4.11
  427. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  428. - initial build for Vine Linux
  429. - disable krb5, prelude and selinux
  430. - add ja.po (XXX: minimal)
  431. * Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
  432. - Add subject to audit daemon events (Chu Li)
  433. - Add tcp_wrappers support for auditd
  434. - Updated syscall tables for 2.6.27 kernel
  435. - Audit connect/disconnect of remote clients
  436. - Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
  437. * Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
  438. - Update system-config-audit to 0.4.8
  439. - Whole lot of bug fixes - see ChangeLog for details
  440. - Reimplement auditd main loop using libev
  441. - Add TCP listener to auditd to receive remote events
  442. - Fix scheduler problem (#457061)
  443. * Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
  444. - Move ausearch-expression to main package (#453437)
  445. * Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
  446. - Fix interpreting of keys in syscall records
  447. - Don't error on name=(null) PATH records in ausearch/report
  448. - Add key report to aureport
  449. - Update system-config-audit to 0.4.7 (Miloslav Trmac)
  450. - Add support for the filetype field option in auditctl new to 2.6.26 kernels
  451. * Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
  452. - Fix output of keys in ausearch interpretted mode
  453. - Fix ausearch/report --start now to not be reset to midnight
  454. - audispd now has a priority boost config option
  455. - Look for laddr in avcs reported via prelude
  456. - Detect page 0 mmaps and alert via prelude
  457. * Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
  458. - Fix overflow in audit_log_user_command, better (#438840)
  459. - ausearch was not matching path in avc records
  460. - audisp-prelude attempt to reposition index after examining each type
  461. - correct building of mls policy
  462. - Fix auparse iterating in auparse_find_field and next_field
  463. - Don't alert on USER_AVC's - they are not quite right
  464. * Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
  465. - Fix buffer overflow in audit_log_user_command, again (#438840)
  466. - Fix memory leak in EOE code in auditd (#440075)
  467. - In auditctl, don't use new operators in legacy rule format
  468. - Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
  469. * Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
  470. - Fix memleak in auditd eoe code
  471. * Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
  472. - Remove LSB headers from init scripts
  473. - Fix buffer overflow in audit_log_user_command again
  474. * Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
  475. - Handle user space avcs in prelude plugin
  476. - Fix watched account login detection for some failed login attempts
  477. - Couple fixups in audit logging functions (Miloslav Trmac)
  478. - Add support in auditctl for virtual keys
  479. - auparse_find_field_next was not iterating correctly, fixed it
  480. - Add idmef alerts for access or execution of watched file
  481. - Fix buffer overflow in audit_log_user_command
  482. - Add basic remote logging plugin - only sends & no flow control
  483. - Update ausearch with interpret fixes from auparse
  484. * Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
  485. - Apply hidden attribute cleanup patch (Miloslav Trmac)
  486. - Apply auparse expression interface patch (Miloslav Trmac)
  487. - Fix potential memleak in audit event dispatcher
  488. - Update system-config-audit to version 0.4.6 (Miloslav Trmac)
  489. - audisp-prelude alerts now controlled by config file
  490. - Updated syscall table for 2.6.25 kernel
  491. - Apply patch correcting acct field being misencoded (Miloslav Trmac)
  492. - Added watched account login detection for prelude plugin
  493. * Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
  494. - Update for gcc 4.3
  495. - Cleanup descriptors in audispd before running plugin
  496. - Fix 'recent' keyword for aureport/search
  497. - Fix SE Linux policy for zos_remote plugin
  498. - Add event type for group password authentication attempts
  499. - Couple of updates to the translation tables
  500. - Add detection of failed group authentication to audisp-prelude
  501. * Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
  502. - In ausearch/report, prefer -if to stdin
  503. - In ausearch/report, add new command line option --input-logs (#428860)
  504. - Updated audisp-prelude based on feedback from prelude-devel
  505. - Added prelude alert for promiscuous socket being opened
  506. - Added prelude alert for SE Linux policy enforcement changes
  507. - Added prelude alerts for Forbidden Login Locations and Time
  508. - Applied patch to auparse fixing error handling of searching by
  509. interpreted value (Miloslav Trmac)
  510. * Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
  511. - Add prelude IDS plugin for IDMEF alerts
  512. - Add --user option to aulastlog command
  513. - Use desktop-file-install for system-config-audit
  514. - Avoid touching auditd.conf most of the time (#408501)
  515. * Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
  516. - Updates for spec file review
  517. - Adjust permission on selinux policy file
  518. * Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
  519. - Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
  520. - Check for audit log being writable by owner in auditd
  521. - If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
  522. - Updated CAPP, LSPP, and NISPOM rules for new capabilities
  523. - Added aulastlog utility
  524. * Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
  525. - Allow 0600 file perms for audit logs
  526. * Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
  527. - fchmod of log file was on wrong variable (#426934)
  528. - Allow use of errno strings for exit codes in audit rules
  529. * Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
  530. - Don't fchmod() /dev/null to mode 0400 (#426934)
  531. * Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
  532. - Add kernel release string to DEAMON_START events
  533. - Fix keep_logs when num_logs option disabled (#325561)
  534. - Fix auparse to handle node fields for syscall records
  535. - Update system-config-audit to version 0.4.5 (Miloslav Trmac)
  536. - Add keyword week-ago to aureport & ausearch start/end times
  537. - Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
  538. - Add RACF zos remote audispd plugin (Klaus Kiwi)
  539. - Add event queue overflow action to audispd
  540. * Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
  541. - Don't retry if the rt queue is full.
  542. * Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
  543. - Add support for searching by posix regular expressions in auparse
  544. - Route DEAMON events into rt interface
  545. - If event pipe is full, try again after doing local logging
  546. - Optionally add node/machine name to records in audit daemon
  547. - Update ausearch/aureport to specify nodes to search on
  548. - Fix segfault interpretting saddr fields in avcs
  549. * Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
  550. - Fix uninitialized variable in auparse (John Dennis)
  551. * Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
  552. - External plugin support in place
  553. - Fix reference counting in auparse python bindings (#263961)
  554. - Moved default af_unix plugin socket to /var/run/audispd_events
  555. * Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
  556. - Add newline to audispd string formatted events
  557. * Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
  558. - spec file cleanups
  559. - Update to s-c-audit 0.4.3
  560. * Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
  561. - Update Licence tags
  562. - Adding perm field should not set syscall added flag in auditctl
  563. - Fix segfault when aureport -if option is used
  564. - Fix auditctl to better check keys on rule lines
  565. - Add support for audit by TTY and other new event types
  566. - Auditd config option for group permission of audit logs
  567. - Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
  568. - New audit event dispatcher
  569. - Update syscall tables for 2.6.23 kernel
  570. * Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
  571. - Fix potential buffer overflow in print clone flags of auparse
  572. - Fix python traceback parsing watches without perm statement (Miloslav Trmac)
  573. - Update auditctl to handle legacy kernels when putting a watch on a dir
  574. - Fix acct interpretation in auparse
  575. * Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
  576. - Fix a double free when auditd receives SIGHUP
  577. - Move the system-config-audit menu entry to the Administration menu
  578. * Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
  579. - Add system-config-audit (Miloslav Trmac)
  580. - Correct bug in audit_make_equivalent function (Al Viro)
  581. * Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
  582. - Add feed interface to auparse library (John Dennis)
  583. - Apply patch to libauparse for unresolved symbols (#241178)
  584. - Apply patch to add line numbers for file events in libauparse (John Dennis)
  585. - Change seresults to seresult in libauparse (John Dennis)
  586. - Add unit32_t definition to swig (#244210)
  587. - Add support for directory auditing
  588. - Update acct field to be escaped
  589. * Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
  590. - Change buffer size to prevent truncation of DAEMON events with large labels
  591. - Fix memory leaks in auparse (John Dennis)
  592. - Update syscall tables for 2.6.21 kernel
  593. - Update capp & lspp rules
  594. - New python bindings for libauparse (John Dennis)
  595. * Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
  596. - New event dispatcher (James Antill)
  597. - Apply patches fixing man pages and Makefile.am (Philipp Hahn)
  598. - Apply patch correcting python libs permissions (Philipp Hahn)
  599. - Fix auditd segfault on reload
  600. - Fix bug in auparse library for file pointers and descriptors
  601. - Extract subject information out of daemon events for ausearch
  602. * Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
  603. - Remove requires kernel-headers for python-libs
  604. - Apply patch to prevent segfaults on auditd reload
  605. * Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
  606. - Updated autrace to monitor *at syscalls
  607. - Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
  608. - Finish reworking auditd config parser
  609. - In auparse, interpret open, fcntl, and clone flags
  610. - In auparse, when interpreting execve record types, run args through unencode
  611. - Add support for OBJ_PID message type
  612. - Event dispatcher updates
  613. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
  614. - rebuild
  615. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
  616. - NEW audit dispatcher program & plugin framework
  617. - Correct hidden variables in libauparse
  618. - Added NISPOM sample rules
  619. - Verify accessibility of files passed in auparse_init
  620. - Fix bug in parser library interpreting socketcalls
  621. - Add support for stdio FILE pointer in auparse_init
  622. - Adjust init script to allow anyone to status auditd (#230626)
  623. * Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  624. - Add man pages
  625. - Reduce text relocations in parser library
  626. - Add -n option to auditd for no fork
  627. - Add exec option to space_left, admin_space_left, disk_full,
  628. and disk_error - eg EXEC /usr/local/script
  629. * Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  630. - updated audit_rule_fieldpair_data to handle perm correctly (#226780)
  631. - Finished search options for audit parsing library
  632. - Fix ausearch -se to work correctly
  633. - Fix auditd init script for /usr on netdev (#228528)
  634. - Parse avc seperms better when there are more than one
  635. * Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
  636. - New report about authentication attempts
  637. - Updates for python 2.5
  638. - update autrace to have resource usage mode
  639. - update auditctl to support immutable config
  640. - added audit_log_user_command function to libaudit api
  641. - interpret capabilities
  642. - added audit event parsing library
  643. - updates for 2.6.20 kernel
  644. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
  645. - Make more adjustments for python 2.5
  646. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  647. - Fix a couple parsing problems (#217952)
  648. - Add tgkill to S390* syscall tables (#218484)
  649. - Fix error messages in ausearch/aureport
  650. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
  651. - rebuild against python 2.5
  652. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
  653. - Fix timestamp for libaudit.conf (#218053)
  654. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
  655. - Fix minor parsing problem and add new msg types
  656. * Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
  657. - ausearch & aureport implement uid/gid caching
  658. - In ausearch & aureport, extract addr when hostname is unknown
  659. - In ausearch & aureport, test audit log presence O_RDONLY
  660. - New ausearch/aureport time keywords: recent, this-week, this-month, this-year
  661. - Added --add & --delete option to aureport
  662. - Update res parsing in config change events
  663. - Increase the size on audit daemon buffers
  664. - Parse avc_path records in ausearch/aureport
  665. - ausearch has new output mode, raw, for extracting events
  666. - ausearch/aureport can now read stdin
  667. - Rework AVC processing in ausearch/aureport
  668. - Added long options to ausearch and aureport
  669. * Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
  670. - In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
  671. - Fix some defines in libaudit.h
  672. - Some auditd config strings were not initialized in aureport (#211443)
  673. - Updated man pages
  674. - Add Netlabel event types to libaudit
  675. - Update aureports to current audit event types
  676. - Update autrace a little
  677. - Deprecated all the old audit_rule functions from public API
  678. - Drop auparse library for the moment
  679. * Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
  680. - Add dist tag and bump version (#208532)
  681. - Make internal auditd buffers bigger for context info
  682. - Correct address resolving of hostname in logging functions
  683. - Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
  684. - Only =, != operators for arch & inode fields in auditctl (#206427)
  685. - Updated audit message type table
  686. - Remove watches from aureport since FS_WATCH is deprecated
  687. - Add audit_log_avc back temporarily (#208152)