acl-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: acl
  3. Summary: Access control list utilities
  4. Version: 2.3.2
  5. Release: 2%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: https://savannah.nongnu.org/projects/acl
  11. Source: http://download.savannah.nongnu.org/releases/acl/acl-%{version}.tar.gz
  12. # avoid permission denied problem with LD_PRELOAD in the test-suite
  13. Patch1: 0001-acl-2.2.53-test-runwrapper.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gawk
  16. BuildRequires: gettext
  17. BuildRequires: libattr-devel >= 2.4.1
  18. BuildRequires: libtool
  19. Requires: libacl = %{version}-%{release}
  20. %description
  21. This package contains the getfacl and setfacl utilities needed for
  22. manipulating access control lists.
  23. %package -n libacl
  24. Summary: Dynamic library for access control list support
  25. License: LGPLv2+
  26. Group: system
  27. %description -n libacl
  28. This package contains the libacl.so dynamic library which contains
  29. the POSIX 1003.1e draft standard 17 functions for manipulating access
  30. control lists.
  31. %package -n libacl-devel
  32. Summary: Access control list static libraries and headers.
  33. License: LGPLv2+
  34. Group: programming
  35. Requires: libacl = %{version}-%{release}
  36. Requires: libattr-devel
  37. %description -n libacl-devel
  38. This package contains static libraries and header files needed to develop
  39. programs which make use of the access control list programming interface
  40. defined in POSIX 1003.1e draft standard 17.
  41. %if %build_compat32
  42. %package -n compat32-libacl
  43. Summary: Dynamic library for access control list support
  44. License: LGPLv2+
  45. Group: system,legacy
  46. %description -n compat32-libacl
  47. This package contains the libacl.so dynamic library which contains
  48. the POSIX 1003.1e draft standard 17 functions for manipulating access
  49. control lists.
  50. %endif
  51. %debug_package
  52. %prep
  53. %setup -q
  54. %autopatch -p1
  55. %build
  56. touch .census
  57. # acl abuses libexecdir
  58. %configure --libdir=/%{_libdir} --libexecdir=%{_libdir}
  59. %make_build
  60. %install
  61. rm -rf %{buildroot}
  62. %make_install
  63. mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
  64. # get rid of libacl.a and libacl.la
  65. rm -f %{buildroot}%{_libdir}/libacl.{a,la}
  66. # fix links to shared libs and permissions
  67. chmod 0755 %{buildroot}/%{_libdir}/libacl.so.*.*.*
  68. # drop already installed documentation, we will use an RPM macro to install it
  69. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}*
  70. %find_lang %{name}
  71. %check
  72. if ./setfacl/setfacl -m u:`id -u`:rwx .; then
  73. make tests || exit $?
  74. if test 0 = `id -u`; then
  75. make root-tests || exit $?
  76. fi
  77. else
  78. echo '*** ACLs are probably not supported by the file system,' \
  79. 'the test-suite will NOT run ***'
  80. fi
  81. %clean
  82. rm -rf %{buildroot}
  83. %files -f %{name}.lang
  84. %defattr(-,root,root)
  85. %doc doc-nover/*
  86. %{_bindir}/chacl
  87. %{_bindir}/getfacl
  88. %{_bindir}/setfacl
  89. %{_mandir}/man1/chacl.1*
  90. %{_mandir}/man1/getfacl.1*
  91. %{_mandir}/man1/setfacl.1*
  92. %{_mandir}/man5/acl.5*
  93. %files -n libacl-devel
  94. %defattr(-,root,root)
  95. /%{_libdir}/libacl.so
  96. %{_includedir}/acl
  97. %{_includedir}/sys/acl.h
  98. %{_libdir}/libacl.*
  99. %{_libdir}/pkgconfig/*.pc
  100. %{_mandir}/man3/acl_*
  101. %files -n libacl
  102. %defattr(-,root,root)
  103. /%{_libdir}/libacl.so.*
  104. %if %build_compat32
  105. %files -n compat32-libacl
  106. %defattr(-,root,root,-)
  107. /%{_libdir}/libacl.so.*
  108. %endif
  109. %changelog
  110. * Wed Jul 03 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-2
  111. - moved files from /%%{_lib}/ to %%{_libdir}/.
  112. * Mon Jun 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  113. - new upstream release.
  114. * Wed Oct 26 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.1-1
  115. - new upstream release.
  116. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-2
  117. - dropped scriptlets.
  118. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-1
  119. - new upstream release.
  120. - dropped all patches: fixed in upstream.
  121. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-2
  122. - added compat32 package.
  123. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
  124. - new upstream release.
  125. - replaced patches to the newest rawhide's.
  126. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
  127. - updated to 2.2.49
  128. - added Patch2-7 from Fedora
  129. * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
  130. - add function acl_extended_file_nofollow() (#692982)
  131. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
  132. - fix typos in setfacl(1) man page (#675451)
  133. * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
  134. - remove dependency of libacl-devel on nfs-utils-lib and openldap
  135. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
  136. - let acl depend on the same version of libacl (#595674)
  137. * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
  138. - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
  139. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
  140. - initial build for Vine Linux
  141. * Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
  142. - new upstream version
  143. * Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
  144. - Fixed segfault when using only "--" as parameter
  145. - Resolves: #430458
  146. * Wed Nov 7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
  147. - Fixed setfacl exitcodes
  148. - Resolves: #368451
  149. * Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
  150. - New version
  151. - dropped walk patch
  152. * Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
  153. - Rewriten path_max patch to support long UTF8 names
  154. - Resolves #287701, #183181
  155. * Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
  156. - Removed NFS4 ACL patch since it was rejected by upstream.
  157. * Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
  158. - disable nfs patch; linking libacl against libs in /usr will lead to breakage
  159. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
  160. - Build Require gawk
  161. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
  162. - Rebuild for selinux ppc32 issue.
  163. * Mon Aug 27 2007 Steve Dickson <steved@redhat.com> 2.2.39-5
  164. - Added NFS v4 ACL support
  165. * Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
  166. - Updated man page for getfacl
  167. * Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
  168. - Added support fort short params to getfacl
  169. - Resolves: #204087
  170. * Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
  171. - new improved walk patch with fixed getfacl exit code (rhbz#232884)
  172. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
  173. - fix buildroot
  174. - remove trailing dot from summary
  175. - -devel requires same version of libacl
  176. - escape macro in changelog
  177. - make .so symlink relative
  178. * Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
  179. - Apply patch to make order consistent.
  180. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
  181. - rebuild
  182. * Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
  183. - new version 2.2.39
  184. - fixed usage of long UTF-8 filenames (#183181)
  185. Thanks to Andrey for the initial patch.
  186. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
  187. - rebuild for -devel deps
  188. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
  189. - bump again for double-long bug on ppc(64)
  190. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
  191. - rebuilt for new gcc4.1 snapshot and glibc changes
  192. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
  193. - new version 2.2.34
  194. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  195. - rebuilt
  196. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
  197. - fixed permissions of libacl
  198. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
  199. - spec file cleanup
  200. - mark po files as lang specific
  201. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  202. - 2.2.32
  203. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
  204. - update to 2.2.31
  205. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
  206. - get rid of *.la files
  207. - remove duplicate doc files
  208. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
  209. - Rebuild
  210. * Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
  211. - make the libs executable so that we find their dependencies (#132696)
  212. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
  213. - libacl-devel Requires: libattr-devel for libattr.la
  214. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
  215. - Requires libtool >= 1.5 for building
  216. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
  217. - Make libacl.so.* executable.
  218. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
  219. - Update to latest upstream version.
  220. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
  221. - Close bug #125300 (Steve Grubb: build requires libtool,gettext)
  222. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  223. - rebuilt
  224. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
  225. - Add missing %%defattr
  226. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
  227. - Add /usr/include/acl to files manifest
  228. - Fix location of doc files, add main doc dir to files manifest
  229. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  230. - rebuilt
  231. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  232. - rebuilt
  233. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
  234. - Fix libtool invocation
  235. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
  236. - Update to acl-2.2.7
  237. * Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
  238. - include patch from Jay Berkenbilt to print better error messages
  239. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
  240. - udpate/rebuild
  241. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
  242. - set execute bits on library so that requires are generated.
  243. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
  244. - Correct patch in previous fix so that shared libraries go in /lib*
  245. instead of /usr/lib*
  246. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
  247. - Fix multilibbing
  248. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
  249. - Added fix to install libs in correct directory on 64bit machine
  250. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
  251. - Made the package only own the one directory that is unique to it:
  252. /usr/include/acl
  253. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
  254. - Initial Red Hat package
  255. Made as few changes as possible relative to upstream packaging to
  256. make it easier to maintain long-term. This means that some of
  257. the techniques used here are definitely not standard Red Hat
  258. techniques. If you are looking for an example package to fit
  259. into Red Hat Linux transparently, this would not be the one to
  260. pick.
  261. - acl-devel -> libacl-devel