suricata-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561
  1. %bcond_with systemd
  2. %bcond_with libprelude
  3. Summary: Intrusion Detection System
  4. Name: suricata
  5. Version: 6.0.1
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: network
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2
  11. URL: https://suricata-ids.org/
  12. Source0: https://www.openinfosecfoundation.org/download/%{name}-%{version}.tar.gz
  13. Source1: suricata.sysconfig
  14. Source2: fedora.notes
  15. Source3: suricata-tmpfiles.conf
  16. Source1000: suricata.init
  17. Source1001: suricata.logrotate
  18. Source1002: pre_start
  19. Source1003: post_stop
  20. # Irrelevant docs are getting installed, drop them
  21. Patch1: suricata-2.0.9-docs.patch
  22. # Suricata service file needs some options supplied
  23. Patch2: suricata-4.1.1-service.patch
  24. # Linux 5.2 headers moved SIOCGSTAMP to linux/sockios.h. Glibc will
  25. # include it via sys/socket.h in a future release. This is temporary
  26. # and should not be needed on other kernel/glibc combos.
  27. Patch3: suricata-4.1.4-socket.patch
  28. BuildRequires: gcc gcc-c++
  29. BuildRequires: rust cargo
  30. BuildRequires: libyaml-devel python3-pyyaml
  31. BuildRequires: libnfnetlink-devel libnetfilter_queue-devel libnet-devel
  32. BuildRequires: zlib-devel pcre-devel libcap-ng-devel
  33. BuildRequires: lz4-devel libpcap-devel
  34. BuildRequires: nspr-devel nss-devel file-devel
  35. BuildRequires: jansson-devel libmaxminddb-devel python3-devel lua-devel
  36. BuildRequires: python3-rpm-macros
  37. # Next line is for eBPF support
  38. %ifarch x86_64
  39. BuildRequires: clang llvm libbpf-devel
  40. %endif
  41. BuildRequires: autoconf automake libtool
  42. %if %{with systemd}
  43. BuildRequires: systemd
  44. %endif
  45. BuildRequires: hiredis-devel
  46. BuildRequires: libevent-devel
  47. %if %{with libprelude}
  48. BuildRequires: libprelude-devel
  49. %endif
  50. BuildRequires: gnutls-devel
  51. %ifarch x86_64
  52. BuildRequires: hyperscan-devel
  53. %endif
  54. Requires: python3-pyyaml
  55. Requires(pre): /usr/sbin/useradd
  56. %if %{with systemd}
  57. Requires(post): systemd
  58. Requires(preun): systemd
  59. Requires(postun): systemd
  60. %endif
  61. %description
  62. The Suricata Engine is an Open Source Next Generation Intrusion
  63. Detection and Prevention Engine. This engine is not intended to
  64. just replace or emulate the existing tools in the industry, but
  65. will bring new ideas and technologies to the field. This new Engine
  66. supports Multi-threading, Automatic Protocol Detection (IP, TCP,
  67. UDP, ICMP, HTTP, TLS, FTP and SMB! ), Gzip Decompression, Fast IP
  68. Matching, and GeoIP identification.
  69. %debug_package
  70. %prep
  71. %setup -q
  72. install -m 644 %{SOURCE2} doc/
  73. %patch1 -p1
  74. %patch2 -p1
  75. %patch3 -p1
  76. sed -i 's/(datadir)/(sysconfdir)/' etc/Makefile.am
  77. %ifarch x86_64
  78. sed -i 's/-D__KERNEL__/-D__KERNEL__ -D__x86_64__/' ebpf/Makefile.am
  79. %endif
  80. autoreconf -fv --install
  81. %build
  82. %configure --enable-gccprotect --enable-pie --disable-gccmarch-native \
  83. --disable-coccinelle --enable-nfqueue --enable-af-packet \
  84. --with-libnspr-includes=/usr/include/nspr4 \
  85. --with-libnss-includes=/usr/include/nss3 \
  86. --enable-jansson --enable-geoip --enable-lua --enable-hiredis \
  87. %if %{with libprelude}
  88. --enable-prelude \
  89. %endif
  90. --enable-rust \
  91. %ifarch x86_64
  92. --enable-ebpf-build --enable-ebpf \
  93. %endif
  94. --enable-python
  95. %make_build
  96. %install
  97. make DESTDIR="%{buildroot}" "bindir=%{_sbindir}" install
  98. # Setup etc directory
  99. mkdir -p %{buildroot}%{_sysconfdir}/%{name}/rules
  100. #install -m 640 rules/*.rules %{buildroot}%{_sysconfdir}/%{name}/rules
  101. for f in rules/*.rules; do
  102. touch %{buildroot}%{_sysconfdir}/%{name}/$f
  103. done
  104. install -m 600 *.config %{buildroot}%{_sysconfdir}/%{name}
  105. install -m 600 suricata.yaml %{buildroot}%{_sysconfdir}/%{name}/
  106. install -m 755 %{SOURCE1002} %{buildroot}%{_sysconfdir}/%{name}/
  107. install -m 755 %{SOURCE1003} %{buildroot}%{_sysconfdir}/%{name}/
  108. %if %{with systemd}
  109. mkdir -p %{buildroot}%{_unitdir}
  110. install -m 0644 etc/%{name}.service %{buildroot}%{_unitdir}/
  111. sed -i \
  112. -e 's|/var/run/|/run/|' \
  113. -e '/ExecStart=/i ExecStartPre=%{_sysconfdir}/%{name}/pre_start' \
  114. -e '/ExecStart=/i ExecStopPost=%{_sysconfdir}/%{name}/post_stop' \
  115. %{buildroot}%{_unitdir}/%{name}.service
  116. %else
  117. mkdir -p %{buildroot}%{_initdir}
  118. install -m 0644 %{SOURCE1000} %{buildroot}%{_initdir}/%{name}
  119. %endif
  120. mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
  121. install -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  122. # Set up logging
  123. mkdir -p %{buildroot}/%{_var}/log/%{name}
  124. mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
  125. #install -m 644 etc/%{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  126. #sed -i -e 's|/var/run/%{name}\.pid|/var/run/%{name}/%{name}.pid|' %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  127. install -m 644 %{SOURCE1001} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  128. # Remove a couple things so they don't get picked up
  129. rm -rf %{buildroot}%{_includedir}
  130. rm -f %{buildroot}%{_libdir}/libhtp.la
  131. rm -f %{buildroot}%{_libdir}/libhtp.a
  132. rm -f %{buildroot}%{_libdir}/libhtp.so
  133. rm -rf %{buildroot}%{_libdir}/pkgconfig
  134. # Setup suricata-update data directory
  135. mkdir -p %{buildroot}/%{_var}/lib/%{name}
  136. # Setup tmpdirs
  137. %if %{with systemd}
  138. mkdir -p %{buildroot}%{_tmpfilesdir}
  139. install -m 0644 %{SOURCE3} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  140. %endif
  141. mkdir -p %{buildroot}/run
  142. install -d -m 0755 %{buildroot}/run/%{name}/
  143. cp suricata-update/README.rst doc/suricata-update-README.rst
  144. %check
  145. make check
  146. %pre
  147. getent passwd suricata >/dev/null || useradd -r -M -s /sbin/nologin suricata
  148. %post
  149. %if %{with systemd}
  150. %systemd_post suricata.service
  151. %else
  152. if [ $1 -gt 0 ]; then
  153. /sbin/chkconfig --add suricata
  154. fi
  155. %endif
  156. %preun
  157. %if %{with systemd}
  158. %systemd_preun suricata.service
  159. %else
  160. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  161. /sbin/service suricata stop
  162. /sbin/chkconfig suricata off ||:
  163. /sbin/chkconfig --del suricata
  164. fi
  165. %endif
  166. %postun
  167. %if %{with systemd}
  168. %systemd_postun_with_restart suricata.service
  169. %else
  170. if [ $1 -gt 0 -a -f /var/run/suricata/suricata.pid -a ! -x /bin/systemctl ]; then
  171. /sbin/service suricata restart
  172. fi
  173. %endif
  174. %files
  175. %doc doc/Basic_Setup.txt doc/suricata-update-README.rst
  176. %doc doc/Setting_up_IPSinline_for_Linux.txt doc/fedora.notes
  177. %{!?_licensedir:%global license %%doc}
  178. %license COPYING
  179. %attr(644,root,root) %{_mandir}/man1/*
  180. %{_sbindir}/suricata
  181. %{_bindir}/suricatasc
  182. %{_bindir}/suricatactl
  183. %{_bindir}/suricata-update
  184. %{_libdir}/libhtp*
  185. %{python3_sitelib}/suricatasc/*
  186. %{python3_sitelib}/suricata/*
  187. %{python3_sitelib}/*egg-info
  188. %config(noreplace) %attr(0755,root,root) %{_sysconfdir}/%{name}/pre_start
  189. %config(noreplace) %attr(0755,root,root) %{_sysconfdir}/%{name}/post_stop
  190. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/suricata.yaml
  191. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/*.config
  192. %ghost %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/rules/*.rules
  193. %config(noreplace) %attr(0600,suricata,root) %{_sysconfdir}/sysconfig/%{name}
  194. %config(noreplace) %attr(644,root,root) %{_sysconfdir}/logrotate.d/%{name}
  195. %attr(750,suricata,suricata) %dir %{_var}/log/%{name}
  196. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}
  197. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/rules
  198. %attr(2770,suricata,suricata) %dir %{_var}/lib/%{name}
  199. %attr(2770,suricata,suricata) %dir /run/%{name}/
  200. %if %{with systemd}
  201. %attr(644,root,root) %{_unitdir}/suricata.service
  202. %{_tmpfilesdir}/%{name}.conf
  203. %else
  204. %attr(0755,root,root) %{_initdir}/%{name}
  205. %endif
  206. %{_datadir}/%{name}/rules
  207. %changelog
  208. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.1-1
  209. - new upstream release.
  210. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-2
  211. - rebuilt with python-3.8.
  212. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
  213. - new upstream release.
  214. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-2
  215. - rebuilt with libevent-2.1.11.
  216. * Sat Mar 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  217. - new upstream release.
  218. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.0-3
  219. - initial build for Vine Linux.
  220. * Fri Oct 18 2019 Steve Grubb <sgrubb@redhat.com> 5.0.0-2
  221. - New feature release (which also fixes a security issue)
  222. - Enable ebpf on x86_64 only
  223. - Disable building on ppc64le due to rust problems
  224. * Thu Aug 01 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-4
  225. - Fix FTBFS bz 1736727
  226. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.4-3
  227. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  228. * Mon Jul 22 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-2
  229. - Rebuild for libprelude so bump
  230. * Tue Apr 30 2019 Jason Taylor <jtfas90@gmail.com> 4.1.4-1
  231. - Upstream bugfix release
  232. * Thu Mar 07 2019 Steve Grubb <sgrubb@redhat.com> 4.1.3-1
  233. - Upstream bugfix release
  234. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.2-2
  235. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  236. * Fri Dec 21 2018 Jason Taylor <jtfas90@gmail.com> 4.1.2-1
  237. - Upstream bugfix release
  238. - Updated source to use official download site
  239. * Thu Dec 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-4
  240. - Adjust permissions on /run/suricata and /var/lib/suricata to group writable
  241. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-2
  242. - Remove ragel requirement
  243. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-1
  244. - Make log directory group readable
  245. - Allow users of the suricata group to run suricata-update
  246. - Add lz4-devel BuildRequires to support pcap compression
  247. - Update service file for systemd security protections
  248. - Upstream bugfix update
  249. * Tue Nov 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-3
  250. - Use the upstream service and logrote files (#1330331)
  251. - Make the log directory readable by members of the suricata group (#1651394)
  252. * Wed Nov 07 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-2
  253. - Add cargo BuildRequires
  254. * Tue Nov 06 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-1
  255. - Latest upstream major release
  256. - Fixes CVE-2018-18956 Segmentation fault in the ProcessMimeEntity function
  257. * Mon Aug 13 2018 Steve Grubb <sgrubb@redhat.com> - 4.0.5-3
  258. - Consolidate branches so that everything is in sync (#1614935)
  259. * Fri Aug 10 2018 Jason Taylor <jtfas90@gmail.com> 4.0.5-2
  260. - fixes bz#1614935
  261. * Wed Jul 18 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.5-1
  262. - upstream security fix release
  263. - addresses CVE-2018-10242, CVE-2018-10243, CVE-2018-10244
  264. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-3
  265. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  266. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-2
  267. - bumped release for build against hyperscan 5.0.0
  268. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  269. - added gcc-c++ buildrequires
  270. * Thu Feb 15 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  271. - fixes bz#1543250 and bz#1543251
  272. - multiple upstream bugfixes
  273. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-3
  274. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  275. * Mon Dec 11 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-2
  276. - Added prelude support
  277. * Fri Dec 08 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-1
  278. - Upstream bugfix release
  279. * Wed Oct 18 2017 Steve Grubb <sgrubb@redhat.com> 4.0.1-1
  280. - Upstream bugfix update
  281. * Tue Sep 26 2017 Steve Grubb <sgrubb@redhat.com> 4.0.0-2
  282. - Make suricata user own /run/suricata (#1396150)
  283. * Mon Jul 31 2017 Jason Taylor <jtfas90@gmail.com> 4.0.0-1
  284. - Latest upstream major release
  285. - Build now has hyperscan and redis support
  286. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.3-2
  287. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  288. * Thu Jul 13 2017 Jason Taylor <jtfas90@gmail.com> 3.2.3-1
  289. - Upstream bugfix update
  290. * Wed Jun 07 2017 Steve Grubb <sgrubb@redhat.com> 3.2.2-1
  291. - Upstream bugfix update
  292. * Wed Feb 15 2017 Steve Grubb <sgrubb@redhat.com> 3.2.1-1
  293. - Upstream security update
  294. * Mon Feb 13 2017 Steve Grubb <sgrubb@redhat.com> 3.2-1
  295. - New upstream feature release
  296. - Rotate /var/log/suricata/eve.json (#1396151)
  297. - Fix ownership of /run/suricata (#1396150)
  298. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-2
  299. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  300. * Tue Nov 01 2016 Steve Grubb <sgrubb@redhat.com> 3.1.3-1
  301. - New upstream bug fix release
  302. * Wed Sep 07 2016 Steve Grubb <sgrubb@redhat.com> 3.1.2-1
  303. - New upstream bug fix release
  304. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
  305. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  306. * Wed Jul 13 2016 Steve Grubb <sgrubb@redhat.com> 3.1.1-1
  307. - New upstream bug fix release
  308. * Wed Jun 22 2016 Steve Grubb <sgrubb@redhat.com> 3.1-1
  309. - New upstream bug fix release
  310. * Mon Apr 04 2016 Steve Grubb <sgrubb@redhat.com> 3.0.1-1
  311. - New upstream bug fix release
  312. * Wed Mar 16 2016 Steve Grubb <sgrubb@redhat.com> 3.0-2
  313. - Fixed Bug 1227085 - Have Suricata start after the network is online
  314. * Mon Mar 07 2016 Steve Grubb <sgrubb@redhat.com> 3.0-1
  315. - New upstream bug fix release
  316. * Wed Feb 10 2016 Peter Schiffer <pschiffe@redhat.com> 2.0.11-3
  317. - Run suricata under suricata user
  318. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.11-2
  319. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  320. * Mon Dec 28 2015 Steve Grubb <sgrubb@redhat.com> 2.0.11-1
  321. - New upstream bug fix release
  322. * Wed Nov 25 2015 Steve Grubb <sgrubb@redhat.com> 2.0.10-1
  323. - New upstream bug fix release
  324. * Sat Oct 03 2015 Steve Grubb <sgrubb@redhat.com> 2.0.9-1
  325. - New upstream bug fix release
  326. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-2
  327. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  328. * Wed May 06 2015 Steve Grubb <sgrubb@redhat.com> 2.0.8-1
  329. - New upstream security bug fix release
  330. * Thu Feb 26 2015 Steve Grubb <sgrubb@redhat.com> 2.0.7-1
  331. - New upstream security bug fix release for CVE-2015-0928
  332. * Thu Jan 15 2015 Steve Grubb <sgrubb@redhat.com> 2.0.6-1
  333. - New upstream bug fix release
  334. - Don't use the system libhtp library
  335. * Fri Dec 12 2014 Steve Grubb <sgrubb@redhat.com> 2.0.5-1
  336. - New upstream bug fix release
  337. - Use the system libhtp library
  338. * Wed Sep 24 2014 Steve Grubb <sgrubb@redhat.com> 2.0.4-1
  339. - New upstream bug fix release
  340. - Fixes CVE-2014-6603 out-of-bounds access in SSH parser
  341. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
  342. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  343. * Fri Aug 08 2014 Steve Grubb <sgrubb@redhat.com> 2.0.3-1
  344. - New upstream bug fix release
  345. * Sat Jun 28 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-2
  346. - Specfile cleanups (#1113413)
  347. * Wed Jun 25 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-1
  348. - New upstream bug fix release
  349. - Enable liblua support
  350. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
  351. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  352. * Wed May 21 2014 Steve Grubb <sgrubb@redhat.com> 2.0.1-1
  353. - New upstream bug fix release
  354. * Wed Mar 26 2014 Steve Grubb <sgrubb@redhat.com> 2.0-1
  355. - Major new upstream release with new features
  356. * Tue Jan 21 2014 Dan Horák <dan[at]danny.cz> 1.4.7-3
  357. - luajit available only on selected arches
  358. * Sat Jan 11 2014 Steve Grubb <sgrubb@redhat.com> 1.4.7-2
  359. - Enable luajit support
  360. * Wed Dec 18 2013 Steve Grubb <sgrubb@redhat.com> 1.4.7-1
  361. - New upstream bug fix release
  362. * Fri Oct 04 2013 Steve Grubb <sgrubb@redhat.com> 1.4.6-1
  363. - New upstream bug fix release
  364. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3
  365. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  366. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-2
  367. - Drop prelude support
  368. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-1
  369. - New upstream bug fix release
  370. * Mon Jun 03 2013 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  371. - New upstream bug fix release
  372. * Sun Mar 10 2013 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  373. - New upstream bugfix release
  374. - Enable libgeoip support
  375. - Switch to stack-protector-all
  376. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
  377. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  378. * Thu Dec 20 2012 Steve Grubb <sgrubb@redhat.com> 1.4-1
  379. - New upstream feature enhancement release
  380. * Thu Dec 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3.5-1
  381. - New upstream bugfix release
  382. * Tue Nov 27 2012 Steve Grubb <sgrubb@redhat.com> 1.3.4-1
  383. - New upstream release
  384. * Mon Nov 05 2012 Steve Grubb <sgrubb@redhat.com> 1.3.3-1
  385. - New upstream release
  386. * Tue Oct 09 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-2
  387. - Add nss-devel build require and systemd macros
  388. * Mon Oct 08 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-1
  389. - New upstream release
  390. * Sat Aug 25 2012 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  391. - New upstream release
  392. - Switch startup to use systemd
  393. * Fri Jul 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3-1
  394. - New upstream release
  395. * Fri Mar 30 2012 Jon Ciesla <limburgher@gmail.com> - 1.2.1-3
  396. - Rebuild for updated libnet.
  397. * Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 1.2.1-2
  398. - Rebuild against PCRE 8.30
  399. * Thu Feb 02 2012 Steve Grubb <sgrubb@redhat.com> 1.2.1-1
  400. - New upstream release
  401. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
  402. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  403. * Thu Dec 22 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-2
  404. - Enable AF_PACKET support
  405. * Wed Dec 07 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-1
  406. - New upstream release
  407. * Mon Jul 25 2011 Steve Grubb <sgrubb@redhat.com> 1.0.5-1
  408. - New upstream release
  409. * Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 1.0.4-1
  410. - New upstream release
  411. * Thu Apr 28 2011 Dan Horák <dan[at]danny.cz> 1.0.3-2
  412. - don't override -march set by the buildsystem (fixes build on non-x86)
  413. * Sat Apr 23 2011 Steve Grubb <sgrubb@redhat.com> 1.0.3-1
  414. - New upstream release
  415. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  416. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  417. * Wed Nov 10 2010 Steve Grubb <sgrubb@redhat.com> 1.0.2-1
  418. - New upstream release (#651978)
  419. * Thu Jul 01 2010 Steve Grubb <sgrubb@redhat.com> 1.0.0-1
  420. - New upstream release
  421. * Fri May 07 2010 Steve Grubb <sgrubb@redhat.com> 0.9.0-1
  422. - New upstream release
  423. * Tue Apr 20 2010 Steve Grubb <sgrubb@redhat.com> 0.8.2-1
  424. - New upstream release
  425. * Sat Feb 27 2010 Steve Grubb <sgrubb@redhat.com> 0.8.1-1
  426. - Initial packaging