libgda-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527
  1. %define major 4
  2. %define minor 2
  3. %define micro 0
  4. %define version %{major}.%{minor}.%{micro}
  5. %define __libtoolize :
  6. # Default provider build options (MySQL, Postgres & unixODBC)
  7. #
  8. # Package build options:
  9. # --with tds
  10. # --with db2
  11. # --with oracle
  12. # --without sqlite
  13. # --with sybase
  14. # --with mdb
  15. # --without ldap
  16. # --without mysql
  17. # --without odbc
  18. # --without postgres
  19. #
  20. %define FREETDS 0
  21. %define IBMDB2 0
  22. %define MYSQL 1
  23. %define ODBC 0
  24. %define ORACLE 0
  25. %define POSTGRES 1
  26. %define SQLITE 1
  27. %define SYBASE 0
  28. %define MDB 0
  29. %define LDAP 0
  30. %{?_with_tds:%define FREETDS 1}
  31. %{?_with_db2:%define IBMDB2 1}
  32. %{?_without_ldap:%define LDAP 0}
  33. %{?_with_mdb:%define MDB 1}
  34. %{?_with_oracle:%define ORACLE 1}
  35. %{?_without_sqlite:%define SQLITE 0}
  36. %{?_with_sybase:%define SYBASE 1}
  37. %{?_without_mysql:%define MYSQL 0}
  38. %{?_without_odbc:%define ODBC 0}
  39. %{?_without_postgres:%define POSTGRES 0}
  40. %define libver 4.0
  41. Summary: A (relatively small) database access library
  42. Name: libgda
  43. Version: %{version}
  44. Release: 1%{?_dist_release}
  45. Source: %{name}-%{version}.tar.bz2
  46. URL: http://www.gnome-db.org/
  47. Group: System Environment/Libraries
  48. License: LGPL
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. Summary(ja): 比較的小規模なデータベース接続ライブラリ
  51. Patch0: libgda-4.2.0-disable-mdb.patch
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: yasumichi
  55. BuildRequires: pkgconfig >= 0.8
  56. BuildRequires: intltool >= 0.35.5
  57. BuildRequires: glib2-devel >= 2.12.0
  58. BuildRequires: libxml2-devel
  59. BuildRequires: libxslt-devel >= 1.0.9
  60. BuildRequires: db4-devel ncurses-devel
  61. BuildRequires: gamin-devel >= 0.1.8
  62. BuildRequires: libgcrypt-devel >= 1.1.42
  63. #BuildRequires: gnome-vfs2-devel >= 2.20 # use gio-2.0(in glib2)
  64. #BuildRequires: mono-devel gtk-sharp2 gtk-sharp2-gapi
  65. %if %{FREETDS}
  66. BuildRequires: freetds-devel
  67. %endif
  68. %if %{MYSQL}
  69. BuildRequires: MySQL-devel
  70. %endif
  71. %if %{POSTGRES}
  72. BuildRequires: postgresql-devel
  73. %endif
  74. %if %{ODBC}
  75. BuildRequires: unixODBC-devel
  76. %endif
  77. %if %{SQLITE}
  78. BuildRequires: sqlite3-devel
  79. %endif
  80. %if %{MDB}
  81. BuildRequires: mdbtools-devel
  82. %endif
  83. %if %{LDAP}
  84. BuildRequires: openldap-devel
  85. %endif
  86. %description
  87. Libgda is a (relatively small) database access library:
  88. - a wrapper like ODBC but with more features to access several database
  89. engines
  90. - a meta data extractor (to know all about database objects in a common
  91. way)
  92. - comes with an SQL console application (like mysql, psql or sqlite3
  93. consoles)
  94. - relies on GLib, coded in C, its API is easy to use
  95. - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
  96. is in progress for other database types (such as Firebird and Oracle) and
  97. to wrap JDBC for more wider usage.
  98. Build option is:
  99. --with mysql postgres sqlite
  100. --without tds ibmdb2 ldap mdb odbc oracle sybase
  101. %package devel
  102. Summary: Development libraries and header files for libgda.
  103. Group: Development/Libraries
  104. Requires: %{name} = %{version}
  105. Requires: glib2-devel >= 2.12.0
  106. Requires: libxml2-devel
  107. Requires: libxslt-devel >= 1.0.9
  108. %description devel
  109. This package contains the header files and libraries needed to write
  110. or compile programs that use libgda.
  111. #%package sharp
  112. #Summary: Mono bindings for libgda
  113. #Group: System Environment/Libraries
  114. #Requires: %{name} = %{version}-%{release}
  115. #Requires: mono-core
  116. #
  117. #%description sharp
  118. #This package contains the dll files needed to run (and compile) Mono
  119. #applications which use libgda.
  120. %if %{FREETDS}
  121. %package -n gda-freetds
  122. Summary: GDA FreeTDS Provider
  123. Group: System Environment/Libraries
  124. %description -n gda-freetds
  125. This package includes the GDA FreeTDS provider.
  126. %endif
  127. %if %{IBMDB2}
  128. %package -n gda-ibmdb2
  129. Summary: GDA IBM DB2 Provider
  130. Group: System Environment/Libraries
  131. %description -n gda-ibmdb2
  132. This package includes the GDA IBM DB2 provider.
  133. %endif
  134. %if %{MYSQL}
  135. %package -n gda-mysql
  136. Summary: GDA MySQL Provider
  137. Group: System Environment/Libraries
  138. %description -n gda-mysql
  139. This package includes the GDA MySQL provider.
  140. %endif
  141. %if %{ODBC}
  142. %package -n gda-odbc
  143. Summary: GDA ODBC Provider
  144. Group: System Environment/Libraries
  145. %description -n gda-odbc
  146. This package includes the GDA ODBC provider.
  147. %endif
  148. %if %{ORACLE}
  149. %package -n gda-oracle
  150. Summary: GDA Oracle Provider
  151. Group: System Environment/Libraries
  152. %description -n gda-oracle
  153. This package includes the GDA Oracle provider.
  154. %endif
  155. %if %{POSTGRES}
  156. %package -n gda-postgres
  157. Summary: GDA PostgreSQL Provider
  158. Group: System Environment/Libraries
  159. %description -n gda-postgres
  160. This package includes the GDA PostgreSQL provider.
  161. %endif
  162. %if %{SQLITE}
  163. %package -n gda-sqlite
  164. Summary: GDA SQLite Provider
  165. Group: System Environment/Libraries
  166. %description -n gda-sqlite
  167. This package includes the GDA SQLite provider.
  168. %endif
  169. %if %{SYBASE}
  170. %package -n gda-sybase
  171. Summary: GDA Sybase Provider
  172. Group: System Environment/Libraries
  173. %description -n gda-sybase
  174. This package includes the GDA Sybase provider.
  175. %endif
  176. %if %{MDB}
  177. %package -n gda-mdb
  178. Summary: GDA MDB Provider
  179. Group: System Environment/Libraries
  180. %description -n gda-mdb
  181. This package includes the GDA MDB provider.
  182. %endif
  183. %if %{LDAP}
  184. %package -n gda-ldap
  185. Summary: GDA LDAP Provider
  186. Group: System Environment/Libraries
  187. %description -n gda-ldap
  188. This package includes the GDA LDAP provider.
  189. %endif
  190. %prep
  191. %setup -q -n %{name}-%{version}
  192. %patch0 -p1 -b .mdb
  193. %build
  194. %if %{FREETDS}
  195. CONFIG="$CONFIG --with-tds"
  196. %else
  197. CONFIG="$CONFIG --without-tds"
  198. %endif
  199. %if %{IBMDB2}
  200. CONFIG="$CONFIG --with-ibmdb2"
  201. %else
  202. CONFIG="$CONFIG --without-ibmdb2"
  203. %endif
  204. %if %{MYSQL}
  205. CONFIG="$CONFIG --with-mysql"
  206. %else
  207. CONFIG="$CONFIG --without-mysql"
  208. %endif
  209. %if %{POSTGRES}
  210. CONFIG="$CONFIG --with-postgres"
  211. %else
  212. CONFIG="$CONFIG --without-postgres"
  213. %endif
  214. %if %{ODBC}
  215. CONFIG="$CONFIG --with-odbc"
  216. %else
  217. CONFIG="$CONFIG --without-odbc"
  218. %endif
  219. %if %{ORACLE}
  220. CONFIG="$CONFIG --with-oracle"
  221. %else
  222. CONFIG="$CONFIG --without-oracle"
  223. %endif
  224. %if %{SQLITE}
  225. CONFIG="$CONFIG --with-sqlite"
  226. %else
  227. CONFIG="$CONFIG --without-sqlite"
  228. %endif
  229. %if %{SYBASE}
  230. CONFIG="$CONFIG --with-sybase"
  231. %else
  232. CONFIG="$CONFIG --without-sybase"
  233. %endif
  234. %if %{MDB}
  235. CONFIG="$CONFIG --with-mdb"
  236. %else
  237. CONFIG="$CONFIG --without-mdb"
  238. %endif
  239. %if %{LDAP}
  240. CONFIG="$CONFIG --with-ldap"
  241. %else
  242. CONFIG="$CONFIG --without-ldap"
  243. %endif
  244. %configure $CONFIG --disable-gtk-doc
  245. make
  246. %install
  247. rm -rf $RPM_BUILD_ROOT
  248. #makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
  249. make install DESTDIR=$RPM_BUILD_ROOT
  250. #fixup mono / sharp related files install
  251. #mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
  252. #mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
  253. #mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
  254. #mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
  255. #rmdir %{buildroot}/%{_libdir}/libgda
  256. # Cleanup unnecessary, unpackaged files
  257. rm -f %{buildroot}/%{_libdir}/lib*.la
  258. rm -f %{buildroot}/%{_libdir}/libgda-%{libver}/providers/*.{a,la}
  259. rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
  260. %find_lang libgda-%{libver}
  261. %post -p /sbin/ldconfig
  262. %postun -p /sbin/ldconfig
  263. %clean
  264. rm -rf $RPM_BUILD_ROOT
  265. %files
  266. %defattr(-,root,root)
  267. %doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
  268. %dir %{_sysconfdir}/libgda-%{libver}
  269. %config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
  270. %{_bindir}/*
  271. %{_libdir}/*.so.*
  272. %dir %{_libdir}/libgda-%{libver}
  273. %dir %{_libdir}/libgda-%{libver}/providers
  274. %{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
  275. %dir %{_datadir}/libgda-%{libver}
  276. %{_datadir}/libgda-%{libver}/dtd
  277. %{_datadir}/libgda-%{libver}/*.xml
  278. %{_datadir}/libgda-%{libver}/web
  279. %{_mandir}/man1/*
  280. %{_datadir}/locale/*/LC_MESSAGES/*
  281. %files devel
  282. %defattr(-,root,root)
  283. %{_includedir}/libgda-%{libver}
  284. %{_libdir}/*.a
  285. #{_libdir}/*.la
  286. %{_libdir}/*.so
  287. %{_libdir}/pkgconfig/*
  288. %{_datadir}/gtk-doc/html/*
  289. #%{_datadir}/omf/*
  290. #%{_mandir}/man5/*
  291. #files sharp
  292. #defattr(-,root,root)
  293. #{_datadir}/gapi-2.0
  294. #/usr/lib/mono/gda-sharp-2.0
  295. #{_libdir}/pkgconfig/gda-sharp-2.0.pc
  296. %if %{FREETDS}
  297. %files -n gda-freetds
  298. %{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
  299. %endif
  300. %if %{IBMDB2}
  301. %files -n gda-ibmdb2
  302. %{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
  303. %endif
  304. %if %{MYSQL}
  305. %files -n gda-mysql
  306. %{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
  307. %{_datadir}/libgda-%{libver}/mysql_*.xml
  308. %endif
  309. %if %{ODBC}
  310. %files -n gda-odbc
  311. %{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
  312. %{_datadir}/libgda-%{libver}/odbc_*.xml
  313. %endif
  314. %if %{ORACLE}
  315. %files -n gda-oracle
  316. %{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
  317. %endif
  318. %if %{POSTGRES}
  319. %files -n gda-postgres
  320. %{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
  321. %{_datadir}/libgda-%{libver}/postgres_*.xml
  322. %endif
  323. %if %{SQLITE}
  324. %files -n gda-sqlite
  325. %{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
  326. %{_datadir}/libgda-%{libver}/sqlite_*.xml
  327. %endif
  328. %if %{SYBASE}
  329. %files -n gda-sybase
  330. %{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
  331. %endif
  332. %if %{MDB}
  333. %files -n gda-mdb
  334. %{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
  335. %endif
  336. %if %{LDAP}
  337. %files -n gda-ldap
  338. %{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
  339. %{_datadir}/libgda-%{libver}/ldap_*.xml
  340. %endif
  341. %changelog
  342. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-1
  343. - new upstream release
  344. - add Patch0 (libgda-4.2.0-disable-mdb.patch)
  345. - change %%{libver}
  346. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
  347. - rebuild with rpm-4.8.1 for pkg-config file
  348. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
  349. - new upstream release
  350. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
  351. - new upstream release
  352. * Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
  353. - new upstream release
  354. - remove gnome-vfs2-devel from BR.(use gio-2.0)
  355. - add Vendor, Distribution and Packager.
  356. - update summary and description.
  357. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
  358. - rebuilt with postgresql-8.4.0
  359. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
  360. - added intltool to BuildRequires.
  361. - rebuilt with MySQL-5.1.34.
  362. * Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
  363. - update from upstream.
  364. - update description and files.
  365. - ODBC,LDAP outdated
  366. * Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
  367. - rebuilt with postgresql-8.3.3
  368. * Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
  369. - new upstream release
  370. - not build sharp subpackage
  371. - built with db4-4.6.21, MySQL-5.0.51a
  372. * Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
  373. - rebuilt with postgresql-8.2.6
  374. * Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
  375. - rebuilt with postgresql-8.2.5
  376. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
  377. - rebuilt with new toolchain
  378. * Wed Nov 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
  379. - rebuilt with openldap 2.3.27, MySQL 5.0.27
  380. - added Patch0 from Fedora
  381. * Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
  382. - rebuilt with openldap-devel-2.3.24-0vl4
  383. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
  384. - rebuilt with gamin-devel in place of fam-devel
  385. * Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
  386. - rebuilt with readline 5.1
  387. - added subpackage for Mono binding
  388. * Mon Jan 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
  389. - new upstream release
  390. * Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  391. - new upstream release
  392. - rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
  393. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  394. - new upstream release
  395. - fixed %files on devel package
  396. * Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
  397. - new upstream release
  398. - re-define __libtoolize to compile shared object
  399. - updated summary
  400. - make sqlite package by default
  401. * Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
  402. - new upstream release
  403. - build with new MySQL
  404. - make ldap package by default
  405. * Sat Dec 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
  406. - new upstream release
  407. * Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
  408. - new upstream release
  409. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
  410. - updated to 1.0.0
  411. - based on original spec
  412. - disabled smp_flag at compile time
  413. * Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
  414. - added BuildPreReq: bonobo >= 1.0.9
  415. (0.2.96-0vl2 seems to be lost by accident, so putting again here)
  416. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
  417. - New upstream release.
  418. - use gcc-2.95.3 and g++-2.95.3
  419. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
  420. - New upstream release.
  421. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
  422. - Rebuild for Vine.
  423. * Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
  424. - Cleaned
  425. * Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
  426. - Initial spec imported from old GNOME-DB spec