gnome-power-manager-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. %define dbus_version 1.4.0
  2. %define dbus_glib_version 0.88
  3. %define gnome_panel_version 2.32.0
  4. Summary: GNOME power management service
  5. Summary(ja): GNOME 電源管理ツール
  6. Name: gnome-power-manager
  7. Version: 2.32.0
  8. Release: 1%{?_dist_release}
  9. License: GPLv2+ and GFDL
  10. Group: Applications/System
  11. URL: http://projects.gnome.org/gnome-power-manager/
  12. Source: http://download.gnome.org/sources/gnome-power-manager/2.32/gnome-power-manager-%{version}.tar.bz2
  13. # for Vine Linux
  14. Patch10: gnome-power-manager-2.28.2-warningflags.patch
  15. Patch11: gnome-power-manager-2.28.2-math.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: autoconf >= 2.65
  18. BuildRequires: libgnomeui-devel
  19. BuildRequires: libglade2-devel
  20. BuildRequires: libwnck-devel
  21. BuildRequires: dbus-devel >= %{dbus_version}
  22. BuildRequires: libnotify-devel
  23. BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  24. BuildRequires: scrollkeeper
  25. BuildRequires: gnome-doc-utils >= 0.3.2
  26. BuildRequires: desktop-file-utils
  27. BuildRequires: gettext
  28. BuildRequires: libtool
  29. BuildRequires: cairo-devel
  30. BuildRequires: libcanberra-devel >= 0.10
  31. BuildRequires: unique-devel >= 1.1.6
  32. ## BuildRequires: DeviceKit-power-devel >= 008
  33. BuildRequires: upower-devel >= 0.9.0
  34. BuildRequires: intltool
  35. BuildRequires: docbook-utils
  36. Requires: gtk2 >= 2.10.0
  37. Requires: gnome-mime-data
  38. Requires: gnome-icon-theme
  39. Requires: libnotify >= 0.4.3
  40. Requires: dbus-glib >= %{dbus_glib_version}
  41. Requires: dbus-x11 >= %{dbus_version}
  42. Requires: libcanberra-gtk2 >= 0.10
  43. Requires: unique >= 1.1.6
  44. Requires: upower >= 0.9.0
  45. Requires(post,postun): scrollkeeper
  46. Requires(post,pre,preun): GConf2
  47. Vendor: Project Vine
  48. Distribution: Vine Linux
  49. Packager: daisuke, Takemikaduchi
  50. %description
  51. GNOME Power Manager uses the information and facilities provided by HAL
  52. displaying icons and handling user callbacks in an interactive GNOME session.
  53. GNOME Power Preferences allows authorised users to set policy and
  54. change preferences.
  55. %package extra
  56. Summary: GNOME Power Manager extra utility programs
  57. Group: Applications/System
  58. Requires: %{name} = %{version}-%{release}
  59. %description extra
  60. Extra GNOME power management applications that are not normally needed.
  61. %prep
  62. %setup -q
  63. #%setup -q -n %{?name}-%{?version}-%{?alphatag}
  64. ## %patch10 -p1 -b .warnings
  65. ## %patch11 -p1 -b .math
  66. autoreconf -i
  67. %build
  68. %configure \
  69. --disable-scrollkeeper
  70. make
  71. # strip unneeded translations from .mo files
  72. # ideally intltool (ha!) would do that for us
  73. # http://bugzilla.gnome.org/show_bug.cgi?id=474987
  74. cd po
  75. grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
  76. mv POTFILES.keep POTFILES.in
  77. intltool-update --pot
  78. for p in *.po; do
  79. msgmerge $p %{name}.pot > $p.out
  80. msgfmt -o `basename $p .po`.gmo $p.out
  81. done
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  85. make install DESTDIR=$RPM_BUILD_ROOT
  86. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  87. desktop-file-install --vendor gnome --delete-original \
  88. --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
  89. $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
  90. # save space by linking identical images in translated docs
  91. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  92. for f in $helpdir/C/figures/*.png; do
  93. b="$(basename $f)"
  94. for d in $helpdir/*; do
  95. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  96. g="$d/figures/$b"
  97. if [ -f "$g" ]; then
  98. if cmp -s $f $g; then
  99. rm "$g"; ln -s "../../C/figures/$b" "$g"
  100. fi
  101. fi
  102. fi
  103. done
  104. done
  105. %find_lang %name --with-gnome
  106. %clean
  107. rm -rf $RPM_BUILD_ROOT
  108. %post
  109. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  110. gconftool-2 --makefile-install-rule \
  111. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas >/dev/null || :
  112. scrollkeeper-update -q &> /dev/null || :
  113. touch --no-create %{_datadir}/icons/hicolor
  114. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  115. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  116. fi
  117. %pre
  118. if [ "$1" -gt 1 ]; then
  119. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  120. gconftool-2 --makefile-uninstall-rule \
  121. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
  122. fi
  123. %preun
  124. if [ "$1" -eq 0 ]; then
  125. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  126. gconftool-2 --makefile-uninstall-rule \
  127. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
  128. fi
  129. %postun
  130. scrollkeeper-update -q &> /dev/null || :
  131. touch --no-create %{_datadir}/icons/hicolor
  132. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  133. gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
  134. fi
  135. %files -f %{name}.lang
  136. %defattr(-,root,root)
  137. %doc AUTHORS COPYING README
  138. %{_bindir}/gnome-power-bugreport.sh
  139. %{_bindir}/gnome-power-manager
  140. %{_bindir}/gnome-power-preferences
  141. %{_sbindir}/gnome-power-backlight-helper
  142. %dir %{_datadir}/gnome-power-manager
  143. %{_datadir}/gnome-power-manager/acme.ui
  144. %{_datadir}/gnome-power-manager/gpm-prefs.ui
  145. %{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
  146. %{_mandir}/man1/gnome-power-manager.1.gz
  147. %{_mandir}/man1/gnome-power-preferences.1.gz
  148. %{_sysconfdir}/gconf/schemas/*.schemas
  149. %{_datadir}/dbus-1/services/gnome-power-manager.service
  150. #%{_datadir}/omf/gnome-power-manager
  151. %{_sysconfdir}/xdg/autostart/*.desktop
  152. %{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
  153. %{_datadir}/icons/hicolor/*/apps/gnome-power-manager.*
  154. %{_datadir}/applications/gnome-power-preferences.desktop
  155. %{_libexecdir}/gnome-brightness-applet
  156. %{_libdir}/bonobo/servers/GNOME_BrightnessApplet.server
  157. %{_datadir}/gnome-2.0/ui/GNOME_BrightnessApplet.xml
  158. %{_datadir}/icons/hicolor/*/apps/gnome-brightness-applet.*
  159. %{_datadir}/polkit-1/actions/org.gnome.power.policy
  160. %files extra
  161. %defattr(-,root,root,-)
  162. %doc AUTHORS COPYING NEWS README
  163. %{_bindir}/gnome-power-statistics
  164. %{_mandir}/man1/gnome-power-statistics.1.gz
  165. %{_datadir}/gnome-power-manager/gpm-statistics.ui
  166. %{_datadir}/applications/gnome-power-statistics.desktop
  167. %{_datadir}/icons/hicolor/*/apps/gnome-power-statistics.*
  168. %{_libexecdir}/gnome-inhibit-applet
  169. %{_libdir}/bonobo/servers/GNOME_InhibitApplet.server
  170. %{_datadir}/gnome-2.0/ui/GNOME_InhibitApplet.xml
  171. %{_datadir}/icons/hicolor/*/apps/gnome-inhibit-applet.*
  172. %changelog
  173. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  174. - new upstream release
  175. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  176. - fix %files
  177. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  178. - new upstream release
  179. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  180. - new upstream release
  181. - remove Patch1, Patch2, Patch3
  182. - change BuildRequires: DeviceKit-power-devel -> upower-devel
  183. - change Requires: DeviceKit-power -> upower
  184. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  185. - new upstream release
  186. - change BuildRequires: xmlto -> docbook-utils
  187. - remove BuildReuiqres: hal-devel
  188. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  189. - new upstream release
  190. * Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  191. - merge spec file from FC package
  192. - add Patch1, Patch2 and Patch3 from FC package
  193. - add Patch10 and Patch11 for Vine Linux
  194. - remove configure option --enable-policykit
  195. - add new package (extra)
  196. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
  197. - new upstream release
  198. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  199. - new upstream release
  200. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  201. - new upstream release
  202. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  203. - new upstream release
  204. * Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  205. - new upstream release
  206. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
  207. - rebuild with new environment/toolchain
  208. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
  209. - new upstream release
  210. - drop Patch10 to enable suspend-to-ram.
  211. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
  212. - new upstream release
  213. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
  214. - new upstream release
  215. * Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
  216. - new upstream release
  217. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
  218. - new upstream release
  219. * Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
  220. - new upstream release
  221. * Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
  222. - new upstream release
  223. * Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
  224. - new upstream release
  225. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  226. - new upstream release
  227. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  228. - add Patch10 to disable suspend-to-ram by default.
  229. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  230. - update ja.po from CVS head.
  231. * Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  232. - new upstream release
  233. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
  234. - initial build for Vine Linux based on FC package
  235. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
  236. - fix the fix in -2 and -3
  237. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
  238. - fix the fix in -2
  239. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
  240. - fix icon in bubbles (bug 184192).
  241. * Fri Mar 3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
  242. - Update to 2.13.93
  243. - ignore d-bus timeout errors
  244. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
  245. - Add patch from Richard Hughes to potentially fix a
  246. crasher bug (bug 183127)
  247. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
  248. - Buildrequires: gnome-doc-utils
  249. * Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
  250. - Update to 2.13.92
  251. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
  252. - Update to 2.13.91
  253. - Drop upstreamed patch
  254. * Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
  255. - Update to 2.13.90
  256. - Require dbus-x11 (#176656)
  257. * Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
  258. - remove Hibernate and Suspend from menus as part of
  259. panel/g-p-m integration effort
  260. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
  261. - bump again for double-long bug on ppc(64)
  262. * Tue Feb 7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
  263. - pull cvs snapshot from HEAD and drop the patches caillon
  264. just added
  265. * Tue Feb 7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
  266. - Install into the autostart directory
  267. - Don't suspend on lid close while on AC power
  268. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
  269. - rebuilt for new gcc4.1 snapshot and glibc changes
  270. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
  271. - rebuild
  272. * Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
  273. - packaging tweaks
  274. * Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
  275. - Update to 2.13.5
  276. * Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
  277. - Left clicking on the applet should bring up the menu
  278. * Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
  279. - update to 0.3.4
  280. - disable updating scrollkeeper database in buildroot
  281. (move to %%post)
  282. * Fri Jan 6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
  283. - update to a cvs snap so that it works with hal cvs snap
  284. - make sure we use libnotify
  285. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
  286. - rebuilt
  287. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  288. - rebuild for new dbus
  289. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
  290. - Update to 0.3.1
  291. * Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
  292. - Update to 0.3.0
  293. * Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
  294. - update to 0.2.8
  295. * Wed Oct 3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
  296. - update to 0.2.6
  297. * Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
  298. - update to 0.2.4
  299. * Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
  300. - Initial import based on an SRPM from Richard Hughes