libssh2-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library implementing the SSH2 protocol
  3. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  4. Name: libssh2
  5. Version: 1.10.0
  6. Release: 2%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: https://www.libssh2.org/
  12. Source0: https://www.libssh2.org/download/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: openssl-devel
  15. BuildRequires: zlib-devel
  16. %description
  17. libssh2 is a library implementing the SSH2 protocol as defined by
  18. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  19. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  20. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  21. %package devel
  22. Summary: Development files for %{name}
  23. Summary(ja): %{name} の開発ファイル
  24. Group: programming
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. The %{name}-devel package contains libraries and header files for
  28. developing applications that use %{name}.
  29. %package docs
  30. Summary: Documentation for %{name}
  31. Summary(ja): %{name} のドキュメント
  32. Group: documentation
  33. Requires: %{name} = %{version}-%{release}
  34. %description docs
  35. The %{name}-docs package contains man pages and examples for
  36. developing applications that use %{name}.
  37. ## to build compat32 for x86_64 architecture support
  38. %package -n compat32-%{name}
  39. Summary: A library implementing the SSH2 protocol
  40. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  41. Group: system,legacy
  42. %description -n compat32-%{name}
  43. libssh2 is a library implementing the SSH2 protocol as defined by
  44. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  45. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  46. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  47. %debug_package
  48. %prep
  49. %setup -q
  50. # Replace hard wired port number in the test suite to avoid collisions
  51. # between 32-bit and 64-bit builds running on a single build-host
  52. sed -i s/4711/47%{__isa_bits}/ tests/ssh2.{c,sh}
  53. # make sure things are UTF-8...
  54. for i in ChangeLog NEWS ; do
  55. iconv --from=ISO-8859-1 --to=UTF-8 $i > new
  56. mv new $i
  57. done
  58. %build
  59. %configure --disable-static --enable-shared
  60. make %{?_smp_mflags}
  61. %install
  62. rm -rf %{buildroot}
  63. make install DESTDIR=%{buildroot} INSTALL="install -p"
  64. find %{buildroot} -name '*.la' -exec rm -f {} +
  65. # clean things up a bit for packaging
  66. ( cd example && make clean )
  67. rm -rf example/simple/.deps
  68. find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
  69. %check
  70. (cd tests && make check)
  71. %clean
  72. rm -rf %{buildroot}
  73. %files
  74. %defattr(-,root,root,-)
  75. %license COPYING
  76. %doc NEWS README* RELEASE-NOTES
  77. %{_libdir}/*.so.*
  78. %files docs
  79. %defattr(-,root,root,-)
  80. %license COPYING
  81. %doc example/ docs/HACKING
  82. %{_mandir}/man?/*
  83. %files devel
  84. %defattr(-,root,root,-)
  85. %license COPYING
  86. %{_includedir}/*
  87. %{_libdir}/*.so
  88. %{_libdir}/pkgconfig/libssh2.pc
  89. %if %{build_compat32}
  90. %files -n compat32-%{name}
  91. %defattr(-,root,root,-)
  92. %{_libdir}/*.so.*
  93. %endif
  94. %changelog
  95. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-2
  96. - rebuilt with openssl-3.0.0.
  97. * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
  98. - new upstream release.
  99. - dropped ldconfig scriptlets.
  100. * Thu Oct 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.0-1
  101. - new upstream release.
  102. * Thu Mar 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
  103. - new upstream release.
  104. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.0-1
  105. - new upstream release.
  106. - built with openssl-1.1.1.
  107. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-2
  108. - rebuilt with openssl 1.0.2g
  109. * Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-1
  110. - new upstream release with security fixes
  111. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
  112. - new upstream reelase
  113. - add compat32 package
  114. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
  115. - new upstream release
  116. - fix %%files
  117. * Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
  118. - initial build for Vine Linux
  119. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
  120. - rebuilt with new openssl
  121. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  123. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  125. * Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
  126. - update to 1.0
  127. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
  128. - rebuild with new openssl
  129. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
  130. - Autorebuild for GCC 4.3
  131. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
  132. - rebuild for new openssl...
  133. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
  134. - bump
  135. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
  136. - add INSTALL arg to make install vs env. var
  137. * Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
  138. - run tests; don't package test
  139. * Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
  140. - split docs into -docs (they seemed... large.)
  141. * Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
  142. - update to 0.18
  143. * Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
  144. - update to 0.17
  145. - many spec file changes
  146. * Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
  147. - Fix release tag
  148. - Move manpages to -devel package
  149. - Add Examples dir to -devel package
  150. * Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
  151. - Initial build