bash-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589
  1. %define baseversion 5.2.21
  2. %define bashversion %(echo %{baseversion} | cut -d. -f1-2)
  3. %define patchlevel 26
  4. Summary: The GNU Bourne Again shell (bash).
  5. Summary(ja): GNU Bourne Again シェル (bash).
  6. Name: bash
  7. Version: %{bashversion}.%{patchlevel}
  8. Release: 1%{?_dist_release}
  9. Group: system
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. License: GPLv3+
  14. Source0: https://ftp.gnu.org/pub/gnu/bash/bash-%{baseversion}.tar.gz
  15. Source10: bashrc-vine
  16. # Official upstream patches
  17. Patch22: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-022
  18. Patch23: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-023
  19. Patch24: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-024
  20. Patch25: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-025
  21. Patch26: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-026
  22. # We don't want to add '/etc:/usr/etc' in standard utils path.
  23. Patch101: bash-2.03-paths.patch
  24. # Non-interactive shells beginning with argv[0][0] == '-' should run the startup files when not in posix mode.
  25. Patch102: bash-2.03-profile.patch
  26. # https://bugzilla.redhat.com/show_bug.cgi?id=60870
  27. Patch103: bash-2.05a-interpreter.patch
  28. # Generate info for debuginfo files.
  29. Patch104: bash-2.05b-debuginfo.patch
  30. # Pid passed to setpgrp() can not be pid of a zombie process.
  31. Patch105: bash-2.05b-pgrp_sync.patch
  32. # Enable audit logs
  33. Patch106: bash-3.2-audit.patch
  34. # Source bashrc file when bash is run under ssh.
  35. Patch107: bash-3.2-ssh_source_bash.patch
  36. # Use makeinfo to generate .texi file
  37. # Patch108: bash-infotags.patch
  38. # Try to pick up latest `--rpm-requires` patch from http://git.altlinux.org/gears/b/bash4.git
  39. Patch109: bash-requires.patch
  40. Patch110: bash-setlocale.patch
  41. # Disable tty tests while doing bash builds
  42. Patch111: bash-tty-tests.patch
  43. # 484809, check if interp section is NOBITS
  44. Patch116: bash-4.0-nobits.patch
  45. # Do the same CFLAGS in generated Makefile in examples
  46. Patch117: bash-4.1-examples.patch
  47. # Builtins like echo and printf won't report errors
  48. # when output does not succeed due to EPIPE
  49. Patch118: bash-4.1-broken_pipe.patch
  50. # Enable system-wide .bash_logout for login shells
  51. Patch119: bash-4.2-rc2-logout.patch
  52. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  53. Patch120: bash-4.2-coverity.patch
  54. # 799958, updated info about trap
  55. # This patch should be upstreamed.
  56. Patch122: bash-4.2-manpage_trap.patch
  57. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  58. # This patch should be upstreamed.
  59. Patch123: bash-4.2-size_type.patch
  60. # 1112710 - mention ulimit -c and -f POSIX block size
  61. # This patch should be upstreamed.
  62. Patch124: bash-4.3-man-ulimit.patch
  63. # 1102815 - fix double echoes in vi visual mode
  64. Patch125: bash-4.3-noecho.patch
  65. #1241533,1224855 - bash leaks memory when LC_ALL set
  66. Patch126: bash-4.3-memleak-lc_all.patch
  67. # bash-4.4 builds loadable builtin examples by default
  68. # this patch disables it
  69. Patch127: bash-4.4-no-loadable-builtins.patch
  70. # 2020528 - Add a runtime option to enable history logging to syslog
  71. # This option is undocumented in upstream and is documented by this patch
  72. Patch128: bash-5.0-syslog-history.patch
  73. Buildroot: %{_tmppath}/%{name}-%{version}-root
  74. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  75. Obsoletes: bash <= 1.14.7
  76. Obsoletes: bash2
  77. %description
  78. Bash is a GNU project sh-compatible shell or command language
  79. interpreter. Bash (Bourne Again shell) incorporates useful features
  80. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  81. can be run by bash without modification.
  82. Bash offers several improvements over sh, including command line
  83. editing, unlimited size command history, job control, shell
  84. functions and aliases, indexed arrays of unlimited size and
  85. integer arithmetic in any base from two to 64. Bash is ultimately
  86. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  87. Tools standard.
  88. %package doc
  89. Summary: Documentation for the GNU Bourne Again shell (bash).
  90. Summary(ja): GNU Bourne Again シェル向けドキュメント
  91. Group: documentation
  92. Requires: %{name} = %{version}-%{release}
  93. Obsoletes: bash2-doc
  94. %description doc
  95. This is a separate documentation package for the GNU Bourne
  96. Again shell.
  97. %debug_package
  98. %prep
  99. %setup -q -n %{name}-%{baseversion}
  100. %autopatch -p0 -m1 -M99
  101. %autopatch -p1 -m100
  102. echo %{version} > _distribution
  103. echo %{release} |sed 's/vl.*//' > _patchlevel
  104. %build
  105. autoconf
  106. %configure --with-bash-malloc=no
  107. # Recycles pids is neccessary. When bash's last fork's pid was X
  108. # and new fork's pid is also X, bash has to wait for this same pid.
  109. # Without Recycles pids bash will not wait.
  110. MFLAGS="CPPFLAGS=-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS` -DSYSLOG_HISTORY -DSYSLOG_SHOPT=0"
  111. # work around missing deps in Makefiles
  112. make "$MFLAGS" version.h
  113. make "$MFLAGS" %{?_smp_mflags} -C builtins
  114. make "$MFLAGS" %{?_smp_mflags}
  115. %install
  116. if [ -e autoconf ]; then
  117. # Yuck. We're using autoconf 2.1x.
  118. export PATH=.:$PATH
  119. fi
  120. # Fix bug #83776
  121. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  122. make DESTDIR=$RPM_BUILD_ROOT install
  123. mkdir -p %{buildroot}/%{_sysconfdir}
  124. pushd $RPM_BUILD_ROOT
  125. mkdir ./bin
  126. mv ./usr/bin/bash ./bin/bash
  127. ln -s bash ./bin/sh
  128. rm -f .%{_infodir}/dir
  129. popd
  130. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  131. # make manpages for bash builtins as per suggestion in DOC/README
  132. pushd doc
  133. sed -e '
  134. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  135. /^\.SH NAME/d
  136. s/^bash, //
  137. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  138. s/,//g
  139. b
  140. }
  141. d
  142. ' builtins.1 > man.pages
  143. for i in echo pwd test kill; do
  144. perl -pi -e "s,$i,,g" man.pages
  145. perl -pi -e "s, , ,g" man.pages
  146. done
  147. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  148. for i in `cat man.pages` ; do
  149. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  150. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  151. done
  152. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  153. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  154. # Not for printf, false and true (conflict with coreutils)
  155. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  156. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  157. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  158. popd
  159. %find_lang %{name}
  160. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  161. %clean
  162. rm -rf %{buildroot}
  163. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  164. # to prevent prereq loops
  165. # post is in lua so that we can run it without any external deps. Helps
  166. # for bootstrapping a new install.
  167. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  168. %post -p <lua>
  169. bashfound = false;
  170. shfound = false;
  171. f = io.open("/etc/shells", "r");
  172. if f == nil
  173. then
  174. f = io.open("/etc/shells", "w");
  175. else
  176. repeat
  177. t = f:read();
  178. if t == "/bin/bash"
  179. then
  180. bashfound = true;
  181. end
  182. if t == "/bin/sh"
  183. then
  184. shfound = true;
  185. end
  186. until t == nil;
  187. end
  188. f:close()
  189. f = io.open("/etc/shells", "a");
  190. if not bashfound
  191. then
  192. f:write("/bin/bash\n")
  193. end
  194. if not shfound
  195. then
  196. f:write("/bin/sh\n")
  197. end
  198. f:close()
  199. %files -f %{name}.lang
  200. %defattr(-,root,root)
  201. %license COPYING
  202. %doc CHANGES
  203. %doc examples
  204. %config(noreplace) /etc/bashrc
  205. /bin/bash
  206. /bin/sh
  207. %{_infodir}/bash.info*
  208. %{_mandir}/*/*
  209. %{_mandir}/*/..1*
  210. %{_bindir}/bashbug
  211. %files doc
  212. %defattr(-,root,root)
  213. %doc COMPAT NEWS NOTES POSIX RBASH
  214. %doc examples/functions/ examples/misc/
  215. %doc examples/scripts*/
  216. %doc examples/startup-files/ examples/complete/ examples/loadables/
  217. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  218. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  219. %changelog
  220. * Mon Jun 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.26-1
  221. - updated to 5.2 patch level 26.
  222. * Thu Jan 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.15-1
  223. - updated to 5.2 patch level 15.
  224. * Sun Nov 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.2-1
  225. - updated to 5.2 patch level 2.
  226. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.16-1
  227. - updated to 5.1 patch level 16.
  228. * Wed Dec 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.12-1
  229. - updated to 5.1 patch level 12.
  230. * Thu Sep 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.8-1
  231. - updated to 5.1 patch level 8.
  232. - updated patches.
  233. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.18-1
  234. - updated to 5.0 patch level 18.
  235. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  236. - updated to 5.0 patch level 16.
  237. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
  238. - updated to 5.0 patch level 11.
  239. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  240. - updated to 5.0 patch level 9.
  241. - dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
  242. - imported Patch140 from rawhide.
  243. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
  244. - updated to 4.3 patch level 46.
  245. * Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
  246. - updated to 4.3 patch level 42.
  247. - imported patch 128-139 from RawHide.
  248. * Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
  249. - updated to 4.3 patch level 29.
  250. - removed patch1000 (included in 4.3.26).
  251. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  252. - added patch1000 to fix CVE-2014-7169.
  253. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  254. - updated to 4.3 patch level 25.
  255. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  256. - update to 4.3 patch level 18
  257. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  258. - update to 4.3 patch level 11
  259. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  260. - update to 4.2 patch level 45
  261. - import some patch from fedora package (122-127)
  262. - patch122: Don't call malloc in signal handler
  263. - patch123: #799958, updated info about trap
  264. - patch124: #695656, block the signal and unblock it after the
  265. new handler is installed
  266. - patch125: Use unsigned type for size
  267. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  268. - patch126: #903833, Fix missing close(), fixes fd leaks
  269. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  270. - remove postun lua script because bash will be never uninstalled
  271. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  272. - update to 4.2 patch level 37
  273. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  274. - update to 4.2 patch level 20
  275. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  276. - update to 4.2 patch level 8
  277. - use lua script in post/postun
  278. - update patches from fedora
  279. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  280. - update to 4.1 patch level 7
  281. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  282. - check if /bin/grep exists on %%post script
  283. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  284. - rebuilt with gcc-4.4.3-3 on ppc
  285. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  286. - rebuilt with new toolchain
  287. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  288. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  289. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  290. - add Requires(post): grep
  291. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  292. - remove obsolete /bin/bash2 entry from /etc/shells
  293. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  294. - add Requires(post): ncurses (should be added by find-requires..)
  295. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  296. - add upstream patch (from 040 to 048)
  297. - build against ncurses-devel (libtinfo)
  298. - spec in utf-8
  299. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  300. - added upstream patch (from 026 to 039)
  301. - added Japanese summary
  302. - applied new versioning policy
  303. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  304. - rebuilt with libtermcap-devel
  305. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  306. - new upstream release
  307. - add upstream patch (from 001 to 025)
  308. - remove Provides: bash2
  309. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  310. - rebuilt with new toolchain
  311. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  312. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  313. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  314. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  315. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  316. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  317. - update to 2.05b
  318. - rebuild with new toolchains
  319. - add make check
  320. - add %postun script based on Fedora development
  321. - README file moved doc package
  322. - update Patch5 and Patch8 from Fedora development
  323. - change Patch6
  324. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  325. - add Patch11--39 from Fedora development 2.05b-36
  326. * Tim Waugh <twaugh@redhat.com>
  327. - Fix parameter expansion in multibyte locales (bug #112657).
  328. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  329. bug #110777).
  330. - Apply upstream patches (bug #109269 among others).
  331. - Fix bash.info (bug #83776).
  332. - Add bash205b-007 patch to fix bug #106876.
  333. - Avoid crashing on multibyte input when locale is set incorrectly
  334. (bug #74266).
  335. - LFS support (bug #103627).
  336. - Fix completion display when multibyte or control characters are to be
  337. shown (bug #90201).
  338. - Fix a warning message (bug #79629).
  339. - Don't build with AFS support (bug #86514).
  340. - Don't explicitly strip binaries (bug #85995).
  341. - Really fix bug #83331 for good.
  342. - Fix builtins.1.
  343. - Actually apply the patch (bug #83331).
  344. - Fix history/UTF-8 bug (bug #83331).
  345. - More tab-completion fixing (bug #72512).
  346. - Force pgrp synchronization (bug #81653).
  347. - Prevent prompt overwriting output (bug #74383).
  348. - Fix '-rbash' (bug #78455).
  349. - Add readline-init patch (bug #74925).
  350. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  351. - Ship '.' man page, which doesn't get picked up by glob.
  352. - Locale shell variables fix (bug #74701).
  353. * Elliot Lee <sopwith@redhat.com>
  354. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  355. cross compiles.
  356. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  357. - update to 2.05
  358. - add README.jpatch to %doc
  359. - remove patch4 (bash2): revert command name in man pages to "bash"
  360. - fix perl command to remove man pages conflict with sh-utils
  361. - remove section of config.h.in from patch0 to prevent remake of configure
  362. - change patch9: define in config-top.h to avoid conflict with patch100
  363. - remove patches 7, 10 & 101
  364. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  365. - made a link for man sh
  366. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  367. - added missing %%post and %%triggerpostun section
  368. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  369. - 2.04-1vl12
  370. - now bash2 is finally bash
  371. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  372. - build for Playstation2
  373. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  374. - 2.04-1vl10
  375. - Provides: bash = %%{version}
  376. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  377. - added Provides: bash
  378. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  379. - Obsoletes: bash
  380. - changed Copyright to License
  381. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  382. - 2.04-1vl7
  383. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  384. - corrected: bashrc-vine -> bashrc
  385. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  386. - combined bash-1.x and bash-2.x packages
  387. - added some patches from bash-2.04-13mdk
  388. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  389. - fix spec macros
  390. - added tests
  391. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  392. - build with gcc-2.95.3
  393. - partially used rpmmacros
  394. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  395. - minor bug fix in spec file
  396. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  397. - 2.04-1vl3
  398. - modified %install and %files section to handle compressed man page(s)
  399. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  400. - added pcomplete patch to fix complete if the candidate list is NULL.
  401. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  402. - updated to 2.04
  403. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  404. - Remove annoying ^H's from documentation
  405. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  406. - patch to detect what executables are required by a script.
  407. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  408. - auto rebuild in the new build environment (release 4)
  409. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  410. - strip binaries.
  411. - include bash-doc correctly.
  412. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  413. - fixed post/postun /etc/shells work.
  414. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  415. - updated again text in the spec file
  416. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  417. - updated text in spec file.
  418. - update to 2.03.
  419. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  420. - build it as bash2 instead of bash
  421. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  422. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  423. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  424. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  425. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  426. - patch for the arm
  427. - use $RPM_ARCH-redhat-linux as the build target
  428. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  429. - rewrite %pre, axe %postun (to avoid prereq loops)
  430. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  431. - resurrect for RH 6.0.
  432. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  433. - update to 2.02.1
  434. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  435. - Package for 5.2.
  436. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  437. - added POSIX.NOTES doc file
  438. - some extraneous doc files removed
  439. - minor .spec file changes
  440. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  441. - upgraded to version 2.02
  442. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  443. - glibc & signal patches no longer required
  444. - added documentation subpackage (doc)
  445. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  446. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  447. is based on a change made in bash 2.0. Should fix some early exit
  448. problems with suspends and fg.
  449. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  450. - added %clean
  451. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  452. - added comment explaining why install-info isn't used
  453. - added mips patch
  454. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  455. - added BuildRoot
  456. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  457. - built against glibc